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What is Computer? 
Computer is an advanced electronic device that takes raw data as input from the user and processes these 

data under the control of set of instructions (called program) and gives the result (output) and saves output 

for the future use. It can process both numerical and non-numerical (arithmetic and logical) calculations.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Block Diagram of Computer: 

                                  

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Input: This is the process of entering data and programs in to the computer system. You should know that 

computer is an electronic machine like any other machine which takes as inputs raw data and performs some 

processing giving out processed data. Therefore, the input unit takes data from us to the computer in an 

organized manner for processing. 

2. Storage: The process of saving data and instructions permanently is known as storage. Data has to be fed 

into the system before the actual processing starts. It is because the processing speed of Central Processing 

Unit (CPU) is so fast that the data has to be provided to CPU with the same speed. Therefore the data is first 

stored in the storage unit for faster access and processing. This storage unit or the primary storage of the 

computer system is designed to do the above functionality. It provides space for storing data and 

instructions. 

The storage unit performs the following major functions:  

• All data and instructions are stored here before and after processing.  
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• Intermediate results of processing are also stored here.  

3. Processing: The task of performing operations like arithmetic and logical operations is called processing. 

The Central Processing Unit (CPU) takes data and instructions from the storage unit and makes all sorts of 

calculations based on the instructions given and the type of data provided. It is then sent back to the storage 

unit.  

4. Output: This is the process of producing results from the data for getting useful information. Similarly 

the output produced by the computer after processing must also be kept somewhere inside the computer 

before being given to you in human readable form. Again the output is also stored inside the computer for 

further processing.  

5. Control: The manner how instructions are executed and the above operations are performed. Controlling 

of all operations like input, processing and output are performed by control unit. It takes care of step by step 

processing of all operations inside the computer. 

Functional Units:  
In order to carry out the operations mentioned in the previous section the computer allocates the task 

between its various functional units. The computer system is divided into three separate units for its 

operation. They are  

1) Arithmetic logical unit, 2) Control unit, 3) Central processing unit 

Arithmetic Logical Unit (ALU): After you enter data through the input device it is stored in the primary 

storage unit. The actual processing of the data and instruction are performed by Arithmetic Logical Unit. 

The major operations performed by the ALU are addition, subtraction, multiplication, division, logic and 

comparison. Data is transferred to ALU from storage unit when required. After processing the output is 

returned back to storage unit for further processing or getting stored.  

Control Unit (CU): The next component of computer is the Control Unit, which acts like the supervisor 

seeing that things are done in proper fashion. Control Unit is responsible for co-ordinating various 

operations using time signal. The control unit determines the sequence in which computer programs and 

instructions are executed. Things like processing of programs stored in the main memory, interpretation of 

the instructions and issuing of signals for other units of the computer to execute them. It also acts as a switch 

board operator when several users access the computer simultaneously. Thereby it coordinates the activities 

of computer’s peripheral equipment as they perform the input and output.  

Central Processing Unit (CPU): The ALU and the CU of a computer system are jointly known as the 

central processing unit. You may call CPU as the brain of any computer system. It is just like brain that 

takes all major decisions, makes all sorts of calculations and directs different parts of the computer functions 

by activating and controlling the operations. 

Basic characteristics about computer are: 
Speed: - As you know computer can work very fast. It takes only few seconds for calculations that we take 

hours to complete. You will be surprised to know that computer can perform millions (1,000,000) of 

instructions and even more per second. 

Accuracy: - The degree of accuracy of computer is very high and every calculation is performed with the 

same accuracy. The accuracy level is 7 

Diligence: - A computer is free from tiredness, lack of concentration, fatigue, etc. It can work for hours 

without creating any error. 

Limitation of Computer: 
a) No Self Intelligence 

b) No Decision-Making power 

c) No learning power 

Computer System:  
All of the components of a computer system can be summarized with the simple equations.  

COMPUTER SYSTEM = HARDWARE + SOFTWARE+ USER  

• Hardware = Internal Devices + Peripheral Devices  

All physical parts of the computer (or everything that we can touch) are known as Hardware.  
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• Software = Programs  

Software gives "intelligence" to the computer.  

• USER = Person, who operates computer. 

 
 

 

 

 

 

 

 

 

 

 

History of Computer: 
The following tables explain the Timeline of Progress of the Modern Computer: 

Timelines of Ancient Electronics Devices 

Time Period Name Details Picture 

3000 BC Abacus  beads on rods to count and 

calculate 

 Still widely used in Asia! 

  

1630 Slide Rule  based on Napier’s rules for 

logarithms 

 used until 1970s 

 
19th 

Century  

Jacquard Loom  Used metal cards with punched 

holes to guide weaving process 

 First stored program - metal cards 

 First computer manufacturing 

 Still in use today! 
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Timelines of Ancient Electronics Devices 

Time Period Name Details Picture 

1822 Difference 

Engine 
 Huge calculator, never finished  

1833 Analytical 

Engine 
 Could store numbers 

 Calculating "mill" used punched 

metal cards for instructions 

 Powered by steam! 

 Accurate to six decimal places 

 

 
Timelines of Modern Computer 

Time Period Name Details Picture 

1975 MITS Altair  256 byte memory 

 2 MHz Intel 8080 chips 

 Just a box with flashing lights 

 Cost $395 kit, $495 assembled. 

 
1977 Apple 

Computers 
 Founded 1977 

 Apple II released 1977  - widely 

used in schools 

 Macintosh (left) - released in 1984, 

Motorola 68000 Microchip 

processor (below) 

 Macintosh is first commercial 

computer with graphical user 

interface (GUI) and pointing device 

(mouse) 
 

1981 IBM PC  IBM-Intel-Microsoft joint venture 

 First wide-selling personal 

computer used in business 

 8088 Microchip - 29,000 transistors 

 4.77 Mhz processing speed 

 256 K RAM (Random Access 

Memory) standard 

 One or two floppy disk drives 
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Timelines of Modern Computer 

Time Period Name Details Picture 

1984 Motorola 

68000  
 RAM memory 64KB 

 Speed 8 MHz 

 It has one floppy drive 

 
1990 Pentiums and 

Power Macs 
 Early 1990s began penetration of 

computers into every niche: every 

desk, most homes, etc. 

 Faster, less expensive computers 

paved way for this 

 Windows 95 was first decent GUI 

for "PCs" 

 Macs became more PC compatible - 

easy file transfers 

 Prices have plummeted 

 

Generation of Computer: 
Genera

tion 

Time 

Period 

Advantages Disadvantages Example 

1st 1942-1955  Vacuum tubes were the 

only electronic component 

available during those 

days. 

 Vacuum tube technology 

made possible to make 

electronic digital 

computers. 

 These computers could 

calculate data in 

millisecond. 

 The computers were very 

large in size. 

 They consumed a large 

amount of energy. 

 They heated very soon due 

to thousands of vacuum 

tubes. 

 They were not very reliable. 

 Constant maintenance was 

required. 

 Costly commercial 

production. 

 Limited commercial use. 

 Very slow speed. 

 ENIVAC 

 UNIVAC-1 

2nd 1955-1964 

 
 Smaller in size as 

compared to the first 

generation computers. 

 The 2nd generation 

Computers were more 

reliable 

 Used less energy and were 

not heated. 

 Wider commercial use 

 Better portability as 

compared to the first 

generation computers. 

 Cooling system was 

required 

 Constant maintenance was 

required 

 Commercial production was 

difficult 

 Only used for specific 

purposes 

 Costly and not versatile 

 Punch cards were used for 

input. 

 

 IBM 7094 

series  

 IBM 1400 

series 
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Genera

tion 

Time 

Period 

Advantages Disadvantages Example 

 Better speed and could 

calculate data in 

microseconds 

 Used faster peripherals like 

tape drives, magnetic disks, 

printer etc. 

 Used Assembly language 

instead of Machine 

language. 

3rd 1964-1975 

 
 Smaller in size as 

compared to previous 

generations. 

 More reliable. 

 Used less energy 

 Produced less heat as 

compared to the previous 

two generations of 

computers. 

 Better speed and could 

calculate data in 

nanoseconds. 

 Used fan for heat discharge 

to prevent damage. 

 Maintenance cost was low 

because hardware failure is 

reare. 

 Air conditioning was 

required. 

 Highly sophisticated 

technology required for the 

manufacturing of IC chips. 

 

 IBM 

System/360 

 UNIVAC 

1108 

4th 1975-

Present 

 

 More powerful and reliable 

than previous generations. 

 Small in size 

 Fast processing power with 

less power consumption 

 Fan for heat discharging 

and thus to keep cold. 

 No air conditioning 

required. 

 Totally general purpose 

 Commercial production 

 Less need of repairing. 

 Cheapest among all 

generations 

 All types of High level 

languages can be used in 

this type of computers 

 The latest technology is 

required for manufacturing 

of Microprocessors. 

 

 Apple 

Macintosh 

 IBM PC 

5th Present & 

Beyond 

[Under 

Researchab

 It is based on the technique 

of Artificial Intelligence 

(AI).  

 Computers can understand 

 Human more idle due to 

depends very much to 

computer 

 IBM 

Watson 
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Genera

tion 

Time 

Period 

Advantages Disadvantages Example 

le] spoken words & imitate 

human reasoning. Can 

respond to its surroundings 

using different types of 

sensors. 

Hardware of Computer: 
 Input Devices collect & translate raw data into form useable by computer. e.g  keyboard accepts letters 

and numbers and converts them to a binary code such as Unicode.  

 Output devices produce results in useable form for user (or another device). e.g.  monitor converts 

binary codes to characters and images, whilst modem converts digital data to analog form for 

transmission over telephone lines. 

 

1 Input Devices 

Mouse      

Keyboard 

 

 

2 Output Devices 

Monitor (VDU)    

Printer 

  

 

3 Secondary Storage Devices 

Hard Disk 

CD / DVD / Floppy 

 

Software of Computer: 

Software:  
Software, simply are the computer programs. The instructions given to the computer in the form of a 

program is called Software. Software is the set of programs, which are used for different purposes. All the 

programs used in computer to perform specific task is called Software.  

Types of software:  

1. System software:  

a) Operating System Software  

DOS, Windows XP, Windows Vista, Unix/Linux, MAC/OS X etc.  

b) Utility Software  

Windows Explorer (File/Folder Management), Windows Media Player, Anti-Virus Utilities, 

Disk Defragmentation, Disk Clean, BackUp, WinZip, WinRAR etc. 

2. Application software:  

a) Package Software:  

Ms. Office 2003, Ms. Office 2007, Macromedia (Dreamweaver, Flash, Freehand), Adobe 

(PageMaker, Photoshop)  

b) Tailored or Custom Software:  

SAGE (Accounting), Galileo/Worldspan (Travel) etc.  

3. Computer Languages & Scripting:  

a) Low Level Language  

i) Machine Level Language  

ii) Assembly Language 
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b) High Level Language  

COBOL (COmmon Business Oriented Language), FORTRAN (FORmula TRANslation), 

BASIC (Beginner's All-purpose Symbolic Instruction Code), C, C++ etc. are the examples of 

High Level Language. 

 

Types of Computer  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

On the basis of Size  
a) Super Computer  

The fastest type of computer. Supercomputers are very expensive and are 

employed for specialized applications that require immense amounts of 

mathematical calculations. For example, weather forecasting requires a 

supercomputer. Other uses of supercomputers include animated graphics, fluid 

dynamic calculations, nuclear energy research, and petroleum exploration. 

b) Mainframe Computer  

A very large and expensive computer capable of supporting hundreds, or even 

thousands, of users simultaneously. In the hierarchy that starts with a simple 

microprocessor (in watches, for example) at the bottom and moves to 

supercomputers at the top, mainframes are just below supercomputers. In some 

ways, mainframes are more powerful than supercomputers because they support 

more simultaneous programs. But supercomputers can execute a single program 

faster than a mainframe. 

 

c) Mini Computer  

A midsized computer. In size and power, minicomputers lie between 

workstations and mainframes. In the past decade, the distinction between large 

minicomputers and small mainframes has blurred, however, as has the 

distinction between small minicomputers and workstations. But in general, a 

minicomputer is a multiprocessing system capable of supporting from 4 to 

about 200 users simultaneously. 

d) Micro Computer  

i. Desktop Computer: a personal or micro-mini computer sufficient to fit on a desk.  

ii. Laptop Computer: a portable computer complete with an integrated screen and keyboard. It is generally 

smaller in size than a desktop computer and larger than a notebook computer.  
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iii. Palmtop Computer/Digital Diary /Notebook /PDAs: a hand-sized computer. Palmtops have no keyboard 

but the screen serves both as an input and output device.  

 

 

 

 

 

 

 

 

 

 

e) Workstations  

A terminal or desktop computer in a network. In this context, workstation is just a generic term for a user's 

machine (client machine) in contrast to a "server" or "mainframe."  

 
  

 

 

 

 

 

 

 

 

 

 

***** End of Class1 ***** 

 

 

Desktop Laptop Palmtop PDA 
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Keyboard Finger Setting 

Keyboard Layout 

Input Device 

Input device categorization: 

1) Online input devices/Direct line entry devices: On line input devices are those devices which are 

directly connected to computer example keyboard, mouse etc. 

2) Offline input devices/Source entry devices: Offline input devices are those devices which are not 

directly connected to computer example scanning device. 

Types of common input devices: 

1)Keyboard: Keyboard is a well-known input 

device which contains alphabets, numeric/digits, 

special keys, function keys etc. Keyboard can be of 

serial or parallel. 

Alphabets:- A to Z, a to z 

Numeric key:-0 to 9 

Special keys:-shift, spacebar, ctr, alt etc. 

Functions key:-F1, F2.....F12. 

Keyboard is used to convert these above mention keys into 

digital form of computer. 
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Mouse 

Buttons 

2) Mouse: Mouse is an input device which is 

also called a pointing device. It is used to move 

the cursor on the screen. Mouse works in GUI 

(Graphical User Interface) mode. Mouse is of 

different-2 types in which some are physical 

mouse, optical mouse, and cordless mouse. 

 

 

 

 

 

 

 

 

3) Scanner: A scanner is an input device that scans documents such as 

photographs and pages of text. When a document is scanned, it is converted into a 

digital format. This creates an electronic version of the document that can be 

viewed and edited on a computer. 

Most scanners are flatbed devices, which mean they have a flat scanning surface. 

This is ideal for photographs, magazines, and various documents. 

 

 

 

 

4) Bar-Code Reader: A barcode reader, also called a price scanner or point-of-sale ( POS ) scanner, is a 

hand-held or stationary input device used to capture and read information contained in a bar code . A 

barcode reader consists of a scanner, a decoder (either built-in or external), and a cable used to connect the 

reader with a computer. Because a barcode reader merely captures and translates the barcode into numbers 

and/or letters, the data must be sent to a computer so that a software application can make sense of the data. 

 

 

 

 

 

 

Mouse 

Handling 

Mouse 

Mouse 

Pointer 
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5) OMR: Short for optical mark recognition, the technology of electronically extracting intended data from 

marked fields, such as checkboxes and fill-infields, on printed forms. OMR technology scans a printed form 

and reads predefined positions and records where marks are made on the form. This technology is useful for 

applications in which large numbers of hand-filled forms need to be processed quickly and with great 

accuracy, such as surveys, reply cards, questionnaires and ballots. A common OMR application is the use of 

"bubble sheets" for multiple-choice tests used by schools. The student indicates the answer on the test by 

filling in the corresponding bubble, and the form is fed through an optical mark reader 

 

 

 

 

 

 

 

 

 

 

 

 

6) Joystick: A joystick is an input device commonly used to control video games. Joysticks consist of a base 

and a stick that can be moved in any direction. The stick can be moved slowly or quickly and in different 

amounts. Some joysticks have sticks that can also be rotated to the left or right. Because of the flexible 

movements a joystick allows, it can provide much greater control than the keys on a keyboard. 
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7) Microphone: Microphone is an input device to input sound that is then stored in digital form. The 

microphone is used for various applications like adding sound to a multimedia presentation or for mixing 

music. 

  

 

 

 

 

8) Webcam: Webcam is a small camera that is either plugged into the computer or built into the top of the 

monitor. It captures images and inputs them into the computer system  

 

 

 

 

 

 

Output Device 
An output device is any device used to send data from a computer to another device or user. Most computer 

data output that is meant for humans is in the form of audio or video. Thus, most output devices used by 

humans are in these categories. Examples include monitors, projectors, speakers, headphones and printers. 

Types of common Output devices: 

 

 

 

 

 

 

 

 

 

 

Webcam 



RRKKMMSSWWSS  

Input & Output Devices, Software & Classification, Memory types & Organization, Number System, Bit, 

Byte, Word, BCD, ASCII, Unicode, Binary-Decimal & Decimal-Binary Conversion 

 

5 

 

1) Monitor: The device which displays computer output. The monitor displays the video and graphics 

information generated by the computer through the video card. Monitors are very similar to televisions but 

usually display information at a much higher resolution. 

Types of Monitor 

•Cathode Ray Tube (CRT) 

•Liquid Crystal Display (LCD) 

•Light-emitting Diode (LED) 

CRT Monitors: 

CRT stands for Cathode Ray Tube. These are all old model 

monitors. Main disadvantages are heavy weight, occupy more 

place, high power consumption, high radiation and supports low 

resolution. These are all main reasons to prefer LCD or LED 

monitors. 

 

LCD Monitors: 

LCD stands for Liquid Crystal Display. The main advantage of 

LCDs are light weigh, occupy less place, 12v power 

consumption, low radiation and supports high resolutions.  

 

 

LED Monitors: 

LED stands for Light Emitting Diode. Actually there are no 

differences between LCD and LED monitors, but better picture 

quality in LED monitors. So now all are prefer LED monitors 

than LCD monitors.       

 

 

2) Printer: A printer is an electromechanical device which converts the text and graphical documents from 

electronic form to the physical form. Generally they are the external peripheral devices which are connected 

with the computers or laptops through a cable or wirelessly to receive input data and print them on the 

papers. A wide range of printers are available with a variety of features ranging from printing black and 

white text documents to high quality colored graphic images. 

 

 

 

 

 

 

 

 

Impact Printers: In this hammers or pins strike against a ribbon and paper to print the text. This mechanism 

is known as electro-mechanical mechanism. They are of two types. 

(i) Character Printer  

(ii) Line Printer  
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Character Printer: It prints only one character at a time. It has relatively slower speed. Eg. Of them are Dot 

matrix printers.  

Dot Matrix Printer: It prints characters as combination of dots. Dot 

matrix printers are the most popular among serial printers. These have a 

matrix of pins on the print head of the printer which form the character. 

The computer memory sends one character at a time to be printed by the 

printer. There is a carbon between the pins & the paper. The words get 

printed on the paper when the pin strikes the carbon. There are generally 

24 pins.  

 

 

 

Laser Printer is a type of printer that utilizes a laser beam to produce an 

image on a drum. The light of the laser alters the electrical charge on the 

drum wherever it hits. The drum is then rolled through a reservoir of toner, 

which is picked up by the charged portions of the drum. Finally, the toner 

is transferred to the paper through a combination of heat and pressure.  

 

 

 

 

 

Non-Impact Printers: There printers use non-Impact technology such as 

ink-jet or laser technology. There printers provide better quality of O/P at 

higher speed. These printers are of two types:  

Ink-Jet Printer: It prints characters by spraying patterns of ink on the paper 

from a nozzle or jet. It prints from nozzles having very fine holes, from 

which a specially made ink is pumped out to create various letters and 

shapes. The ink comes out of the nozzle in a form of vapors. After passing 

through a reflecting plate, it forms the desired letter/shape at the desired 

place. 

 

 

 

Other Types of Printers 
Photo Printer – Is a type of printer use for printing photographs. 
 
 
 
 
  

Dye-Sublimation Printer – Is a type of printer which employs a printing process 

that uses heat to transfer dye to a medium such as a plastic card, printer paper or 

poster paper. 

 

  

 

Thermal Printer- Is a type of printer that produces a printed image by 

selectively heating coated thermo chromic paper, or thermal paper as it is 
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commonly known, when the paper passes over the thermal print head. The coating turns black in the areas 

where it is heated which then produce an image. 

All-in-One Printer - A printer than can also do scanning, fax and make copies 

 

  

Plotter - A large device use to print large posters and documents 

 

3D Printer - Prints 3D objects 

 

Wireless Printer (WiFi, Bluetooth and Infrared) 

 

 

3) Speaker: Speakers are popular output devices used with computer systems. They receive audio input 

from the computer's sound card and produce audio output in the form of sound waves. Most computer 

speakers are active speakers, meaning they have an internal amplifier which allows you to increase the 

volume, or amplitude, of the sound. Speakers usually come in pairs, which allow them to produce stereo 

sound from two separate audio channels. 

 

 

 

 

 

 

 

4) Digital Projector: A digital projector is a device which connects 

to a computer and is used to project the video output from the 

computer onto a wall or screen. In classrooms they are often used 

with electronic whiteboards. The projector can be portable and 

placed on a stand or it can be permanently fixed to the ceiling. 

                

 

 

Speaker 
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Software 
Definition: Software consists of carefully-organized instructions and code written by programmers in any of 

various special computer languages. Software is divided commonly into two main categories: (1) System 

software: controls the basic (and invisible to the user) functions of a computer and comes usually 

preinstalled with the machine. See also BIOS and Operating System. (2) Application software: handles 

multitudes of common and specialized tasks a user wants to perform, such as accounting, communicating, 

data processing, word processing. 

Classification of Software:  

 

 

 

 

 

Operating Systems: The operating system is the software that allows you to operate the hardware. The 

programs that we want to execute, the applications that we want to use all 

require a platform on which to execute. That platform is provided by the 

operating system. 

One role of the operating system is to provide a virtual machine. This refers to 

the way that, by clicking on icons and menus, or by typing in commands at a 

prompt, we get to interact with the computer hardware without having to 

understand its complexity. By hiding the true complexity of the system from the 

user, the operating system makes it easier for ordinary people to make computers perform useful 

tasks. 

Example: Windows 7, Linux Ubuntu etc. 

Utility Programs: Some utility programs are bundled in with operating system software 

these days. Others you buy or source in some other way. 

Utility programs tend to perform specific tasks related to the management of hardware. 

Examples of utility programs include compression programs, formatters, defragmenters and 

other disk management tools. 

Example: Anti-Virus Utilities, Disk Defragmentation, Disk Clean, BackUp, WinZip, 

WinRAR etc 

Library Programs: Library programs are compiled libraries of commonly-used routines. On a Windows 

system they usually carry the file extension dll and are often referred to as run-time libraries. The libraries 

are run-time because they are called upon by running programs when they are needed. When you program 

using a run-time library, you typically add a reference to it either in your code or through the IDE in which 

you are programming. 

Language Translators: Whatever language or type of language we use to write our 

programs, they need to be in machine code in order to be executed by the computer. There 

are 3 main categories of translator used, 

Assembler: An assembler is a program that translates the mnemonic codes used in assembly 

language into the bit patterns that represent machine operations. Assembly language has a one-

to-one equivalence with machine code, each assembly statement can be converted into a single machine 

operation. 

Compiler: A compiler turns the source code that you write in a high-level language into object 

code (machine code) that can be executed by the computer. The compiler is a more complex 

beast than the assembler. It may require several machine operations to represent a single high-

level language statement. As a result, compiling may well be a lengthy process with very large programs. 
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Interpreter: Interpreters translate the source code at run-time. The interpreter translates statements one-at-a-

time as the program is executed. 

Interpreters are often used to execute high-level language programs whilst they are being developed since 

this can be quicker than compiling the entire program. The program would be compiled when it is complete 

and ready to be released. 

Interpreters are also used with high-level scripting languages like PHP, Javascript and many more. These 

instructions are not compiled and have to be interpreted either by the browser (in the case of Javascript) or 

by interpreters on the server (in the case of PHP). 

 

 

 

 

 

 

 

 

 

Application Software: Application software tends be used for the tasks that have some relationship to the 

world outside of the computer. For example, you might use a word processor to write a letter or an essay. 

Although you use the computer to perform the task, the task itself might reasonably be considered to be a 

non-computer task. 

General-Purpose Software: Software is general-purpose if it can be used for lots of different tasks. You 

can use a word processor to write letters, memos, essays, instructions, notes, faxes, invoices and lots more. 

These days we tend to use integrate suites of office software where a range of general-purpose software is 

provided, usually with the facility to combine elements from each application in a single file. 

Example: M.S.Word, Open Ofiice etc. 

Special-Purpose Software This software performs a single specific task. This task might be complex like 

payroll calculation, stock control etc. but will be based on a single task. 

As with many abstract concepts, you can stretch these definitions until they blur a little. These days, web 

browsers can contain a lot of features. They are still primarily focused on a single task, rendering web pages 

and so the web browser is special-purpose. Being able to access an application using a browser does not 

change the main purpose of the browser software itself. 

Bespoke Software Bespoke software is written for a single client. Large organizations have a need for well-

developed applications suited to their specific needs. Such software is often expensive to develop since the 

development costs are not shared among a large number of people purchasing the software. 

Memory 
Memory is an essential element of a computer. Without its memory, a computer is of hardly any use. 

Memory plays an important role in saving and retrieving data. The performance of the computer system 

depends upon the size of the memory.  
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Memory is of following types: 

1. Primary Memory / Volatile Memory. 

2. Secondary Memory / Non Volatile Memory. 
1. Primary Memory / Volatile Memory: Primary Memory is internal memory of the computer. RAM 

AND ROM both form part of primary memory. The primary memory provides main working space to the 

computer. The following terms comes under primary memory of a computer are discussed below: 

 Random Access Memory (RAM): The primary storage is referred to as random access memory (RAM) 

because it is possible to randomly select and use any location of the memory directly store and retrieve 

data. It takes same time to any address of the memory as the first address. It is also called read/write 

memory. The storage of data and instructions inside the primary storage is temporary. It disappears from 

RAM as soon as the power to the computer is switched off. The 

memories, which lose their content on failure of power supply, are 

known as volatile memories .So now we can say that RAM is 

volatile memory. 

 Read Only Memory (ROM): There is another memory in computer, 

which is called Read Only Memory (ROM). Again it is the ICs inside 

the PC that form the ROM. The storage of program and data in the 

ROM is permanent. The ROM stores some standard processing 

programs supplied by the manufacturers to operate the personal 

computer. The ROM can only be read by the CPU but it cannot be 

changed. The basic input/output program is stored in the ROM that 
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examines and initializes various equipment attached to the PC when the power switch is ON. The 

memories, which do not lose their content on failure of power supply, are known as non-volatile 

memories. ROM is non-volatile memory. 

 PROM: There is another type of primary memory in computer, which is called Programmable Read 

Only Memory (PROM). You know that it is not possible to modify or erase programs stored in ROM, 

but it is possible for you to store your program in PROM chip. Once the programmers’ are written it 

cannot be changed and remain intact even if power is switched off. Therefore programs or instructions 

written in PROM or ROM cannot be erased or changed. 

 EPROM: This stands for Erasable Programmable Read Only Memory, which overcome the problem of 

PROM & ROM. EPROM chip can be programmed time and again by erasing the information stored 

earlier in it. Information stored in EPROM exposing the chip for some time ultraviolet light and it erases 

chip is reprogrammed using a special programming facility. When the EPROM is in use information can 

only be read. 

 Cache Memory: The speed of CPU is extremely high compared to the access time of main memory. 

Therefore the performance of CPU decreases due to the slow speed of main memory. To decrease the 

mismatch in operating speed, a small memory chip is attached between CPU and Main memory whose 

access time is very close to the processing speed of CPU. It is called CACHE memory. CACHE 

memories are accessed much faster than conventional RAM. It is used to store programs or data 

currently being executed or temporary data frequently used by the CPU. So each memory makes main 

memory to be faster and larger than it really is. It is also very expensive to have bigger size of cache 

memory and its size is normally kept small. 

 Registers: The CPU processes data and instructions with high speed; there is also movement of data 

between various units of computer. It is necessary to transfer the processed data with high speed. So the 

computer uses a number of special memory units called registers. They are not part of the main memory 

but they store data or information temporarily and pass it on as directed by the control unit. 

2. Secondary Memory / Non-Volatile Memory:  Secondary memory is external and permanent in nature. 

The secondary memory is concerned with magnetic memory. Secondary memory can be stored on storage 

media like floppy disks, magnetic disks, magnetic tapes, This memory can also be stored optically on 

Optical disks - CD-ROM. The following terms comes under secondary memory of a computer are discussed 

below: 

 Magnetic Tape: Magnetic tapes are used for large computers like mainframe 

computers where large volume of data is stored for a longer time. In PC also 

you can use tapes in the form of cassettes. The cost of storing data in tapes is 

inexpensive. Tapes consist of magnetic materials that store data permanently. It 

can be 12.5 mm to 25 mm wide plastic film-type and 500 meter to 1200 meter 

long which is coated with magnetic material. The deck is connected to the 

central processor and information is fed into or read from the tape through the 

processor. It’s similar to cassette tape recorder. 

 Magnetic Disk: You might have seen the gramophone record, which is circular like a disk and 

coated with magnetic material. Magnetic disks used in computer are made on the same principle. It 

rotates with very high speed inside the computer drive. Data is stored on both the surface of the disk. 

Magnetic disks are most popular for direct access storage device. 

Each disk consists of a number of invisible concentric circles called 

tracks. Information is recorded on tracks of a disk surface in the form 

of tiny magnetic spots. The presence of a magnetic spot represents 

one bit and its absence represents zero bit. The information stored in 

a disk can be read many times without affecting the stored data. So 

the reading operation is non-destructive. But if you want to write a 

new data, then the existing data is erased from the disk and new data is recorded.  For Example-

Floppy Disk. 
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 Optical Disk: With every new application and software there is greater 

demand for memory capacity. It is the necessity to store large volume of 

data that has led to the development of optical disk storage medium. 

Optical disks can be divided into the following categories:  

1. Compact Disk/ Read Only Memory (CD-ROM 

2. Write Once, Read Many (WORM) 

3. Erasable Optical Disk 

Memory Unit: 

 It is the amount of data that can be stored in the storage unit. 

 The storage capacity are expressed in terms of Bytes. 

Following are the main memory storage units: 

Sl. Unit Description 

1 Bit 
A binary digit is logical 0 & 1 representing a passive or an active state of a component in an 

electric circuit. 

2 Nibble A group of 4 bits is called nibble. 

3 Byte 
A group of 8 bits is called byte. A byte is the smallest unit which can represent a data item or a 

character. 

4 Word 
A computer word like a byte, is a group of fixed number of bits processed as a unit which varies 

from computer but is fixed for each computer.  

Few higher storage units are following 

Sr. No. Unit Description 

1 Kilobyte (KB)  1 KB = 1024 Bytes 

2 Megabyte (MB)  1 MB = 1024 KB 

3 GigaByte (GB)  1 GB = 1024 MB 

4 TeraByte (TB) 1 TB = 1024 GB 

5 PetaByte (PB)  1 PB = 1024 TB 

Number System: When we type some letters or words, the computer translates them in numbers as 

computers can understand only numbers. A computer can understand positional number system where there 

are only a few symbols called digits and these symbols represent different values depending on the position 

they occupy in the number. 

A value of each digit in a number can be determined using 

 The digit 

 The position of the digit in the number 

 The base of the number system (where base is defined as the total number of digits available in the 

number system). 

Decimal Number System: The number system that we use in our day-to-day life is the decimal number 

system. Decimal number system has base 10 as it uses 10 digits from 0 to 9. In decimal number system, the 

successive positions to the left of the decimal point represent units, tens, hundreds, thousands and so on. 

Each position represents a specific power of the base (10). For example, the decimal number 1234 consists 

of the digit 4 in the units position, 3 in the tens position, 2 in the hundreds position, and 1 in the thousands 

position, and its value can be written as 
(1x1000)+ (2x100)+ (3x10)+ (4xl) 

(1x10
3
)+ (2x10

2
)+ (3x10

1
)+ (4xl0

0
) 

1000 + 200 + 30 + 4 

1234 
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Binary Number System: 

Characteristics of binary number system are as follows: 

 Uses two digits, 0 and 1. 

 Also called base 2 number system 

 Each position in a binary number represents a 0 power of the base (2). Example 2
0
 

 Last position in a binary number represents a x power of the base (2). Example 2
x
 where x represents 

the last position - 1. 

Example 
Binary Number: 101012 

Calculating Decimal Equivalent: 

Step Binary Number Decimal Number 

Step 1 101012 ((1 x 24) + (0 x 23) + (1 x 22) + (0 x 21) + (1 x 20))10 

Step 2 101012 (16 + 0 + 4 + 0 + 1)10 

Step 3 101012 2110 

Note : 101012 is normally written as 10101. 

 

Binary to Decimal Number System Conversion: 

 1. Write down the binary number and list the powers of 2 from right to left. Let's say we want to 

convert the binary number 100110112 to decimal. First, write it down. Then, write down the powers 

of two from right to left. Start at 20, evaluating it as "1". Increment the exponent by one for each 

power. Stop when the amount of elements in the list is equal to the amount of digits in the binary 

number. The example number, 10011011, has eight digits, so the list, with eight elements, would 

look like this: 128, 64, 32, 16, 8, 4, 2, 1  

 

 2 Write the digits of the binary number below their corresponding powers of two. Now, just write 

10011011 below the numbers 128, 64, 32, 16, 8, 4, 2, and 1 so that each binary digit corresponds 

with its power of two. The "1" to the right of the binary number should correspond with the "1" on 

the right of the listed powers of two, and so on. You can also write the binary digits above the 

powers of two, if you prefer it that way. What's important is that they match up. 
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 3 Connect the digits in the binary number with their corresponding powers of two. Draw lines, 

starting from the right, connecting each consecutive digit of the binary number to the power of two 

that is next in the list above it. Begin by drawing a line from the first digit of the binary number to 

the first power of two in the list above it. Then, draw a line from the second digit of the binary 

number to the second power of two in the list. Continue connecting each digit with its corresponding 

power of two. This will help you visually see the relationship between the two sets of numbers. 

 

 4 Write down the final value of each power of two. Move through each digit of the binary number. If 

the digit is a 1, write its corresponding power of two below the line, under the digit. If the digit is a 0, 

write a 0 below the line, under the digit.  

 Since "1" corresponds with "1", it becomes a "1." Since "2" corresponds with "1," it becomes a "2." 

Since "4" corresponds with "0," it becomes "0." Since "8" corresponds with "1", it becomes "8," and 

since "16" corresponds with "1" it becomes "16." "32" corresponds with "0" and becomes "0" and 

"64" corresponds with "0" and therefore becomes "0" while "128" corresponds with "1" and becomes 

128. 

  

 5 Add the final values. Now, add up the numbers written below the line. Here's what you do: 128 + 0 

+ 0 + 16 + 8 + 0 + 2 + 1 = 155. This is the decimal equivalent of the binary number 10011011. 
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  6 Write the answer along with its base subscript. Now, all you have to do is write 15510, to show that 

you are working with a decimal answer, which must be operating in powers of 10. The more you get used to 

converting from binary to decimal, the more easy it will be for you to memorize the powers of two, and 

you'll be able to complete the task more quickly.  

  7 Use this method to convert a binary number with a decimal point to decimal form. You can use 

this method even when you want to covert a binary number such as 1.12 to decimal. All you have to do is 

know that the number on the left side of the decimal is in the units position, like normal, while the number 

on the right side of the decimal is in the "halves" position, or 1 x (1/2).  

 The "1" to the left of the decimal point is equal to 20, or 1. The 1 to the right of the decimal is equal 

to 2-1, or .5. Add up 1 and .5 and you get 1.5, which is 1.12 in decimal notation. 

Decimal to Binary Number System Conversion: 

1 Set up the problem. For this example, let's convert the decimal number 15610 to binary. Write the decimal 

number as the dividend inside an upside-down "long division" symbol. Write the base of the destination 

system (in our case, "2" for binary) as the divisor outside the curve of the division symbol.  

 This method is much easier to understand when visualized on paper, and is much easier for 

beginners, as it relies only on division by two. 

 To avoid confusion before and after conversion, write the number of the base system that you are 

working with as a subscript of each number. In this case, the decimal number will have a subscript of 

10 and the binary equivalent will have a subscript of 2. 

2  Divide. Write the integer answer (quotient) under the long division symbol, and write the remainder (0 or 

1) to the right of the dividend. 
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 Since we are dividing by 2, when the dividend is even the binary remainder will be 0, and when the 

dividend is odd the binary remainder will be 1. 

   
3 Continue to divide until you reach 0. Continue downwards, dividing each new quotient by two and writing 

the remainders to the right of each dividend. Stop when the quotient is 0.  

 



RRKKMMSSWWSS  

Input & Output Devices, Software & Classification, Memory types & Organization, Number System, Bit, 

Byte, Word, BCD, ASCII, Unicode, Binary-Decimal & Decimal-Binary Conversion 

 

17 

 

  4 Write out the new, binary number. Starting with the bottom remainder, read the sequence of 

remainders upwards to the top. For this example, you should have 10011100. This is the binary equivalent of 

the decimal number 156. Or, written with base subscripts: 15610 = 100111002  

 This method can be modified to convert from decimal to any base. The divisor is 2 because the 

desired destination is base 2 (binary). If the desired destination is a different base, replace the 2 in the 

method with the desired base. For example, if the desired destination is base 9, replace the 2 with 9. 

The final result will then be in the desired base. 

End of Class2 
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Windows 7 Interface:  
Unlike its predecessor, Windows Vista, which introduced a large number of new features, Windows 7 was 

intended to be a more focused, incremental upgrade to the Windows line, with the goal of being compatible 

with applications and hardware with which Windows Vista was not at the time. Presentations given by 

Microsoft in 2008 focused on multi-touch support, a redesigned Windows shell with a new taskbar, referred 

to as the Superbar, a home networking system called HomeGroup, and performance improvements. Some 

standard applications that have been included with prior releases of Microsoft Windows, including Windows 

Calendar, Windows Mail, Windows Movie Maker, and Windows Photo Gallery, are not included in 

Windows 7; most are instead offered separately at no charge as part of the Windows Live Essentials suite. 

What is a desktop?  
If you are using Windows 7, after you start your computer the first thing you see is the desktop. The desktop is 

your work area.  

Explanation of Windows 7 desktop: 

The following table explains the various features of the Windows 7 desktop. 

Feature  Explanation  

Taskbar  By default, the taskbar is located on the bottom edge of the desktop. You can click the 

taskbar and drag it to other locations. The Start button, active program buttons, icons for 

quick access to programs, and the notification area are located on the taskbar.  

Recycle Bin  When you delete an object, Windows 7 sends it to the Recycle Bin. You can restore objects 

from the Recycle Bin or you can permanently delete them.  

Shortcut icon  Icons with an arrow in the lower-left corner are shortcut icons. Click the icon for quick 

access to the object it represents (program, document, printer, and so on).  
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Explanation of taskbar: The taskbar is a long bar that by default runs along the bottom of your desktop. The 

Start button, Quick Launch toolbar, active program buttons, and the notification area are located on the taskbar. 
You click the Start button to display the Start menu. You use the Start menu to open programs and to perform 

other functions such as searching for files.  

On the taskbar, right next to the Start button is the Quick Launch toolbar. Using the Quick Launch toolbar, you 

can open a program or file simply by clicking its icon. 

 

Using the Start Menu:  
How do I open the Start menu?  

To open the Start menu, click the Start button in the 

lower-left corner of your screen. Or, press the Windows 

logo key on your keyboard. The Start menu appears.  
1. A menu showing the programs you use most 

frequently appears on the left, and commonly performed 

tasks appear on the right.  

2. Click the program you want to open. Windows 7 starts 

the program.  

Creating Shortcuts to the Desktop  
What is a desktop shortcut?  
A desktop shortcut, usually represented by an icon, is a 

small file that 

points to a 

program, 

folder, 

document, or 

Internet 

location. 

Clicking on a 

shortcut icon 

takes you directly to the object to which the shortcut points. 

Shortcut icons contain a small arrow in their lower-left corner. 

Shortcuts are merely pointers; deleting a shortcut does not delete 

the item to which the shortcut points.  

How do I create a desktop shortcut?  
If the item is located on the Start menu:  

1. Click the Start button. The Start menu appears.  

2. All Programs Games  

3. Locate the Solitaire link which you will create a shortcut from.  

4. Right-click the item. A context menu appears.  

5. Click Send To. A submenu appears.  

6. Click Desktop (Create Shortcut). Windows 7 creates a shortcut to the item.  
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How do I create a folder on my desktop?  
1. Right-click the desktop. The context menu will appear.  

2. Click New. A submenu will appear.  

3. Click Folder.  

4. Accept the default name or type over with a new name.  

Deleting and Retrieving Files  
You can permanently delete any unwanted files or folders to 

save disk space, or to just “clean out” your computer. When 

you delete items from your hard drive, they move to the 

Recycle Bin. Files are not permanently removed until you empty the Recycle Bin.  

1. Let’s remove, or delete the shortcut to Solitaire that we just created.  

2. Locate both the Shortcut to Solitaire, and the Recycle Bin on your desktop. Simply, click and drag your 

shortcut to Solitaire into the Recycle Bin.  

NOTE: As you drag the shortcut to the Recycle Bin, the bin itself will highlight. This is your indication that 

the computer understands you want to delete the shortcut. If the Recycle Bin is not highlighted, position the 

shortcut over it until it does become highlighted. Once highlighted, you can let go of the mouse button.  

3. This should eliminate the Shortcut to Solitaire from your desktop. Take a look at the Recycle Bin, and 

notice that is now has papers in it. This indicates that there are some item(s) in the bin.  

4. Double-Click on the Recycle Bin. This will open the Recycle Bin Window, and displays the Shortcut to 

Solitaire that you just deleted. Highlight the Shortcut to Solitaire by clicking on it once.  

5. In the menu bar, click on the word File. In the File menu, there is an option to Restore. (If you do not 

have a Restore option, go back and highlight an item first, then click on File.) Click on the Restore option. 

This will remove the Shortcut to Solitaire from the Recycle Bin, and put it back into its original position or 

place (the desktop). Close the Recycle Bin window, and verify that the Shortcut to Solitaire is on the 

desktop.  

6. Let’s delete the Shortcut to Solitaire again. This time, instead of dragging the item to the Recycle Bin, 

simply point to the icon with your mouse pointer. As you point, right-click. In this object menu, there is an 

option to delete. Highlight the Delete option, and left-click once. This will move the Shortcut to Solitaire to 

the Recycle Bin, without you dragging it there.  

7. Now point to the Recycle Bin with your mouse, and again, right-click. In this object menu, there is an 

option to Empty Recycle Bin. Highlight this option and left-click once. This will actually empty the Bin, 

making all items that were inside, unrecoverable. 

Working with Windows 
A window is a framed area on the desktop that contains an application, document, icon, or task. You can 

control the appearance and location of windows, and you can switch between open windows on the desktop. 

You can also use menus when working with windows. 

What is a window?  
We will use WordPad as an example.  

1. Double click on the Wordpad icon on the desktop. 
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Part  Description  

Ribbon  Displays a variety of menu options found within each grouping of operations (i.e. 

Clipboard, Font, Paragraph) that will be discussed in the MS Word 2010 class.  

Title bar  Displays the name of the current file and the name of the current program.  

Minimize button  Click to temporarily decrease the size of a window or remove a window from view. 

While a window is minimized, its title appears on the taskbar.  

Maximize button  Click to make the window fill the screen.  

Close button  Click to exit a window or close a program.  

Border  Separates the window from the desktop. Drag a window’s borders outward to expand 

it and inward to contract it.  

Status bar  Provides information about the status of your program.  

Restore button  Click to restore a minimized window to its former size.  

 

Windows Aero: Snap, Preview Desktop, Shake, and Flip3D 
Windows 7 has introduced several new graphical user interface features for desktop and windows 

management. These are collectively referred to as Aero and are explained briefly below: 

Docking Windows: Windows 7 now incorporates a feature that allows for windows to be “docked” or 

“snapped” to the sides of the desktop, taking up half of the screen space. A window can be docked to the left 

or right side of the screen. To do this, just drag the window to the side where you want it to be docked. 

No  Area  No  Area  

1.  Ribbon  2.  Title Bar  

3.  Minimize  4.  Maximize  

5.  Close button  6.  Border  

7.  Status Bar  8.  Work Area  
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Unclick the mouse button once the mouse pointer hits the left or right side of the screen. To undock a 

window, just drag it toward the center of the desktop. 

Preview Desktop: As most Windows users have experienced, the desktop can get cluttered very quickly 

when multiple windows are opened over the course of time. On the right side of the time and date on the 

taskbar is a hotspot – a small box (highlighted above) which is used to trigger a function called Preview 

Desktop. When a user holds the mouse over this box, all windows are made transparent, and the desktop can 

be seen temporarily. When the mouse is moved off of this hotspot, the windows are restored. This hotspot 

provides a toggle function: clicking it minimizes all windows to the taskbar; clicking it again restores the 

windows to the desktop. 

 

Aero Shake: In some cases, you want to minimize all open windows with the exception of a single program. 

In Windows 7, you can accomplish this by clicking the title bar of the desired window, holding the left 

mouse button, and shaking the window. All other windows will be minimized to the task bar. To restore all 

windows back to the desktop, just shake the window again. 

Flip3D: Windows now icludes the ability to cycle through open applications using a three-dimensional 

mechanism called Flip3D. To use it simply hold the Windows key and tap the Tab key. This rotates the 

selections until the desired window is displayed. Repeating this process while holding the Shift key rotates 

the selections backwards. Releasing the Windows key brings the selected window to the forefront. 
 

 

 

 

 

 

 

 
Jump Lists: Items 

pinned to the taskbar will be listed on the jump list. Jump list contains pinned 
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and recent files. Easy way to open files, documents and pictures from the taskbar.  

o Right click on program icon from the taskbar & select file under pinned or recent to open  

o To move a file from the recent to pinned group: right click on file name and click on push pin icon  

o Note: Windows Explorer and Internet Explorer also have Jump Lists.  

 

Windows Explorer 
Windows Explorer has become a very powerful utility for navigation and searching directories for files the 

system. The field at the top used to contain an address like C:\Documents and Settings\Directory. This 

address is now much more functional. You can still see the path, but now you have the ability to click an 

arrow to the right of any directory in the path and perform branched browsing from that point. You can still 

get that old-style path name by clicking to the right of the address. 

 
Windows Search 
You can also perform location-specific searches from any directory. Just navigate to the folder and initiate 

your search from the search field in the upper-right corner of the window. Next, Windows Explorer now 

gives you the ability to preview documents as you select them from search results. This is an option which 

can be enabled and disabled on the right side of the Menu Toolbar. Finally, the pane at the bottom of the 

Explorer window provides a way to view and modify the metadata associated with your documents. Much 

of this metadata can be used to perform advanced searches. For example, from any search field, you can 

type tags: *****, or category: *****, or author: *****, etc to restrict the results of a search to metadata from 

that field. With the improved search capabilities of Windows 7, finding programs, documents, and utilities 

has never been easier. From the Start menu, as you begin typing what you’re looking for, results are updated 

and categorized in the search results. Then, just make your selection for the resulting list. You can also 

search from within specific locations in Windows Explorer, including libraries by selecting the location in 

the left-navigation and entering the search criteria in the search box in the upper-right corner of the window. 

If you have defined tags in your documents, you are able search the tags field as well, using the Tags 

criteria. You can use Boolean operators such as AND and OR to refine your searches. 
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Desktop Gadgets: Gadgets, such as Weather or CPU meter can be placed on your 

desktop.  

o Right click anywhere on your desktop and select gadgets  

o Double click on desired gadget to add or click on Get more gadgets online  

o When you point to the gadget on the desktop, you will notice a small vertical toolbar. 

Click on the x to close and remove the gadget from the desktop, click on the arrow to 

increase the size of the gadget and click on the wrench to change the options  

Personalize your PC:  
 

o Click Start / your account picture is located on the 2nd column above your name  

o Click on the picture  

o Click on Change your picture  

o Select desired picture or click on browse for more pictures to locate personal picture  

o Click ok  

 

o Right click on your desktop  

o Click on Personalize  

o Select from Aero theme pictures or  

o Click on Desktop Background / click Browse to select picture location and locate folder and click ok / 

click Save changes  

 

o Right click on your desktop  

o Click on Screen Resolution  

o Click on Make text and other items larger or smaller  

o Select desired option  

o Click apply and select logoff later or logoff now to apply changes  

Other Windows 7 Features:  
Snipping Tool: used to make screen shots or to crop a portion of your screen:  

o Go to the window you want to crop  
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o Click on Start / type snipping / press enter to select and run Snipping Tool  

o Click on New or click the arrow next to New to define type of snip  

o Click and drag + sign to define region  

o Options: 

 

 

 application that lets you post sticky notes to your  

desktop:  

o Click on Start / type sticky / press enter  

o Type your message on the note  

o To add notes: click on the +  

o Note: Since this is an app, when you close the program, the notes are not visible. 

The app must be open to see the notes.  

 set of free programs that allow you to create and share movies, share photos 

online, chat using Instant Messenger & create a blog. We can download the free program suite from the 

Microsoft site.  

o Go to www.microsoft.com and search for windows live essentials  

Paint in Windows 7:  
Paint is a drawing tool that can be used for simple drawings and basic image editing. Paint has been included 

in every version of Microsoft Windows, starting with Windows 1.0 which was released in 1985. After more 

than 20 years of development, Paint reached version number 6.1 in Windows 7 and 6.2 in Windows 8. Even 

though the version number is different between Windows 7 and Windows 8, the application is the same in 

both operating systems. But, compared to earlier versions of Windows, Paint has been changed and 

improved dramatically, after years of stagnation. It finally feels like a basic image editing tool worth taking 

into consideration. 

In this article we will show you where to find Paint, how to work with the new interface and which are the 

most important options and improvements. 

Where to Find Paint in Windows 7: You can find Paint by typing the word 

'paint' in the search box of the Start Menu, in Windows 7, 

An Overview of the Paint Interface 
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How to Work:  We have the Home tab with all the main image editing items that you would expect to see 

in Paint. 

 

 

 

Also the selections have new options. When selecting parts of an image, you 

can decide if you want the background color to be included in the selection or 

not. Simply check or uncheck the "Transparent selection" option. If you want 

the background included, uncheck the option and vice-versa. 

 

Finally, there are the Brushes and Shapes tools which also gained new options, 

shown in the screenshot below. 

 

  

 

 

 

 

 
Drawing lines 

 Open Paint by clicking the Start button , clicking All Programs, clicking Accessories, and then 

clicking Paint.  

You can use several different tools to draw in Paint. The tool you use and the options you select determine 

how the line appears in your drawing. These are the tools you can use to draw lines in Paint. 

Pencil tool 

Use the Pencil tool to draw thin, free-form lines or curves.  

1. On the Home tab, in the Tools group, click the Pencil tool . 
2. In the Colors group, click Color 1, click a color, and then drag the pointer in the picture to draw. 

To draw using the Color 2 (background) color, right-click while you drag the pointer. 

Brushes 

Use the Brushes tool to draw lines that have a different appearance and texture—it's like using different 

artistic brushes. By using different brushes, you can draw free-form and curving lines that have different 

effects. 

1. On the Home tab, click the down arrow under Brushes.  

2. Click the artistic brush that you want to use. 

3. Click Size, and then click a line size, which determines the thickness of the brush stroke. 

4. In the Colors group, click Color 1, click a color, and then drag the pointer to paint.  

To paint using the Color 2 (background) color, right-click while you drag the pointer. 

Line tool:  

Use the Line tool to draw a straight line. When using this tool, you can choose the thickness of the line, as 

well as the appearance of it. 
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1. On the Home tab, in the Shapes group, click the Line tool .  
2. Click Size, and then click a line size, which determines the thickness of the line. 

3. In the Colors group, click Color 1, click a color, and then drag the pointer to draw the line.  

To draw a line that uses the Color 2 (background) color, right-click while you drag the pointer. 

4. (Optional) To change the line style, in the Shapes group, click Outline, and then click a line style. 

Curve tool 

Use the Curve tool to draw a smooth, curved line. 

1. On the Home tab, in the Shapes group, click the Curve tool . 
2. Click Size, and then click a line size, which determine the thickness of the line. 

3. In the Colors group, click Color 1, click a color, and then drag the pointer to draw the line. 

To draw a line that uses the Color 2 (background) color, right-click while you drag the pointer. 

4. After you have created the line, click the area in the picture where you want the arc of the curve to 

be, and then drag the pointer to adjust the curve. 

Drawing different shapes: 

You can use Paint to add different shapes in a picture. The ready-made shapes range from traditional 

shapes—rectangles, ellipses, triangles, and arrows—to fun and unusual shapes, such as a heart, lightning 

bolt, or callouts (to name a few). If you want to make your own custom shape, you can use to the Polygon 

tool to do this. 

 

 

 

 

Text tool 

Use the Text tool to enter text in the picture. 

1. On the Home tab, in the Tools group, click the Text tool 

. 

2. Drag the pointer in the drawing area where you want to 

add text. 

3. Under Text Tools, on the Text tab, in the Font group, click 

the font face, size, and style. 

4.   In the Colors group, click Color 1, and then click a color 

for the text. 

5. Type the text that you want to add. 

6.  (Optional) If you want the background of the text area to be filled, in the Background group, click 

Opaque. In the Colors group, click Color 2, and then click a background color for the text area. 

7.  (Optional) If you want to change the appearance of some of the text in the text box, select the text 

you want to change, and then choose a new font face, size, style, or color for the selected text. 

End of Class3 
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Disk Cleanup: Simply click on your Windows 7 Start button and 

go to All Programs > System Tools > Disk Cleanup and/or 

Defragmenter as show below:  

Select the drive you want to use Disk Cleanup on and click on OK. In 

most cases, you will select Drive: C.  

You will now see this screenshot below for a moment. 

 

To Delete Unnecessary Non-System Files  
Check the type of files box that you want to delete, and click on OK. 

 

 

 

 

 

 

 

 

 

 

Defragmenter 
Fragmentation makes your hard disk do extra work that can slow down your computer. Removable storage 

devices such as USB flash drives can also become fragmented. Disk Defragmenter rearranges fragmented 

data so your disks and drives can work more efficiently. While Disk Defragmenter can run on a schedule, 

this will show you how to open and use Disk Defragmenter to manually analyze and defragment your disks 

and drives in Windows 7.  

To Anaylze a Disk -  

NOTE: This will anaylze the selected disk to see what percentage fragmented it is. If the number is above 

10%, you should defragment the disk.  

A) Select a disk, and click on the Anaylze disk button.  

To Defragment a Disk -  

NOTE: Disk Defragmenter might take from several minutes to a few hours to finish, depending on the size 

and degree of fragmentation of your hard disk. You can still use your computer during the defragmentation 

process.  

A) Select a disk, and click on the Defragment disk button.  
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Upon doing so you will be presented with the following Disk Defragmenter prompt screen located below, 

simply select Analyze or Defragment now and you’re good to go!  

It says it’s “Defragmenting hard disks…”, now what?  

Provided you’ve followed all steps correctly - and I don’t doubt you have - you should hopefully be looking 

at the screen which confirms that the hard drive defragmentation process is currently under way: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Control Panel: 

Remove Program: 

Steps 

1.  

Open the Control Panel. You can access the 

Control Panel from the Start menu. The Start 

menu can be opened by clicking the Windows 

logo in the bottom-left corner of the display, or 

by pressing the Windows key on your keyboard.  
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2 

Open Programs and Features. The Control 

Panel is typically displayed in one of two 

different ways: either a Category View or an 

Icon view. Category view will have 8 or 9 

icons with a few options under each one, while 

Icon view will be a large list of icons.  

 In Category view, click the “Uninstall a 

program” link under the “Programs” 

category 

 In Icon view, click the “Programs and 

Features” icon. 

 

 

 

 

3 

Find the program you want to uninstall. When you open Programs and Features, you will see a list of all of your 

installed programs. You may need to wait a few moments for the list to fully load. Click the program in the list to 

select it.  
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 If the program you want to remove does not appear on the list, check to see if it has its own uninstallation 
tool. This will be typically located in the Start menu group, which you can get to by clicking Start → All 
Programs →Program Name or Company. 

 If you can’t find the uninstallation tool anywhere, it may be malware and will need special procedures to 

remove. Download a program such as Malwarebytes and scan your computer for malware. 

  

 4 
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 Click the Uninstall button. This will appear in the top toolbar when a program is selected in the list. 

You can also right-click on the program to find Uninstallation in the menu that appears. Click it to 

begin the uninstallation process. You will be asked if you want to continue. 

5 

Follow the prompts. Different programs will have different uninstallation programs. You may get asked if you want 

to keep settings can configuration files. If you plan on reinstalling the program at a later date, leaving these could 

make getting it set up easier.  

 If the program refuses to uninstall, or reappears after being installed, you probably have a virus. To deal with 
a virus, you may need to run several different virus removal programs. See this guide for some tips on 
dealing with virus infections. 

Date and Time: 

First, Open the Date and Time Window 

Changing all these settings is done from only one window, named "Date and Time". As always in Windows, 

there are many way to access it. 

One way to open it is to go to the Desktop. On the taskbar, go to the notification area on the right and right 

click (or press and hold) the time. 

 

The right click menu is shown. There, click or tap on "Adjust date/time". 

 

Alternatively, you can click or tap on the time. The time and calendar are shown. Then, click or tap "Change 

date and time settings". 
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You can also use the Control Panel. Open it and go to "Clock, Language, and Region". Then, click or tap 

"Date and Time". 

 

Obviously, you can also use search, both in Windows 7 and Windows 8. But... we've shown enough ways 

for you to access the "Date and Time" window. 
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In the screenshot above you can see how it looks. In this tutorial we will work with two of its main tabs: 

Date and Time and Internet Time. 

How to Change The Date, Time & Their Format 

On the first tab (Date and Time) you can change the date, time and the time zone used by Windows. Also, 

you can view information about the Daylight Saving Time - when it ends or when it starts. You can select 

whether you want to be notified when the clock changes by checking "Notify me when the clock changes". 

To modify the date and time click or tap "Change date and time" 
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In the Date and Time Settings window, set the appropriate time and date. In the calendar you can zoom-in 

and out if you click on the name of the month. You can also press the Ctrl key on your keyboard and then 

use the scroll wheel of the mouse to perform the same action.  
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At first, you will see all the months from the current year and, if you continue, all the years from this decade 

and finally all the decades from this century. 

 

You can zoom back in by selecting the appropriate decade, year, month and day. Also you can use the small 

left-right arrows to move from one decade/year/month/day to another.  
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In the same window there is a link to "Change calendar settings". Click or tap on it if you want to change 

the date or time format. The Customize Format window opens. Here you have the possibility to change the 

format of the date. There are two date formats that you can customize: a Short date and a Long date. The 

short date appears in the taskbar right under the clock and the long date appears only when you hover or 

click on the clock from the taskbar. 

 

You can use the drop-down list menu to choose from different date formats or you can directly edit each 

format. 

 

As an example, let's assume that I want to display the short date like this: Wednesday, 01 / Jan. - 09. In order 

to accomplish this, I have to write in the short date format text box this code: dddd, d / MMM - yyyy. As you 

can see you can add punctuation marks like '. , / -' and spaces, between the default day, month or year code. 

One limitation that I noticed is that you cannot insert MMMM (which is the full name of a month) in the 

short date format. Apparently this code works only in the long date format. 
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This is how this code looks like in the taskbar clock. 
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Word Processing Concept: Word processing is the application that is used most often and most 

widely. We will start with it to learn about the terms and features that are common to most applications, as 

well as some that are specific to word processing. Then we will look at other major applications and what 

they do. 

Examples of word processing programs: Microsoft Word, WordPerfect, Lotus WordPro, and Open Office 

Writer. 

Word Processing 

Word processing is the most used computer application!  

It has replaced the typewriter as the main way words are put on paper. Documents can be revised and 

corrected before they are ever printed. An existing document can be used as a template, or pattern, for a 

new one. So the user doesn't have to recreate standard documents from scratch each time. This is a major 

time-saver and helps keep things consistent.  

Purpose:  To produce documents 

Main advantage: 
 Can easily change what has been done 

 Can reuse existing documents as a template 

Steps to produce a document 
 Create 
 Edit 
 Format 
 Print 
 Save (often!!) 

Let's look at the terms involved in these steps more closely.  

Most of these terms also apply to the other standard applications, so we will not redefine them for all. 

Create  
You create a document when you open a blank document and enter text.  

Features/Terms:  

Word wrap -  Automatically wrapping the text to the next line so it all fits within the screen's width.  

Change the size of the screen and the text moves to fit in the space. 

Cursor -  
Symbol for where text will appear like:  

Enter text- Type new text 

Scrolling -  Moving document around within window 

Select - Highlight text, usually by dragging. Commands and keystroke combinations will apply 

to the selected material. 

Edit -  Make changes 

Cut -  Remove selection from document and store temporarily on the Clipboard, which is a 

section of computer memory. The Windows Clipboard can hold only one thing at a 

time. The Office Clipboard from Office XP and later versions can hold many items. 

Copy - Duplicate selection onto Clipboard 

Paste - Place contents of the Clipboard at cursor location 

Undo - Reverses whatever change you just made  

Some programs will only "undo" the last change.  

Others keep a list and can undo more, depending on how many changes the program 

tracks. 

Insert - Add text at location without overwriting existing text 

Overwrite - Typing overwrites existing text, replacing whatever characters were there already 

Delete - Remove text (not saved anywhere) 
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Search - Look for specific word(s) or character(s) in the document 

Replace - Can replace specific word(s) or character(s) with stated text 

Template - Document that serves as a pattern for a new document 

Thesaurus  - Looks for synonyms for selected word 

Spelling check -  Looks for spelling errors 

Grammar check - Looks for grammar/style errors (of limited help) 

Format 
Once a document has been created, or during the process, you arrange how it will look by selecting the kind 

of letters and their sizes and colors, how much space is left and where, how things line up. All of this makes 

up the formatting of the document. 

Features/Terms:  

Typeface - Set of characters of similar design like: 

 

Point size - One point = 1/72 of an inch like:  

12 pt 18 pt 24 pt 36 pt 

Font - Combo of typeface & point size, includes styles such as BOLD, italics, underline 

Margins -  

  Space at the page borders   

Justification - left center right justify 

    

 

Spacing - 

  Space between letters and lines   

Borders/shading - 

  Lines around table or page; background color    

Headers/footers - 

  Info to repeat on each page    
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Style set - 

Saved sets of formats to reuse in different places in the document 

and with different documents. Possible confusion with 'style' used for bold, italics, and 

underline! 

Columns - 

 Columns of text side by side as in a newspaper 

Tables - 

  Items listed in rows and columns  

Graphics - 

  Pictures and charts 

Print 
When a document is finished, you can print it onto paper, if you have a printer connected to the computer. 

You will have several choices to make as part of the printing process: 

Features/Terms:  

Number of copies/pages to print 

Orientation:  

 

 

 
Portrait  Landscape  

Quality: 
Most printer can print with a low quality 

(Draft) as well as with better quality levels. 

Print Preview:  Shows you how it will look in print 
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Word 2010:  

Interface: 

 
  

Ribbon Tabs 
The ribbon in Office programs runs across the top of the program window and contains tabs which hold tab 

groups of items that are related.  

 

For example, the Home tab shown above has the tab groups Clipboard, Font, Paragraph, Styles, and Editing. 

Each group holds items that are related. So the Font group has buttons for formatting text like font, font size, 

bold, italics, underline, strikethrough, subscript, superscript, etc. 

The default tabs for the ribbon in Word are: 

 Home             Format text, Cut, Copy, Paste, Find, Replace 
 Insert             Insert an object - image, table, shape, symbol, 

                      header/footer 
 Page Layout   Margins, sections, orientation, themes 
 References     Create sources, footnotes, bibliography entries,  

                      table of contents 
 Mailings          Envelopes, address labels, mail merge 
 Review           Spelling and grammar, thesaurus, translation, track changes 
 View              Select a view, arrange windows 

Context tabs become available as needed, such as Drawing Tools, which appears when you insert or select a 

Drawing shape. This keeps the ribbon from getting entirely too full! 

We have already seen part of the View ribbon on the Views page. In these lessons we will get very familiar 

with the Home tab and specific features on some other tabs plus what you can do from the Office button or 

File tab. 
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What's that button for? 

To find out what an item on a ribbon tab is actually for, just hover the mouse 

pointer over the button. A screen tip will appear below the ribbon. It tells 

you the name of the command and usually more information. 

Problem: A control on the 

ribbon is gray and does not work. 

Grayed out controls are not 

available right now.   

Solution: Select the object or text 

that you want first. Then the controls that make sense for your 

selection will be active. 

Example: In the illustration at the right, an AutoShape is selected, 

so the buttons for formatting text are grayed out. But Paste, Cut, 

Copy, and Format Painter are still active because you can use those on a shape.  

If the shape contains text (it was really a text box), then the text formatting tools will still be active.  

Backstage View:  
The Ribbon contains the set of commands for working in a document, while the Microsoft Office Backstage 

view is the set of commands you use to do things to a document.  

Open a document, and click the File tab to see the Backstage view. 

The Backstage view is where you manage your documents and related data about them — creates, save, and 

send documents, inspect documents for hidden metadata or personal information, set options such as turning 

on or off AutoComplete suggestions, and more. 

 
When you click the File tab, you see many of the same basic commands 

that you saw when you clicked the Microsoft Office Button or on the File 

menu in earlier releases of Microsoft Office. You'll find Open, Save, and 

Print, as well as a new Backstage view tab called Save & Send, which 

offers multiple options for sharing and sending documents.  
TIP: To quickly return to your document from the Backstage view, click the Home 

tab, or press ESC on your keyboard. 
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Click a Ribbon Object... 
What happens when a ribbon object is clicked? It depends!  

Command Button: 
Performs an action, like making selected text bold or 

opening a pane   

 or  

Menu: 

An arrow under an icon drops a menu of 

choices, like this one for what to delete.  

 
Drop list: 
A down arrow at the right of a button drops a list of 

choices for a single characteristic, like font size or 

borders.  

   

Dialog Box Launcher:  

The tiny diagonal arrow button at bottom right 

of a ribbon group opens a dialog or a pane 

related to the group on the ribbon. The 

illustrations show buttons for launching the Font 

dialog and the Style pane. 

 
Spin box: 
Adjusts the number in the box, up or down when you 

click an arrow, or you can type in a value. 

Checkbox: 
Toggles the feature on/off  
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Gallery: 

Applies the clicked choice to whatever is selected.  

 

 

The up and down arrows rotate what shows in the ribbon. 

This area will collapse when the window is narrow. 

 

Complete Gallery:  

Clicking the More button    at the right end of 

the gallery opens a larger palette of choices. 

 
Customize the Quick Access Toolbar  

The Quick Access Toolbar is a customizable toolbar that 

contains a set of commands that are independent of the tab 

on the ribbon that is currently displayed. You can move the 

Quick Access Toolbar from one of the two possible 

locations, and you can add buttons that represent commands 

to the Quick Access Toolbar. 
 

 

Add a command to the Quick Access Toolbar  

1) On the ribbon, click the appropriate tab or group to display 

the command that you want to add to the Quick Access 

Toolbar.  

2) Right-click the command, and then click Add to Quick 

Access Toolbar on the shortcut menu.  
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Mini-Toolbar 

1. Select line 7 by dragging back across the line to the left. Do 

not highlight any of the line above. 

The Mini-Toolbar appears above your selection. 

2. Word 2010: Move your mouse pointer up toward the 

Mini-Toolbar to make the toolbar solid and clear. 

               

3. On the Mini-Toolbar:  

o Click on the  Bold and Italics buttons  

o Change the size to 20 using  the Font Size drop list.  

4. Click in a blank part of the document to deselect the text. 

 

Save a document in Word  
You can use the Save and Save As commands to store your work, and you can adjust 

the settings that Microsoft Word uses to save your documents.  

<CTRL> + S (same as: ) 

 

 

 

 

Give the document a name, and remember to save a place where you can find it again. finish by pressing the Save 

button, 

 
1) Document location on your computer.  

2) Choose where you want to save the document.  

3) Name of the document and file format.  
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Save as PDF  
To keep your file’s format when you share your files with other people or print your files by using 

commercial methods, you can use Microsoft Office 2010 programs to save files as PDFs without needing 

additional software or add-ins.  

Use PDF format when you want a file that:  

 

 

 

How to  

1) Click the File tab.  

2) Click Save As.  

3) In the File Name box, enter a name for 

the file, if you haven't already.  

4) In the Save as type list, click PDF 

(*.pdf).  

5) If you want the file to open in the 

selected format after saving, select the 

Open file after publishing check box.  

6) If the document requires high print 

quality, click Standard (publishing online 

and printing).  

7) If the file size is more important than print quality, click Minimum size (publishing online).  

8) Click Options to set the page to be printed, to choose whether markup should be printed, and to select 

output options. Click OK when finished.  

9) Click Save.  
 

 Home Tab  
This is the most used tab; it incorporates all text formatting features such as font and paragraph changes. 

 

Cut, Copy and Paste  
If you would like to remove text from your document you can copy or cut the text from the document. 

Simply highlight the text and go to the Home tab in the Clipboard group and click 

Cut or Copy. You can also right click on your mouse and select Cut or Copy.  

Pasting Text  

If you Copy text, you typically need to Paste it somewhere. The Paste feature in 

2010 is much more detailed than in previous versions of Word. When you paste 

content, the Paste Options button provides different options, depending on the 

source of the content.  
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Undo  
The Quick Access Toolbar holds a variety of commands right at you 

finger tips. It is located in the top left of the document above the File and 

Home tab.  

You can add or remove command by clicking on the arrow to the right of the Quick Access Toolbar.  

If you make an error in your document click on the Undo command and it will remove the last thing you did.  

Press Ctrl + Z to undo action to any document. 

 

Show/Hide Formatting Marks  
The Show/Hide command allows you to see every time you hit the space bar, hit enter or tab. This feature 

can be quite useful when creating documents to understand where everything is placed within your 

document and see if any errors have been made. On the Home tab, in the Paragraph group, click Show/Hide. 

 
 
 
 
 

Formatting Text  
Formatting a document can range from modifying text size to adding graphics. It is easy to add creative 

touches to any document with the options Microsoft Word has to offer.  
Modifying Fonts  

The Font Group allows you to change your text font style, size, color and many other elements.  

1. Highlight the text you would like to modify.  

2. Click on the drop down arrow of font style and font size and 

select the changes you would like to make.  

3. While text is highlighted you can also click on the color, 

bold, italics or underline commands to modify the text even 

more.  
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Change Text Case  

You can change the case of selected text in a document by 

clicking a single button called Change Case on the ribbon.  

1. Highlight the text for which you want to change the case.  

2. On the Home tab, in the Font group, click Change Case.  

3. Choose an option from the dropdown list, which includes  

Sentence case, lowercase, UPPERCASE, Capitalize  

Each Word, and tOGGLE cASE.  
 
Adding text effects  

1. Select the text that you want to add an effect to.  

2. On the Home tab, in the Font group, click Text Effect.  

3. Click the effect that you want.  

For more choices, point to Outline, Shadow,  

Reflection, or Glow, and then click the effect that you want to add.  

 
Remove text effects  

1. Select the text that you want to remove an effect from.  

2. On the Home tab, in the Font group, click Clear Formatting.  
 
Format Painter  

The Format Painter feature allows you to quickly copy a format that you have applied to text already in 

your document.  

1. Select the text or graphic that has the formatting that you want to copy.  

2. On the Home tab, in the Clipboard group, single click Format Painter. The 

pointer will change to a paintbrush icon.  

3. Bring your cursor to the text or graphic that you want to format and click on the text.  

4. To stop formatting, press ESC or click on the Format Painter command again.  

NOTE: Double-click the Format Painter button if you want to change the format of 

multiple selections in your document. 
Clear Formatting  

To get rid of all the styles, text effects, and font formatting in 

your document, do the following:  

1. Select the text that you want to clear the formatting from. 

Or press CTRL+A to select everything in the document.  

2. On the Home tab, in the Font group, click Clear 

Formatting.  

NOTE: The Clear Formatting command will not remove highlighting from your text. To clear 

highlighting, select the highlighted text, and then click the arrow next to Text Highlight Color and click No 

Color.  

Formatting Documents  
Adjusting Line Spacing  

The default spacing is 1.15 line spacing and 10 points after each paragraph. The default spacing in Office 

Word 2003 documents is 1.0 between lines and no blank line between paragraphs.  

The easiest way to change the line spacing for an entire document is to highlight the paragraphs or entire 

document that you want to change the line spacing on.  

1. On the Home tab, in the Paragraph group, click Line Spacing.  

2. Do one of the following:  
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Click the number of line spaces that you want.  

For example, click 1.0 to single-space with the spacing that is used in earlier versions 

of Word. Click 2.0 to double-space the selected paragraph. Click 1.15 to single-space 

with the spacing that is used in Word 2010.  

Click Remove Space Before Paragraph to remove any additional lines added after 

each paragraph as a default  

NOTE: If a line contains a large text character, graphic, or formula, Word increases 

the spacing for that line. To space all lines evenly within a paragraph, use exact 

spacing and specify an amount of space that is large enough to fit the largest 

character or graphic in the line. If items appear cut off, increase the amount of spacing. 

 
Bulleted or Numbered List  
You can quickly add bullets or numbers to existing lines of text, or 

Word can automatically create lists as you type. By default, if you 

start a paragraph with an asterisk or a number 1., Word recognizes 

that you are trying to start a bulleted or numbered list. If you don't 

want your text turned into a list, you can click the AutoCorrect 

Options button that appears.  

Bullets Command  

Numbering Command  

Insert Bulleted or Numbered List  

1. Click on the area where you would like your list to appear or highlight the text you would like to be in a 

list.  

2. Go to the Home tab, in the Paragraph group, click Bullets or 

Numbering.  

3. A bullet(s) or number(s) will be inserted.  

Select Bullets or Numbering Style  
1. Select the items that you want to add bullets  

or numbering to.  

2. On the Home tab, in the Paragraph group, click the arrow next to 
the Bullets or Numbering command.  

3. Select the bullet or number format you would like to be inserted.  

Move a List Left or Right  

If you do not like the location of your bullets or numbers you can easily move them 

to a preferred location.  

1. Click a bullet or number in the list to highlight the list.  

2. Drag the list to a new location. The entire list moves as you drag.  

The numbering levels do not change.  

Setting Detailed Tab Stops  

If you want your tab stops at precise positions that you can't get by clicking the ruler, or if you want to insert 

a specific character (leader) before the tab, you can use the Tabs dialog box.  

1. Click the Home tab, click the Paragraph Dialog Box  

Launcher  

2. A Paragraph box will appear, click on the Tabs button at the 

bottom left of the dialog box.  

3. A Tabs dialog box will appear.  
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4. Under Tab stop position area, type the location where you want to set 

the tab stop. Hit enter.  

5. Under Alignment, click the type of tab stop that you want. See the 

table above for an explanation of the different types of tab stops.  

6. To add dots with your tab stop, or to add another type of leader, click 

the option that you want under Leader.  

7. Click Set.  

8. Repeat steps 4-5 to add another tab stop, or click OK.  

9. The Tabs dialog box will disappear and you should see your tabs set 

on the document ruler.  

Clear Tab Stops  

You can clear tab stops in a variety of ways, the simplest is going to the 

ruler, click and hold on the tab stop and drag in down towards the 

document. The tab stop will disappear. To quickly clear multiple tab stops and start fresh:  

1. Click the Home tab, click the Paragraph Dialog Box Launcher  

2. A Paragraph box will appear, click on the Tabs button at the bottom left of the dialog box.  

3. A Tabs dialog box will appear.  

4. In the list under Tab stop position, click the tab stop position that you want to clear, and then click 

Clear. To remove the spacing from all manual tab stops, click Clear All.  

5. Click OK.  

 

Using Styles  

1. Select the Home tab.  

2. Select the text you wish to style.  

3. In the Styles box, select the style you would like to use. For 

additional styles, select the down arrow on the right-hand side of the 

Styles box.  

Formatting Styles  

1. Select the Change Styles option. A drop-down menu appears.  

2. Scroll through the options and select your preferences. You can make changes to colors, fonts, and more.  

Removing Styles  

1. Select the styled text you want to remove.  

2. Select the Normal option from the Styles Ribbon. Your text switches back to 

your default font and font size.  

 

 

Find and Replace: 

Find a Word: 

In Word 2010, you can access find and replace using the Home tab and the Find option at the right 

(note Advanced Find option): 
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If you just choose Find, you’ll get the sidebar shown below, if you choose Advanced Find, you’ll jump 

straight to the dialogue box. 

Pressing Ctrl-F will bring up a sidebar with a simple search option. This seems very odd if you’re used to 

Word 2003 and Word 2007, as you are left wondering where the familiar dialogue box is, but it’s actually 

very useful, as you can see at a glance how many times your word is used and where in the text it can be 

found, and the word searched for (in this case localization) is highlighted in the text: 

 

If you want to access the more advanced Find and Replace dialogue box that you’re used to from Word 

2010, you need to either choose Advanced Find from the Home tab Find area, or click on the arrow to the 

right of the magnifying glass in the side panel. If you do that, 

you’ll get a drop-down menu which includes Advanced Find. 

Whichever option you choose, you will then be confronted with 

the familiar Find and Replace dialogue box: 
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Once you’ve brought up the dialogue box, type in the text you want to search for and press Enter or the 

Find Next button. 

Replace text Word 2010: 

(Note: all screenshots are from Word 2010; however this works exactly the same for all versions of Word 

back to Word 2003 and up to Word 2013 (at least)). 

To Replace text, you need to go to the second tab along in the Find and Replace dialogue box, marked 

Replace. You will then be given an extra space to fill in the text you want to replace your found text with. In 

this case, I’m finding “localization” and replacing it with “localization”: 

 

At this point you have a choice: hitting Find Next (to find the next instance of the word) and then Replace 

(to replace it with your new word) for each individual occurrence, or going wild and pressing Replace All 

(which will automatically replace every occurrence of the word you’ve found with the one you’re replacing 

it with), 
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I would always recommend using Find Next – Replace unless you absolutely know that you are not going 

to be replacing something you don’t mean to replace. Even replacing a double space with a single might 

play havoc if the person who wrote the document has used spaces to format tables (even if they shouldn’t do 

that, some still do). 

End of Class5 
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Insert Tab  
This tab allows you to insert a variety of items into a document from pictures, clip art, tables and headers 

and footers. 

Create a cover page 
Microsoft Word offers a gallery of convenient predesigned cover pages. Choose a cover page and replace the sample 

text with your own.  

Cover pages are always inserted at the beginning of a document, regardless of where 

the cursor appears in the document.  

1. On the Insert tab, in the Pages group, click Cover Page.  

2. Click a cover page layout from the gallery of options.  

After you insert a cover page, you can replace the sample text with your own text by 

clicking to select an area of the cover page, such as the title, and typing your text.  
NOTES  

If you insert another cover page in the document, the new cover page will replace the first cover page you 

inserted.  

To replace a cover page created in an earlier version of Word, you must delete the first cover page manually, 

and then add a cover page with a design from the Word gallery.  

To delete a cover page inserted with Word, click the Insert tab, click Cover pages in the Pages group, and 

then click Remove Current Cover Page.  

Page Breaks:  

Word automatically inserts a page break when you reach the end of a page. If you want the page to break in 

a different place, you can insert a manual page break.  

Inserting a Page Break  

1. Click where you want to start a new page.  

2. On the Insert tab, in the Pages group, click Page Break.  

NOTE: You can also insert breaks into your document by going to the Page 

Layout tab, Page Setup group and clicking on the Breaks command to view a 

variety of page and section breaks you can insert into your document.  

Deleting a Page Break  

You cannot delete the page breaks that Word inserts 

automatically; you can only delete a page break that you insert 

manually.  

1. Go to the page break you would like to remove.  

2. Select the page break by clicking in the margin next to the dotted line.  

3. Press the DELETE key on your keyboard.  

Headers, Footers, and Page Numbers:  

You can add headers, footers and page numbers numerous ways. The simplest 

way is to double click on the top or bottom of the page and the header and footer 

area will appear. Enter the text you wish to be displayed at the top or bottom of 

every page.  

Add Page Numbers  

If you want a page number on each page, you can quickly add a page number 

from the gallery.  
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1. On the Insert tab, in the Header & Footer group, click Page Number.  

2. Click the page number location that you want.  

3. In the gallery, scroll through the options, and then click the page number format that you want.  

4. To return to the body of your document, click  

Close Header and Footer on the Design tab (under Header & Footer Tools).  

 

 

 

 

 

 

Add Header or Footer:  

1. On the Insert tab, in the Header & Footer group, click Header or Footer.  

2. Click the header or footer that you want to add to your document and your 

header or footer area will open.  

3. Type text in the header or footer area.  

4. To return to the body of your document, click Close Header and Footer on 

the Design tab (under Header & Footer Tools).  

Remove page numbers, headers, and footers:  

1. Click on the Header, Footer or Page Number Command.  

2. A drop down menu will appear.  

3. Click Remove at the bottom of the menu.  

Working with Graphics  
Inserting Shapes:  

You can add one shape to your file or combine multiple shapes to make a 

drawing or a more complex shape. Available shapes include lines, basic 

geometric shapes, arrows, equation shapes, flowchart shapes, stars, banners, 

and callouts. After you add one or more shapes, you can add text, bullets, 

numbering, and Quick Styles to them.  

1. On the Insert tab, in the Illustrations group, click Shapes.  

2. A drop down menu will appear, click the shape that you want.  

3. Click anywhere in the document, and then drag to place the shape.  

Insert Text to Shapes:  

Once you have added a shape, you may want to add text inside the shape. 

All you have to do is click on the inside of the shape and start typing.  

NOTE: The text that you add becomes part of the shape — if you rotate or 

flip the shape, the text rotates or flips also.  

Format Shapes:  

After you insert a shape a new tab called Drawing Tools Format will 

appear every time you click on the shape.  

1. Click the shape that you want to apply a new or different Quick Style to.  

2. Go to the Drawing Tools Format tab, in the Shape Styles group; click 

the style that you want to be applied.  
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3. To see more Quick Styles, click the more button.  

The Drawing Tools Format Tab also allows you to change the shape fill, outline, effects and select how the 

text in your document is wrapped around the shape. 

Delete Shapes  

If you decide you no longer want the shape in your document then click on the shape and then press 

DELETE.  

Inserting Text Boxes  

A text box is an object that lets you put and type text anywhere in your file.  

1. On the Insert tab, in the Text group, click Text Box and a drop down menu will appear.  

2. Click on a text box template or click Draw Text Box at the bottom of the drop down menu to draw your 

own text box.  

3. If you elect to draw your own text box you need to click in the document, and then drag to draw the text 

box the size that you want.  

4. To add text to a text box, click inside the text box and then type or paste text.  

To format text in the text box, select the text, and then use the formatting options in the Font group on the 

Home tab.  

To position the text box, click it, and then when the pointer becomes a, drag the text box to a new location.  

NOTE: If you have problems printing text boxes, make sure that the Print drawings created in Word 

check box are selected. To do this, click the File tab, click Options, click Display, and then under Printing 

Options, select the Print drawings created in Word check box.  

Deleting Text Boxes:  

To remove a text box just click the border of the text box that you want to delete, and then press DELETE. 

Make sure that the pointer is not inside the text box, but rather on the border of the text box. If the pointer is 

not on the border, pressing DELETE will delete the text inside the text box and not the text box.  

WordArt  

WordArt can be used to add special text effects to your document. For example, you can stretch a title, skew 

text, make text fit a preset shape, or apply a gradient fill. This WordArt becomes an object that you can 

move or position in your document to add decoration or 

emphasis. You can modify or add to the text in an existing 

WordArt object whenever you want. To add WordArt to text 

in your document, complete the following steps:  

1. On the Insert tab, in the Text group, click WordArt,  

2. A Drop down menu will appear, click the WordArt style that you want.  

3. A Text Box will appear with the words” Enter your text here”, Enter your text.  

Insert Picture/Clip Art  

Pictures and clip art can be inserted or copied into a 

document from many different sources, including 

downloaded from a clip art Web site provider, copied from a 

Web page, or inserted from a folder where you save 

pictures. 

Insert Clip Art:  

1. On the Insert tab, in the Illustrations group, click Clip Art.  

2. A Clip Art task pane will appear on the right of your screen, in the Search for box, type a word or phrase 

that describes the clip art that you want.  

3. Click Go.  

4. In the list of results, double click on the clip art to insert it into your document.  
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Insert Picture from Web:  

1. Open the document.  

2. From the Web page, drag the picture that you want into the Word document.  

Insert Picture from File:  

To insert a picture saved in your computer, insert it by following these steps.  

1. Click where you want to insert the picture in your document.  

2. On the Insert tab, in the Illustrations group, click Picture.  

3. Locate the picture that you want to insert. For example, you might have a picture file located in My 

Documents.  

4. Double-click the picture that you want to insert and it will appear in your document.  

NOTE: To resize a picture, select the picture you've inserted in the document. To increase or decrease the 

size in one or more directions, drag a sizing handle away from or toward the center. 
 
Advanced Formatting Techniques  
Create Columns:  

Columns can be used in documents such as brochures, newsletters or to save space when creating lists.  

Add columns before entering text:  

1. Go to the Page Layout tab, in the Page Setup group, click Columns.  

2. Click the layout that you want. Your document will be formatted in columns.  

NOTE: To add a vertical line between the columns, click Columns again, click 

More Columns, and then select the Line between check box. You can also adjust 

the column width and spacing.  

Add columns to part of a document:  

To do that highlight the text you want formatted in columns, or place your cursor 

where you want columns to begin.  

1. On the Page Layout tab, in the Page Setup group, click Columns.  

2. Click More Columns.  

3. Click the number of columns that you want.  

4. In the Apply to list, click Selected text or This point forward.  

NOTE: To change the layout again further on in your document, select text or click 

where you want to change the layout, and then follow the same steps. For example, 

you can change from one column to a two-column layout, and then you can change 

back to the single-column layout on a later page.  

SmartArt Graphic  

A SmartArt graphic is a visual representation 

of your information that you can quickly and 

easily create, choosing from among many 

different layouts, to effectively communicate 

your message or ideas. You can create 

SmartArt graphics in Excel, Outlook, 

PowerPoint, and Word.  

SmartArt graphics enables you to create 

designer-quality illustrations with only a few 

clicks of your mouse. When you create a 

SmartArt graphic, you are prompted to 

choose a type of SmartArt graphic, such as Process, Hierarchy, Cycle, or Relationship. Each type of 

SmartArt graphics contains several different layouts. After you choose a layout, it is easy to switch the 

layout or type of a SmartArt graphic. Most of your text and other content, colors, styles, effects, and text 

formatting are automatically carried over to the new layout. 
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When you select a layout, placeholder text (such as [Text]) is displayed, so that you can see how your 

SmartArt graphic looks, nor is it displayed during a slide show. However, the shapes are always displayed 

and printed, unless you delete them. You can replace the placeholder text with your own content.  

Create a SmartArt Graphic  

1. On the Insert tab, in the Illustrations group, click SmartArt.  

2. In the Choose a SmartArt Graphic dialog box, click the type and layout that 

you want.  

3. Enter your text by doing one of the following:  

Click [Text] in the Text pane, and then type your text.  

Copy text from another location, click [Text] in the Text pane, and then paste your text.  

 

 

 

 

 

Add or Delete Shapes in SmartArt Graphic:  

1. Click the SmartArt graphic that you want to add another shape to.  

2. Click the existing shape that is located closest to where you want to add the new shape.  

3. Under SmartArt Tools, on the Design tab, in the Create Graphic group, click the arrow under Add 

Shape.  

4. Do one of the following:  

To insert a shape after the selected shape, click Add  

Shape After.  

To insert a shape before the selected shape, click Add  

Shape Before.  

NOTE: To delete a shape from your SmartArt graphic, click the shape you want to delete, and then press 

DELETE. To delete your entire SmartArt graphic, click the border of your SmartArt graphic, and then press 

DELETE. 

Tables  
Using tables in Word can provide you with additional elements to any document. 

Tables can be used to create lists or format text in an organized fashion.  

Inserting a Table:  

1. Click where you want to insert a table.  

2. On the Insert tab, in the Tables group, click Table  

3. A drop down box will appear; click and hold your mouse then drag to select 

the number of rows and columns that you want inserted into your document. 

You will see your table appearing in your document as you drag on the grid.  

4. Once you have highlighted the rows and columns you would like let go of 

your mouse and the table will be in your document  

Add Row/Column to Table:  

1. Click on the table.  

2. Under Table Tools, go to the Layout tab  

3. Click on the Insert Above or Insert Below to add a row, Click on Insert Left 

or Insert Right to insert a column.  
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4. Click on Delete to remove a column, row or cell.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Delete a Table  

1. Rest the pointer on the table until the table move handle appears, and then click the table move handle.  

2. Press BACKSPACE on your keyboard.  

 

 

 
Delete Table Contents.  

You can delete the contents of a cell, a row, a column, or the whole table. When you delete the contents of a 

table, the table's rows and columns remain in your document.  

1. Select the contents that you want to clear by following the table below:  

TO SELECT  DO THIS  

The entire table  In Print Layout view, rest the pointer over the table until the table move handle 

appears, and then click the table move handle.  

A row or rows  Click to the left of the row.  

A column or columns  

Click the column's top gridline or border.  

A cell  Click the left edge of the cell.  

2. Press DELETE.  

 

Page Layout Tab  
This tab has commands to adjust page elements such as margins, orientation, inserting columns, page 

backgrounds and themes. 
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Apply Themes to Word Documents 

You can quickly and easily give your document a professional look 

by applying a document theme. A document theme is a set of 

formatting choices that include a set of theme colors, a set of theme 

fonts (including heading and body text fonts), and a set of theme 

effects (including lines and fill effects).  

IMPORTANT Document themes that you apply affect the styles 

that you can use in your document.  

1. On the Page Layout tab, in the Themes group, click Themes.  

2. Click the document theme that you want to use.  

NOTES  

If a document theme that you want to use is not listed, click Browse for Themes to find it on your computer 

or network.  

To automatically download new themes, click Enable Content Updates from Office.com.  

 

Adding Line Numbers  
1. Select the Page Layout tab.  

2. Select the Line Numbers option.  

3. Scroll through the options and select your 

preference.  

Removing Line Numbers  
1. Repeat Steps 1-2 of Adding Line Numbers.  

2. Select None. This removes any line numbers 

you have in your document.  

Editing Margins: 

In Word 2010, your document automatically has one-inch margins. However, you 

change these to another one of the pre-formatted margin settings Word provides or 

customize your own margins.  

Pre-Formatted Margins  
1. Select the Page Layout tab.  

2. Select the Margins option. A drop-down menu with pre-formatted options appears.  

3. Select your preference. Word automatically applies your changes.  

Customizing Your Margins  
1. Follow Steps 1 and 2 of Pre-Formatted Margins.  

2. Select the Customize Margins option at the bottom of the drop-down menu. A box 

appears on your screen.  

3. Fill in the opinions according to your preferences.  

4. Select OK.  
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Adding and Deleting Watermarks  

Watermarks are useful for identifying certain documents. You can use watermarks to classify a document as 

a memo, a draft, and more.  

Adding a Watermark  
1. Select the Page Layout tab of the Microsoft Word Ribbon.  

2. Select the Watermark option.  

3. Scroll through the available options and select your preference. The watermark appears on your 

document.  

4. If you wish, you can edit your watermark by selecting the Custom Watermark option.  

 

 

 

 

 

 

 

 

 

 

 

Deleting a Watermark  
1. Place your mouse tab on the page with the watermark you wish to remove.  

2. Repeat Steps 1-2 of Adding a Watermark.  

3. Select the Delete Watermark option.  

Inserting and Deleting Page Borders  

Page borders are typically optional. However, you can still use 

them to add a decorative flair to your document if you wish.  

Inserting a Page Border  
1. Select the Page Layout tab.  

2. Select the Page Borders option near the center.  

A box with multiple border options appears on your screen. 
3. Select your preference and click OK.  

 

 

 

 

End of Class 6 



RRKKMMSSWWSS                                                            

Options from picture tool format, Reference Tab 

 

1 

 

Picture Tools Format: 
To move your image to the right hand side, try this: 

 Click on your image to get the sizing handles back 

 Hold down your left mouse button 

 Keep the left mouse button held down 

 Drag your mouse to the right 

What happens? Nothing! The image refuses to move to the right hand side! What's going on? And how do 

you move an image in Microsoft Word? 

The reason the image won't move to the right is because of the way it is formatted. The wrapping style is set 

to "In line with text". What this means is that you can move your image up, and the text will shift to the top 

and bottom of the image. But it won't move to the right. It will be like this one below: 

 

To move your image anywhere on the page, do the following: 

 Click on your image so that it has the sizing handles around its edges 

 From the Ribbon at the top of Microsoft Word, make sure the Format tab is selected, if it's not 

already 

At this stage, you could choose a style for your picture, if you wanted. Try some of them out. Move your 

mouse over any of the Picture Styles to see what happens: 

 

If you find one you like, you can click on it to insert that style. 

But leave the style alone, and locate the Arrange panel. The option we're looking for is Position: 

 

Position means the position of the image in relation to the text. We want it square and to the right. 

Click the arrow on the Position option to see a dropdown list: 
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Again, move your mouse over each one to see what they do. But don't left click any. Instead, click the link at 

the bottom that says "More Layout Options". When you do, you'll see this dialogue box (select the Text 

Wrapping tab if it's not already selected): 

 

Select the same option we have, in the image above: 

Wrapping Style: Square 

Wrap Text: Left Only 

Distance from Text: 1.5 cm Left (0.59 inches) 

When you have set the three options above, click the Picture Position tab at the top of the dialogue box. 
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For the Horizontal alignment, set it Right. Then click OK on the dialogue box. Your article and image 

should then look like this: 

 

You should now be able to move your image around the page. Position it on the right, with the top of the 

image aligned with the top of the article text. Now select the text of the article and change the font size to 

14. Change the size of the headings as well, any size you want. Your article will then look something like 

this: 

 

To straighten the right edge of the text, do the following: 

 Highlight all the text from "The remarkable Mr Presto" right down to the end "And they say 

entertainment is dead!" 

 Click the justify icon in the Home tab, on the Paragraph panel: 

 

Your finished article will then look like ours: 
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Reference Tab  
This tab has commands to use when creating a Table of Contents and citation page for a paper. It provides 

you with many simple solutions to create these typically difficult to produce documents. 

 

Word Count: 

Include text in footnotes, endnotes and text in boxes in the word count  

1) On the Review tab, in the Proofing group, click Word Count.  

2) In the Word Count dialog box, select the Include textboxes, 

footnotes and endnotes check box.  
Footnotes  
Footnotes and endnotes are used in printed documents to explain, 

comment on, or provide references for text in a document. You might use 

footnotes for detailed comments and endnotes for citation of sources.  
Footnotes and endnotes  
A footnote or an endnote consists of two linked parts — the note reference mark and the corresponding note 

text. 

1) Footnote and endnote reference marks  

2) Separator line  

3) Footnote text  

4) Endnote text  
Insert a footnote or an endnote  
Microsoft Word automatically numbers footnotes and endnotes for you. You 

can use a single numbering scheme throughout a document, or you can use 

different numbering schemes within each section in a document.  

Commands for inserting and editing footnotes and endnotes can be found on the References tab in the 

Footnotes group. 

1) Insert Footnote  

2) Insert Endnote  

3) Footnote & Endnote Dialog Box  
Delete a footnote  
When you want to delete a note, you work with the note reference 

mark in the document window, not the text in the note.  

In the document, select the note reference mark of the footnote or 
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endnote that you want to delete, and then press DELETE. 

If you delete an automatically numbered note reference mark, Word renumbers the 

notes in the new order. 

Table of contents  
On page two in the master template is inserted into a table of contents. When you 

apply styles throughout your document, Word 2010 will automatically create a TOC 

based on your headers.  

You create a table of contents by applying heading styles — for example, Heading 1, Heading 2, and 

Heading 3 — to the text that you want to include in the table 

of contents. Microsoft Word searches for those headings and 

then inserts the table of contents into your document.  

When you create a table of contents this way, you can 

automatically update it if you make changes in your 

document.  

5.1.1 Mark entries by using built-in heading styles  

1) Select the text that you want to appear in the table of contents.  

2) On the Home tab, in the Styles group, click the style that you want.  

Update the table of contents  

If you added or removed headings or other table of contents 

entries in your document, you can quickly update the table of 

contents.  

1) On the References tab, in the Table of Contents group, 

click Update Table  

2) Click Update page numbers only or Update entire table  
 

 

End of Class7 
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Check spelling and grammar  
1) On the Review tab, in the Proofing group, click Spelling & 

Grammar.  

 
Tip! You can access this command quickly by adding it to the Quick Access 

Toolbar by right-clicking the Spelling & Grammar button, and then clicking 

Add to Quick Access Toolbar on the shortcut menu.  

2) If the program finds spelling mistakes, a dialog box or task pane appears with the first misspelled word found 

by the spelling checker.  

3) After you resolve each misspelled word, the program flags the next misspelled word so that you can decide 

what you want to do.  

4) After the program finishes flagging the spelling mistakes, it shows you the grammar mistakes. For each 

mistake, click an option in the Spelling and Grammar dialog box.  

 

 

 

 

Inserting and Deleting Comments  
Word’s Comments feature is one of the most valuable for 

an academic setting. You can use it for grading, 

collaborating with colleagues (especially when grading 

and/or collaboration are taking place through email), and 

even writing notes to yourself.  

Insert a Comment  

1. Select the Review tab.  

2. Select the text you would like to comment on.  

3. Select the New Comment option. A red box appears on 

the right side of your document.  

4. Type your comment in the red box.  

Delete a Comment  
1. Right-click on the comment you wish to delete.  

2. Select the Delete Comment option.  

 

Track Changes  
Track Changes is a helpful tool for an academic setting. You can use it for collaborating with colleagues or 

editing students’ papers.  

Turning on Track Changes  
1. Select the Review tab.  

2. Select the Track Changes option. This turns the feature on.  
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After you have turned on Track Changes, Word records any changes you 

make to the document. These changes are be visible to anyone who sees 

the document. 

 

 
 

After you have turned on Track Changes, Word records any changes you make to the document. These changes 

are be visible to anyone who sees the document. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Turning off Track Changes  
1. Select the Review tab.  

2. Select the Track Changes option. If the feature is on, this turns it off.  

Accepting or Rejecting Track Changes and Comments  

If you receive a document with comments or tracked changes, you can choose to either accept these changes or 

apply them to your document, or you can reject 

them and retain your original content.  

Accepting Track Changes and Comments  
1. Select the Review tab.  

2. Select the tracked change or comment you wish 

to accept.  

3. Select the Accept option. If you accept a 

tracked change, it is fully applied to your 

document. If you accept a comment, it remains in 

your document so you can delete it when you are 

ready  

Rejecting Track Changes and Comments  
1. Select the Review tab.  

2. Select the tracked change or comment you wish 

to reject.  

3. Select the Reject option. The tracked change or comment disappears.  

 

Mail Merge: 
When you are performing a Mail Merge, you will need a Word document (you can start with an existing one or 

create a new one) and a recipient list, which is typically an Excel workbook. If you'd like to work along with 

the lesson, you can download the examples below. 

Unedited text 

 

Edited text 
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 Letter (Word document) 

 Recipient list (Excel workbook 

To use Mail Merge: 

1. Open an existing Word document, or create a new one. 

2. Click the Mailings tab. 

3. Click the Start Mail Merge command. 

4. Select Step by Step Mail Merge Wizard. 
The Mail Merge task pane appears and will guide you through the six main 

steps to complete a merge. The following is an example of how to create a form letter and 

merge the letter with a recipient list. 

Step 1: 

1. Choose the type of document you wish to create. In this example, select Letters. 

2. Click Next: Starting document to move to Step 2. 

 

 

 

Step 2: 

1. Select Use the current document. 

2. Click Next: Select recipients to move to Step 3. 

 

Step 3: 

Now you'll need an address list so Word can automatically place each address into the 

document. The list can be in an existing file, such as an Excel workbook, or you can type 

a new address list from within the Mail Merge Wizard. 

1. From the Mail Merge task pane, select Use an existing list, then click Browse. 

2. Locate your file in the dialog box (you may have to navigate to a different folder), 

then click Open. 

3. If the address list is in an Excel workbook, select the worksheet that contains the 

list, then click OK. 

 

4. In the Mail Merge Recipients dialog box, you can check or uncheck each recipient to control 

which ones are used in the merge. When you're done, click OK to close the dialog box. 
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5. From the Mail Merge task pane, click Next: Write your letter to move to Step  

 

Step 4: 

Now you're ready to write your letter. When it's printed, each copy of the letter will 

basically be the same, except the recipient data (such as the name and address) will be 

different on each one. You'll need to add place holders for the recipient data so Mail 

Merge knows exactly where to add the data. If you're using Mail Merge with an existing 

letter, make sure the file is open. 

 

 

To insert recipient data: 

1. Place the insertion point in the document where you wish the information to appear. 

2. Select Address block, Greeting line, Electronic postage, or More items from the task pane. 

3. Depending on your selection, a dialog box may appear with various options. Select the desired options, 

and then click OK. 

 

1. A placeholder appears in your document. For example: «AddressBlock». 

2. Repeat these steps each time you need to enter information from your data record. 

3. From the Mail Merge task pane, click Next: Preview your letters to move to Step 5. 

Step 5: 
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1. Preview the letters to make sure information from the recipient list appears correctly in the 

letter. You can use the left and right scroll arrows to view each document. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Click Next: Complete the merge to move to Step 6. 

Step 6: 

1. Click Print to print the letters. 

2. The Merge to Printer dialog box opens. Click All, then click OK. 
 

 

 

 

 

 

 

 

End of Class 8 
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Auto Correct: 
Automatically detect and correct typos and misspelled words 

For example, if you type teh plus a space, AutoCorrect replaces 

what you typed with the. Or if you type This is theh ouse plus a 

space, AutoCorrect replaces what you typed with This is the 

house.  

 

1) Click the File tab and then, under Help, click Options.  

2) Click Proofing.  

3) Click AutoCorrect Options.  

4) On the AutoCorrect tab, make sure the Replace text as you type check box is selected.  

5) In the Replace box, type a word or phrase that you often mistype or misspell — for example, type usually.  

6) In the With box, type the correct spelling of the word — for example, type usually.  

7) Click Add.  

8) Click OK.  
 

 

 

 

 

 

 

 

 

 

 

 

Word Count: 
Microsoft Word counts the number of words in a 

document while you type. Word can also count the 

following:  

 

 

 

spaces  

 

1) On the Review tab, in the Proofing group, click 

Word Count.  

2) In the Word Count dialog box, select the Include textboxes, footnotes and endnotes check box.  
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View Tab: 
This tab allows you to change the view of your document to a different two page document or zoom. 

Navigation pane:  
Looking for text or a table in your document? The new Navigation pane can help you find text, tables, 

graphics, comments, footnotes or endnotes, and equations.  

You can also get a quick look at the structure of your document, and you can change the structure by 

dragging headings inside the Navigation pane.  

To get the navigation pane in Word 2010, select the Navigation Pane in the Show group in the View tab 
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In Word 2010 you can do the following with the Navigation pane:  

 

you can work easily with the map even in deeply 

structured and complicated long documents.  

 

r copy 

headings and their content.  

the hierarchy.  

g to 

scroll around in the document.  

-authoring 

indicator.  

 

Thumbnail images of pages  

1) On the View tab, in the Show group, select the Navigation Pane check box.  

2) In the Navigation pane, click the Browse the pages in your document tab  
 

 

 

 

 

 

 

 

 

 

 

 

Layout Views: Use layout views while you are working on your document. Some of Layout Views are 

follows:  

a) Print Layout: Standard documents, such as letters, memos, and reports, are often written and edited in 

Print Layout view. One advantage of working in this view is its adherence to WYSIWYG (what you see is 

what you get). The margins, headers, and footers correspond to the printed output. Pages are shown as 

equivalent pieces of paper with physical breaks between pages. 

b) Full Screen Reading View: Full Screen Reading view is 

optimized for reading a document on the computer screen. In Full 

Screen Reading view, you also have the option of seeing the 

document as it would appear on a printed page. You should view 
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 Thumbnails Pane     

 Document 

 Document Map Pane     

 Document 

the document in full screen reading view to maximize the space available for reading or commenting on the 

document. 
c) Web Layout: Use web layout view to view the document as it would look like as a web page. In this view you can 

see the background, text is wrapped to fit the window, and images appear as they would online. 

d) Outline: Work in outline view to look at the structure of a document and to 

move, copy, and reorganize text by dragging headings. In outline view, you can 

collapse a document to see only the main headings, or you can expand it to see 

all headings and even body text. 

Outline view also makes it easy to work with master documents. A master 

document makes it easier to organize and maintain a long document, such as a 

multipart report or a book with chapters. In outline view, page boundaries, 

headers and footers, graphics, and backgrounds do not appear. 

To switch to outline view, click Outline on the View menu. 

d) Draft: Work in Draft view when speed is of primary importance. In Print Layout view, physical pages 

and breaks are drawn. Draft view displays a document as a continuous text scroll; page breaks are denoted 

by dashed lines. Because repagination occurs almost instantly as you compose, this is an ideal view if you 

have an older, slower computer. 

2) Viewing Modes: Use viewing modes when you want to read or move around in a document. 

a) Reading Layout View: To read a document with a minimum of eye strain and with tools optimized for 

reading, use reading layout view. Reading layout view is designed to make reading documents on the screen 

more comfortable. In this mode, Word removes distracting screen elements, such as extraneous toolbars. 

Word also uses your computer's screen resolution settings to size the document for optimum readability. 

Reading layout view does not display the document the way the document is formatted for printing. Text 

may appear larger than expected, and the page breaks do not necessarily correspond to breaks between 

printed pages. 

b) Thumbnails: Thumbnails are small renderings of each page in your document, displayed in a 

separate pane. Thumbnails give you a visual impression of the content of each page. You can click a 

thumbnail image to jump directly to a page. Thumbnails are available in normal view, print layout 

view, outline view, and reading layout view. They are not available in Web layout view or in conjunction 

with the Document Map. 
 

 

 

 

 

 

 

 

 

b) Document Map: The Document Map is a separate pane that displays a list of headings in the document. 

Use the Document Map to quickly navigate through the document and keep track of your location in it. 

When you click a heading in the Document Map, Word jumps to the corresponding heading in the 

document, displays it at the top of the window, and highlights the heading in the Document Map. You can 

show or hide the Document Map at any time. 

To switch to the Document Map, click Document Map on the View menu. 
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Working with Macro: 
To create a macro in Word, you first have to have something you want recorded, for this example, we will 

create a macro that will change the font of some highlighted text to Arial, the size to 16, and then make the 

text both bold and italicized, all automatically with just one click. 

Before you can record a macro to do what you want, you have to first know yourself how to do it so that you 

can record those steps. In this case, the way to do it is to first highlight some text, then, follow these steps: 

click on the Current Font box and choose Arial, then click on the Current Font size box and select 16, 

then finish by clicking on the Bold and Italicize icons. 

To create a macro to perform these steps, first highlight some text in your document, then click on the View 

tab on the main ribbon, then click on the tiny down arrow under the Macros icon to get the following drop-

down menu.. 

 

Click where it says Record Macro and you should get a screen like this: 

 

Type in a name for your macro, then click on the Button icon. 

Note: If you use more than one word in your macro name it must have an underscore between the two words 

or Word will reject it. 

You should get a screen that looks like this: 
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Click on the new macro name listed on the left side of the screen (under where it says <separator>) to 

highlight it, then click the Add button to add the macro to your Quick Access Toolbar , then click the Ok 

button. 

The macro setup window will go away and you will be taken back to your document and your cursor will 

have been turned into a tiny picture of an old fashioned tape recorder. This means your macro is recording, 

so now it’s time to do the things you want recorded. 

Click on the Current Font box and select Ariel. 

Click on the Font Size box and select 16. 

Click on the Bold and Italics icons. 

 

That’s all you want your macro to record, so to make it stop recording, click on the View tab again from the 

main ribbon, then click on Macros, and then Stop recording. 

 

Your macro should now be ready for use. To test it, highlight some text, then look at the Quick Access 

Toolbar; on it there should be a new Macro icon: 

 

To test your macro, highlight some text, then click on the new Macro icon on your Quick Access Toolbar. 

Your macro should run and perform all of the formatting tasks you assigned it to do. 

There are of course more options and ways to record macros in Word, but this is by far the easiest and 

simplest. 

End of Class 9 
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What is a spreadsheet? 
A spreadsheet is basically a document which has been 

divided into rows and columns. 

Excel and its fellow spreadsheet applications are designed to 

ease the management of numbers and calculations. Various 

commands and buttons make it easy to arrange and format 

columns of numbers and to calculate totals, averages, 

percentages, budgets, and complex financial and scientific 

formulas.  

The look of a spreadsheet application comes from the 

account ledgers that have been used to keep records for centuries. Ledger 

pages are lined off into rows and columns to record such things as items in 

inventory, income and expenses, debits and credits, and census data, like 

the illustration.  

The biggest advantages of a computer-based spreadsheet over these paper 

ledgers are the ability to create and update totals and other calculations 

automatically as you enter new data and the ability to search the whole 

document quickly. 

What is Excel? 
Excel is a spreadsheet program in the Microsoft Office system. You can use Excel to create and format 

workbooks (a collection of spreadsheets) in order to analyze data and make more informed business 

decisions. Specifically, you can use Excel to track data, build models for analyzing data, write formulas to 

perform calculations on that data, pivot the data in numerous ways, and present data in a variety of 

professional looking charts. 

Common scenarios for using Excel include: 

 Accounting You can use the powerful calculation features of Excel in many financial accounting 

statements—for example, a cash flow statement, income statement, or profit and loss statement. 

 Budgeting Whether your needs are personal or business related, you can create any type of budget in 

Excel—for example, a marketing budget plan, an event budget, or a retirement budget. 

 Billing and sales Excel is also useful for managing billing and sales data, and you can easily create the 

forms that you need—for example, sales invoices, packing slips, or purchase orders. 

 Reporting You can create various types of reports in Excel that reflect your data analysis or summarize 

your data—for example, reports that measure project performance, show variance between projected and 

actual results, or reports that you can use to forecast data. 

 Planning Excel is a great tool for creating professional plans or useful planners—for example, a weekly 

class plan, a marketing research plan, a year-end tax plan, or planners that help you organize weekly 

meals, parties, or vacations. 

 Tracking You can use Excel to keep track of data in a time sheet or list—for example, a time sheet for 

tracking work, or an inventory list that keeps track of equipment. 

 Using calendars Because of its grid-like workspace, Excel lends itself well to creating any type of 

calendar—for example, an academic calendar to keep track of activities during the school year, or a 

fiscal year calendar to track business events and milestones. 

 

Opening Excel 
You may have a shortcut to Word on your desktop, if so double click the icon and Word will open. If not 

follow the steps below:  

1. Click on the Start button  

2. Highlight Programs  

3. Highlight Microsoft Office  

4. Click on Microsoft Excel 2010  
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Interface  
If you have worked with Windows programs before, you already know a lot about Excel's window. It has all 

the normal window parts, like the Status bar, Title bar, scroll bars. The Excel window is actually a lot like 

what you saw in Word 2007/10/13. 

Spreadsheet Terms 
Term Explanation 

spreadsheet  Document that is entirely made up of rows and columns. Used to list and analyze data.  

Point of Confusion: People tend to use the word spreadsheet in two ways:   
 the entire Excel workbook file 

 an individual worksheet in a workbook 
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Term Explanation 

workbook The basic document for Excel. The default workbook name is Book1.xlsx where the extension 

xlsx seems to come from Excel spreadsheet in XML format. Older versions of Excel use a 

different format, xls. 

worksheet 

 
A single sheet of data. One or more worksheets make a workbook.  

Think of them as pieces of paper that are stacked on top of each other to form the workbook. 

The default workbook contains three worksheets, named Sheet1, Sheet2, Sheet3. You will 

want to change these names to something more interesting and helpful!  

The maximum number of worksheets in a workbook depends on your computer's 

memory.  

A worksheet, also called just a sheet or spreadsheet, can have up to 1,048,576 rows by 

16,384 columns with up to 32,767  characters in a single cell. This is enough for 

most purposes!  

workbook window The document window inside an Excel window. (See next section for illustrations) 

Excel 2013 shows each workbook in its own window.  

columns Named with letters in the following pattern: A, B, C,…Z, AA, AB, AC,…AZ, BA, BB, 

BC,…BZ, CA,…IA, IB,…IV... XFD, which is the last column possible. 

rows   Named with numbers from 1 to 1,048,576.  

cell Intersection of a row and a column on a worksheet. 

active cell 

 
Has a dark border around it and the row and column headers are colored. 

 This is the cell that receives your keystrokes and commands. You make a cell the active cell 

when you select it, by clicking it or by moving into it with keys. The TAB or the arrow keys 

are handy for moving from cell to cell. 
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Term Explanation 

grid lines 

 
The gray lines that form the cells. By default they don't print.   

If you want to print the gridlines, there is a check box in the Page Setup dialog  

sheet tab 

 
Each worksheet has a tab at the bottom of the workbook window with the name of the 

worksheet on it. 

active worksheet   The worksheet that receives your keystrokes and commands.  

It has a white sheet tab with its name in bold.  

If you group two or more worksheets together, you can have more than one active 

sheet. This is a cool feature, when it is not a disaster because you did not realize that 

your typing was going to show up on more than one sheet! 

workspace The area below the ribbon that holds your documents 

The Worksheet & Formula Bar 
The Formula Bar is a feature that is special to a 

spreadsheet program. To help keep life confusing, 

the term Formula Bar is used both for the whole bar 

you see above the cells and also for just the text box 

on the right above the cells, which displays what is 

in the selected cell. In older versions of Excel, you 

had to do all editing in the Formula Bar but recent 

versions let you edit directly in the cell. Much better!  

The Formula bar in Excel 2007, 2010, and 2013 

behaves the same, except from some color 

differences. 

The Name Box shows the cell reference for the current cell or for the upper left cell of the current selection 

or the name of the selected cell or range of cells.  

The buttons to the right of the Name Box apply to the Formula Bar.  

 Cancel: Clears any changes. 

 Enter:  Accepts changes and exits Edit mode. More typing will replace cell contents. 

 Insert Formula: Opens a dialog where you can choose one of Excel's pre-defined formulas. That 

dialog then opens the Function Arguments dialog, which has text boxes for you to fill in. No risk of 

typing errors messing up the formula you meant to enter! 
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Worksheet Terms  

Term Explanation 

headings  The buttons at the top of columns (letters) and at the left end of rows (numbers).  

For a selected column or row the heading is colored. 

enter data Select the cell, type your data, and press the ENTER key or click the Enter button 

on the Formula bar. What you typed is now contained in the cell.  

Name Box   At the top left above the sheet cells and headings. Used to display cell references and 

to assign and display names for a cell or a range of cells.  

range   

 
A rectangular set of cells, referred to by using the upper left and lower right cell 

references with a colon between them, like A2:C5 for the range illustrated at the right. 

The absolute reference for the range would be $A$2:$C$5.  

You select a range by dragging, for example from the upper left cell to the lower right 

cell. As you drag, the Name Box shows the number of rows and columns that are 

selected. Once you quit dragging, the Name Box displays the upper left cell only. 

Formula bar  
Shows the 

contents of a selected cell, whether it is plain text, numbers, or a formula. Sometimes 

the whole bar that contains the Name Box and the formula text box is called the 

Formula bar. Sometimes just the text box that shows the formula or text is meant.  

formula   Looks rather like part of an algebra equation, like =SUM(A4:D7) or =AVERAGE(C3, 

F5, H10). Most formulas use cell references to get the values to calculate with.  

cell reference or   

relative reference 

  

The usual way we refer to a cell, using the letter of the cell's column followed by the 

number of the cell's row, like B3 or AD345.    

Cool feature: If you move the contents of a cell, any formula that contains a 

relative reference to that cell is changed to match the new cell reference. A very handy 

feature - most of the time. 

absolute reference When you don't want the cell reference to change in a formula as things are moved 

around, you must use an absolute reference, by putting a $ in front of both the column 

letter and the row number, like $B$3 or $AD$345. 

Triangles in Cell Corners 
Microsoft Excel uses small triangles in the corner of a cell to indicate formula errors or comments. 

 Error = Green triangle in upper left corner  

 
Click the cell and the Trace Error icon appears. Click the arrow next to the icon to see a menu of options. 

 Comment = Red triangle in upper right corner  
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Hover over a cell to show an embedded comment.  

 
Create a New Workbook  

1. Click the File tab and then click New.  

2. Under Available Templates, double click Blank Workbook or Click Create  

Enter Data in a Worksheet  

1. Click the cell where you want to enter data.  

2. Type the data in the cell.  

3. Press enter or tab to move to the next cell.  

Select Cells or Ranges  

In order to complete more advanced processes in Excel you need to be able to highlight or select cells, rows 

and columns. There is a variety of way to do this, see the table below to understand the options. 

To select  Do this  

A single cell  Click the cell, or press the arrow keys to move to the cell.  

A range of cells  Click the first cell in the range, and then drag to the last cell, or hold 

down SHIFT while you press the arrow keys to extend the selection.  

A large range of cells  Click the first cell in the range, and then hold down SHIFT while you 

click the last cell in the range. You can scroll to make the last cell 

visible.  

All cells on a worksheet  Click the Select All button or press CTRL+A.  

Nonadjacent cells or cell 

ranges  

Select the first cell or range of cells, and then hold down CTRL while 

you select the other cells or ranges.  

NOTE: You cannot cancel the selection of a cell or range of cells in a 

nonadjacent selection without canceling the entire selection.  

An entire row or column  Click the row or column heading.  

Row heading  

Column heading  

Adjacent rows or columns  Drag across the row or column headings. Or select the first row or 

column; then hold down SHIFT while you select the last row or 

column.  

Nonadjacent rows or columns  Click the column or row heading of the first row or column in your 

selection; then hold down CTRL while you click the column or row 

headings of other rows or columns that you want to add to the 

selection.  
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To select  Do this  

Cells to the last used cell on 

the worksheet (lower-right 

corner)  

Select the first cell, and then press CTRL+SHIFT+END to extend the 

selection of cells to the last used cell on the worksheet (lower-right 

corner).  

Cells to the beginning of the 

worksheet  

Select the first cell, and then press CTRL+SHIFT+HOME to extend 

the selection of cells to the beginning of the worksheet.  

 

Modifying Spreadsheets  

In order to create an understandable and professional document you will need to 

make adjustments to the cells, rows, columns and text. Use the following processes to 

assist when creating a spreadsheet.  

Cut, Copy, and Paste Data  

You can use the Cut, Copy, and Paste commands in Microsoft Office Excel to move or copy entire cells or 

their contents. NOTE: Excel displays an animated moving border around cells that have been cut or copied. 

To cancel a moving border, press ESC. 

Move/Copy Cells  

When you move or copy a cell, Excel moves or copies the entire cell, including formulas and their resulting 

values, cell formats, and comments.  

1. Select the cells that you want to move or copy.  

2. On the Home tab, in the Clipboard group, do one of the following:  

a. To move cells, click Cut.  

b. To copy cells, click Copy.  

3. Click in the center of the cell you would like to Paste the information too.  

4. On the Home tab, in the Clipboard group, click Paste .  

NOTES: Excel replaces existing data in the paste area when you cut and paste cells to move them.  

When you copy cells, cell references are automatically adjusted. If the selected copy or paste area includes 

hidden cells, Excel also copies the hidden cells. You may need to temporarily unhide cells that you don't 

want to include when you copy information.  

Move/Copy Cells with Mouse  

1. Select the cells or a range of cells that you want to move or copy.  

2. To move a cell or range of cells, point to the border of the selection. When the pointer becomes a move 

pointer, drag the cell or range of cells to another location.  

Pointer Shapes 
The mouse pointer has a number of shapes in Excel. The shape indicates what the effect will be of your 

mouse actions and keystrokes. As you move the pointer around, it may flicker from one shape to another. 

The examples below were taken from Excel 2010, but Excel 2013 is the same except for color differences. 

 

Shape:  Used to:  

 

Select a cell or range 

 

Drag a selection to new location. The pointer must be over the border of the selection to 

change to the Move shape. 

 

Fill (copies values into the cells you drag across) or fill series (copies a pattern of values, 

such as filling in the days of the week or months of the year). 

 

Entering or editing data. The cursor (vertical line inside the cell) blinks. 

 

Resize column 

 

Resize row 
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Shape:  Used to:  

 

Select whole column 

 

Select whole row 

 

Copy cell formats with Format Painter 

 

Select & Navigate: Range 
A range is a rectangle of cells. The normal form for the range 

reference lists the upper left cell first, then the lower right 

cell, like B7:C9 or b7:c9. (The column letters do not have to 

be capitalized.)  

 

Range = upper left cell : lower right cell 

Name Box shows upper left only 

To select more than one cell is not hard, if the cells are next to each other. Just drag over the cells that you 

want.  

For cells and ranges that are scattered around (non-adjacent), you will need to use the CTRL key along with 

your mouse. The SHIFT key is a great help when you need to select large numbers of cells that are next to 

each other (adjacent).  

Highlight Colors 
When you select more than one cell, Excel highlights all but the first cell in the selection. The highlight 

color combines with any existing colors. When you select cells that have a dark background, the 

highlighting can be very hard to see, but the column and row headers for the selection change also, which is 

easier to spot. You just have to remember to look! The border around the selected cells changes color. The 

border itself may not show well at the edges of the sheet, next to the headers. 

Original Cells  Selected A1:C2 

 

 

 

 

Black text on white; 

border is thick 

Black text; 

colored background except upper left cell; 

border is thick 

Select & Navigate: Row/Column 
Suppose you want to rearrange the order of columns or you want to apply formatting to a whole row. You 

need to select whole rows or whole columns but no one wants to scroll to the far edges of a sheet to do this 

kind of selecting. (Remember the 1,048,576 rows in 16,384 columns!) 
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So, what's the easy way? Use the column and row headers to do your selecting!  

 

 

 

 

 

Home Tab  
This is the most used tab; it incorporates all text and cell formatting features such as font and paragraph 

changes. The Home Tab also includes basic spreadsheet formatting elements such as text wrap, merging 

cells and cell style. 

Column Width and Row Height  

On a worksheet, you can specify a column width of 0 to 255 and a row height of 0 to 

409. This value represents the number of characters that can be displayed in a cell 

that is formatted with the standard font. The default column width is 8.43 characters 

and the default row height is 12.75 points. If a column/row has a width of 0, it is 

hidden.  

Set Column/Row Width/Height  

1. Select the column(s) or row(s) that you want to change.  

2. On the Home tab, in the Cells group, click Format.  

3. Under Cell Size, click Column Width or Row Height.  

4. A Column Width or Row Height box will appear.  

5. In the Column 

Width or Row Height 

box, type the value 

that you want your 

column or row to be.  

                                         

 

 

 

 

Automatically Fit Column/Row Contents  

1. Click the Select All button  

2. Double-click any boundary between two column/row headings.  

3. All Columns/Rows in the entire worksheet will be changed to the new size  

NOTE: At times, a cell might display #####. This can occur when the cell 

contains a number or a date that exceeds the width of the cell so it cannot display 

all the characters that its format requires. To see the entire contents of the cell with 

its current format, you must increase the width of the column. 
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Set Column/Row Width/Height with Mouse  

To change the width of one column/row  

1. Place you cursor on the line between two rows or columns.  

2. A symbol that looks like a lower case t with arrows on the horizontal line will 

appear  

3. Drag the boundary on the right side of the column/row heading until the 

column/row is the width that you want.  

To change the width of multiple columns/rows  

1. Select the columns/rows that you want to change  

2. Drag a boundary to the right of a selected column/row heading.  

3. All selected columns/rows will become a different size.  

To change the width of columns/rows to fit the contents in the cells  

1. Select the column(s) or row(s) that you want to change  

2. Double-click the boundary to the right of a selected column/row heading.  

3. The Column/Row will automatically be size to the length/height of the longest/tallest text.  

Merge or Split Cells  
When you merge two or more adjacent horizontal or vertical cells the 

cells become one larger cell that is displayed across multiple columns 

or rows. When you merge multiple cells, the contents of only one cell 

appear in the merged cell.  

Merge and Center Cells  

1. Select two or more adjacent cells that you want to merge.  

2. On the Home tab, in the Alignment group, click Merge and Center.  

3. The cells will be merged in a row or column, and the cell contents will be centered 

in the merged cell.  

Merge Cells  

To merge cells only, click the arrow next to Merge and Center, and then click Merge 

Across or Merge Cells.  
Split Cells  

1. Select the merged cell you want to split  

2. To split the merged cell, click Merge and Center. The cells will split and the 

contents of the merged cell will appear in the upper-left cell of the range of split cells.  

Formatting Spreadsheets  
To further enhance your spreadsheet you can format a number of elements such as text, numbers, coloring, 

and table styles. Spreadsheets can become professional documents used for company meetings or can even 

be published.  

Wrap Text  

You can display multiple lines of text inside a cell by wrapping the text. 

Wrapping text in a cell does not affect other cells.  

1. Click the cell in which you want to wrap the text.  

2. On the Home tab, in the Alignment group, click Wrap Text.  

3. The text in your cell will be wrapped.  

NOTE: If the text is a long word, the characters won't wrap (the word won't be split); instead, you can 

widen the column or decrease the font size to see all the text. If all the text is not visible after you wrap the 

text, you might have to adjust the height of the row. On the Home tab, in the Cells group, click Format, and 

then under Cell Size click AutoFit Row 

Format Numbers  

In Excel, the format of a cell is separate from the data that is stored in the cell. This display difference can 

have a significant effect when the data is numeric. For example, numbers in cells will default as rounded 

numbers, date and time may not appear as anticipated. After you type numbers in a cell, you can change the 

format in which they are displayed to ensure the numbers in your spreadsheet are displayed as you intended.  
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1. Click the cell(s) that contains the numbers that you want to format.  

2. On the Home tab, in the Number group, click the arrow next to the Number 

Format box, and then click the format that you want.  

If you are unable to format numbers in the detail you would like that you can click 

on the More Number Formats at the bottom of the Number Format drop down list.  

1. In the Category list, click the format that you want to use, and then adjust settings to the right of the 

Format Cells dialog box. For example, if you’re using the Currency format, you can select a different 

currency symbol, show more or fewer decimal places, or change the way negative numbers are displayed.  

 

 

 

 

 

 

 

 

 

Cell Borders  

By using predefined border styles, you can quickly add a border around cells or ranges of cells. If predefined 

cell borders do not meet your needs, you can create a custom border.  

NOTE: Cell borders that you apply appear on printed pages. If you do not 

use cell borders but want worksheet gridline borders for all cells to be 

visible on printed pages, you can display the gridlines.  

Apply Cell Borders  

1. On a worksheet, select the cell or range of cells that you want to add a 

border to, change the border style on, or remove a border from.  

2. Go to the Home tab, in the Font group  

3. Click the arrow next to Borders  

4. Click on the border style you would like  

5. The border will be applied to the cell or cell range  

NOTE: To apply a custom border style, click More Borders. In the 

Format Cells dialog box, on the Border tab, under Line and Color, click 

the line style and color that you want.  

Remove Cell Borders  

1. Go to the Home tab, in the Font group  

2. Click the arrow next to Borders  

3. Click No Border.  

NOTES: The Borders button displays the most recently used border style. 

You can click the Borders button (not the arrow) to apply that 

style.  

 

 

Cell Styles  
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You can create a cell style that includes a custom border, colors and accounting formatting.  

1. On the Home tab, in the Styles group, click Cell Styles.  

2. Select the different cell style option you would like applied to your spreadsheet.  

NOTE: If you would like to apply a cell fill and a cell border, select the cell fill color first ensure both 

formats are applied. 

Cell and Text Coloring  
You can also modify a variety of cell and text colors manually.  

Cell Fill  

1. Select the cells that you want to apply or remove a fill color from.  

2. Go to the Home tab, in the Font group and select one of the following 

options:  

a. To fill cells with a solid color, click the arrow next to Fill Color, and 

then under Theme Colors or Standard Colors, click the color that you want.  

b. To fill cells with a custom color, click the arrow next to Fill Color, click More 

Colors, and then in the Colors dialog box select the color that you want.  

c. To apply the most recently selected color, click Fill Color  

NOTE: Microsoft Excel saves your 10 most recently selected custom colors. To 

quickly apply one of these colors, click the arrow next to Fill Color, and then 

click the color that you want under Recent Colors.  

Remove Cell Fill  

1. Select the cells that contain a fill color or fill pattern.  

2. On the Home tab, in the Font group, click the arrow next to Fill  

Color, and then click No Fill.  

Text Color  

1. Select the cell, range of cells, text, or characters that you want to format with a 

different text color.  

2. On the Home tab, in the Font group and select one of the following options:  

a. To apply the most recently selected text color, click Font Color.  

b. To change the text color, click the arrow next to Font Color, and then under Theme  

Colors or Standard Colors, click the color that you want to use.  

Bold, Underline and Italics Text  

1. Select the cell, range of cells, or text.  

2. Go to the Home tab, in the Font group  

3. Click on the Bold (B) Italics (I) or Underline (U) commands.  

4. The selected command will be applied.  

Advanced Spreadsheet Modification  
Once you have created a basic spreadsheet there are numerous things you can do to make working with you 

data easier. Some of these elements are hiding, freezing and splitting rows. You can also sort and filter data, 

these features are quite helpful when working with a large amount of data.  

Hide or Display Rows and Columns  

You can hide a row or column by using the Hide command or when you change its row height or column 

width to 0 (zero). You can display either again by using the Unhide command. You can either unhide 

specific rows and columns, or you can unhide all hidden rows and columns at the same time. The first row 

or column of the worksheet is tricky to unhide, but it can be done.  

Hide Rows or Columns  

1. Select the rows or columns that you want to hide.  

2. On the Home tab, in the Cells group, click Format.  

3. Under Visibility, point to Hide & Unhide, and then click Hide Rows or Hide Columns.  
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NOTE: You can also right-click a row or column (or a selection of multiple rows 

or columns), and then click Hide.  

Unhide Rows or Columns  

1. Select the rows, columns or entire sheet to unhide.  

2. On the Home tab, in the Cells group, click Format.  

3. Under Visibility, point to Hide & Unhide, and then click Unhide Rows or 

Unhide Columns.  

TIP You can also right-click the selection of visible rows and columns 

surrounding the hidden rows and columns, and then click Unhide. 

Using the Fill Series Command 

If you have a specialized or very long list, it may be more efficient to use the 

EDIT, FILL, SERIES option. 

Examples If you had to have a column numbered 1 to 600, it would be quicker to 

use the EDIT, FILL, SERIES command. Another example is if you had to have a 

monthly date entered for 25 years (for a mortgage repayment schedule??) 

The screenshot above shows the example of having a column numbered from 1 to 600. 

1. Type a #1 in a blank cell. 

2. Click on EDIT, FILL, SERIES 

3. Select either ROWS or COLUMNS (specifies where data will 

be filled – column is 

the more common). 

4. Excel recognizes #1 as being a number and therefore has 

automatically selected LINEAR. 

5. Make sure Step Value = 1, and Stop value = 600 

6. Click on OK to finalize. 

NOTES: Linear – will create a linear series based on the value 

you have entered on the worksheet. If the TREND option is 

cleared, Linear uses the value in the STEP VALUE text box. This value is the amount you want adding each 

time to the value you have on the worksheet – 1 would make it 1,2,3,4 etc. 2 would make it 1,3,5,7 etc). 

STOP VALUE is the value you want to stop at. 

If TREND is enabled, the STEP VALUE AND STOP VALUE are greyed out. In this scenario you would 

enter an example of the trend desired in 2 or more cells on the worksheet, then select all the cells which you 

want filling before going to the EDIT, FILL, SERIES command. For example, if you put #5 in cell A1, and 

#10 in cell A2, then select A1:A12, the result would be 5,10,15,20,25,30,35,40…..60. 

Growth – will create a series whereby the number is multiplied by the number in the STEP VALUE. If you 

have #1 in cell A1, then go into EDIT, FILL, SERIES and select COLUMN, GROWTH, STEP VALUE = 2 

and STOP VALUE = 20 the result would be 1,2,4,8,16. 

 

Creating a Conditional Format 
Steps 1-8 show how to make cells in Column D in the 

screenshot below change color if a student has passed 

(using 19 marks or over as the benchmark), (the 

formula will have to refer to the data in Column C to 

work this out). Steps 9-10 show how to make the 

score in Column C change color if a student has 10 

marks or less (to show that they have failed). 

A working example of the following has been set up 

on the CONDITIONAL FORMATTING worksheet 

which is in the Advanced Excel Exercises workbook. 

1. Click in the first cell that will have conditional 
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formatting attached (D6) 

2. Click on FORMAT, CONDITIONAL FORMATTING. The CONDITIONAL 

FORMATTING dialog box will appear. 

 

 

 

 

 

3. Change the first dialogue box to FORMULA IS. This allows you to enter the instructions to refer to 

another location other than the one you are currently in. 

4. The formula is the condition i.e. to find out if the figure to the left is greater than or equal to (>=) the pass 

mark of 19 . If you use the pointer to enter the cell address, make sure you change it to relative (as a default 

Excel will make it Absolute). 

5. Click on the FORMAT button 

6. In the FORMAT CELLS dialogue box that appears, make all the required changes. 

 

 

 

 

 

 

 

In the example being used here you would choose the PATTERNS tab, and then choose a yellow fill colour 

for the cell.  

7. Click on OK (twice) to finalise the formatting. 

8. To copy the formatting to the rest of the cells in the column either: 

• use the FORMAT PAINTER ; 

• use the fill handle (use this only if the cell contains a formula) to copy to the other cells – beware - if you 

use the fill handle on cells containing values, you will change the values; or 

• use the normal COPY command and then use the EDIT, PASTE SPECIAL, 

FORMATS option to apply to the other cells 

9. To apply conditional formatting to an active cell (in our example, changing the cell to red if the student 

has 10 or less marks) - place the cursor in Cell C6. Click on 

FORMAT, CONDITIONAL FORMATTING 

10. Select CELL VALUE IS (this will make Excel look at the value of the cell you are currently placed in). 

Make the changes the same as the screenshot below (the fill color is red). Click on OK to finish, then copy 

the formatting to the rest of the column as 

previously described. 

 

 

 

 

End of Class10 
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View Tab  
This tab allows you to change the view of your document including freezing or splitting panes, viewing 

gridlines and hide cells. 

View Choices 
All views listed below have buttons on the View tab except Print 

Preview and Full Screen in Excel 2013. There are buttons at the 

bottom right of the Status Bar for Normal, Page Layout, and Page 

Break Preview. 

View tab > Workbook Views tab group 

View: Normal  

1. If necessary, select the View tab and click on button Normal .  

 

Alternate method: Click the Normal view button at the right of the Status Bar.  

Normal View displays the document with the grid lines in gray. This is the default view.  

In Normal view you may see a dotted line between rows or columns to show where a page break falls. Such 

a line is hard to see and only shows after you have viewed the document in a way that shows how it fits on 

paper and then return to Normal view.  

View: Page Layout 

1. On  View tab, click the button Page Layout. 
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Alternate method: Click the Page Layout view button at the right of the Status Bar.  

 Page Layout shows how the spreadsheet will fit on paper. It is not a Print Preview because you can add a 

header or footer. Just click in the header or footer area and type or insert what you want. You can also edit 

what is in the cells. 

View: Page Break Preview   
1. On the Status bar, click the button Page Break Preview. 

Excel 2007, 2010:  
A message may appear that explains this view.   

 

Alternate Method: On the View ribbon tab, click the button Page Break Preview . 

 

2. Click on OK to close the Welcome dialog if it appeared.  
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The Page Break Preview uses wide blue lines to show what parts of the worksheet that will print on 

the same page.   

Pages are labeled with large gray numbers (that won't print) in the center of each page area so you 

can see what order the sections of the worksheet will print. The size of the gray text depends on the 

size of the area. 

For large sheets with many rows and columns, it can get confusing as to what parts will print on 

which pages and in what order.  

View: Full Screen  
For large spreadsheets you may need a larger space to work in. Full Screen View can help with that. 

1. Change to Full Screen View: 

Excel 2007, 2010: On the View tab click the button Full Screen .  

  

 

The view expands to take up the whole monitor screen except for the Windows taskbar at the bottom. 

The ribbon and Status bar for the Excel window go into hiding.  
2. Return to Normal View:  

Excel 2007, 2010: Press the ESC key.  

Your screen returns to the previous view.  

View: Split  
Sometime you need to see widely separated areas of a sheet at the same time. You can split the screen into 2 

or 4 panes that you can scroll separately. 

The Split button on the View tab automatically divides the CURRENT window into 4 equal panes. There are 

also horizontal and vertical split bars which create just 2 panes. If you resize the window, the 4 panes do not 

resize. 

1. On the View tab click the button Split. 
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A Split View with four panes is created.  

View: Frozen Panes  
Frozen panes do not scroll while the rest of the sheet does. This effect is used primarily to hold labels for 

the rows and/or columns in place while you scroll to the part of the sheet you are interested in. Without the 

labels it can be hard to tell what you are looking at. 

1. Scroll the window vertically until row 4 is out of sight. 

Is it easy to tell what these columns mean without the labels? 

2. Scroll the window horizontally until column A is out of sight. 

Is it easy to know what these rows mean without the labels?  

3. Select row 5.  

 

4. On the View tab click the Freeze Panes button. 

A menu with three choices appears. The first choice freezes the rows above the selected cell and the 

columns to the left of the selected cell.  

5. Click on the first choice, Freeze Panes. 

The rows above your selected row are frozen.  Since you selected the whole row, no columns are 

frozen. 
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6. Scroll up and down.  

The top four rows of the sheet stay put! 

 
7. Unfreeze the pane: Click the Freeze Pane button again and select Unfreeze Panes. 

8. Select Column B and then freeze the panes. The columns to the left of your selected column are 

frozen. 

9. Scroll left and right. The first column remains in place. 

10. Unfreeze the panes. 

11. Select cell B5 and freeze the panes.  

The rows above and the column to the left are frozen. 

12. Scroll up and down and also left and right. The top and left of the sheet remain in place so you can 

see the labels. Very useful on large sheets. 

13. Unfreeze the panes. 

View: Print Preview  
There is no button for Print Preview on the View tab. Unexpected!  

Excel 2007 and Excel 2010/13 handle Print Preview differently. All three versions can have a Print Preview 

button on the Quick Access Toolbar. (Recommended!) 

Remember the No-Print Area: The bottom rows of the Budget sheet will not show in Print Preview. In 

Page Break Preview, we changed the print area to leave them out. If those rows are included, the print-out 

takes 4 sheets of paper.  

1. Open Print Preview: 

2. Excel 2010: Click the File tab and then on Print.  
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3. The print preview appears at the right of the Print pane in the Backstage view. The Status bar below the 

preview shows that there are 2 pages. You can use the arrows at the bottom or the vertical scrollbar to 

see other pages. The header you created earlier shows here on all pages. The cells that you excluded in 

Page Break Preview are not here. At the bottom right is the Zoom to Page button .Clicking this 

button toggles between showing the whole page at once and showing 100% zoom. You cannot adjust the 

zoom otherwise. Also at the bottom right is the button to show/hide margins .Dotted lines shows where 

the page margins are. You can drag them to new locations and the document will re-wrap. 

4. 

 

5. Experiment: Print Preview 

Try out the choices in the ribbon or pane. What can you change from here? Excel 2007 and 2010/13 are 

quite different here. 

Change the page orientation to Landscape. (In Excel 2007 open Page Setup to do this.) 

How many pages will print now?  

6. No editing allowed in Print Preview. 

7. Save to your Class disk in the folder excel project1 with the name 

budget-2010-views-Firstname-Lastname.xlsx 
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8. Print the whole worksheet in Portrait orientation. 

[Check with your instructor before printing. There may be special instructions for using your classroom 

computer or perhaps you need to submit your document electronically.] 

 

Insert Tab  
This tab allows you to insert a variety of items into a document from pictures, clip art, and headers and 

footers. 

Charts in Excel  

Microsoft Excel no longer provides the chart wizard. Instead, you can create a basic chart by clicking the 

chart type that you want on the Insert tab in the Charts group. Charts are used to display series of numeric 

data in a graphical format to make it easier to understand large quantities of data and the relationship 

between different series of data.  

To create a chart in Excel, you start by entering the numeric data for the chart on a worksheet. Then you can 

plot that data into a chart by selecting the chart type that you want to use on the 

Insert tab, in the Charts group. Worksheet data  

Chart created from worksheet data 

A chart has many elements. Some of these elements are displayed by default; 

others can be added as needed. You can change the display of the chart elements 

by moving them to other locations in the chart, resizing them, or by changing the 

format. You can also remove chart elements that you do not want to display.  

1 The chart area is the entire chart and all its elements  

2 The plot area is the area of the chart bounded by the axes.  

3 The data points are individual values plotted in a chart 

represented by bars, columns, lines, or pies.  

4 The horizontal (category) and vertical (value) axis 

along which the data is plotted in the chart.  

5 The legend identifies the patterns or colors that are 

assigned to the data series or categories in the chart.  

6 A chart and axis title are descriptive text that for the 

axis or chart.  

7 A data label provides additional information about a 

data marker that you can use to identify the details of a 

data point in a data series.  

Create a Chart  

1. On the worksheet, arrange the data that you want to 

plot in a chart. The data can be arranged in rows or 

columns — Excel automatically determines the best way to plot the data in the chart.  

2. Select the cells that contain the data that you want to use for the chart.  

NOTE: If the cells that you want to plot in a chart are not in a continuous range, you can select nonadjacent 

cells or ranges as long as the selection forms a rectangle. You 

can also hide the rows or columns that you do not want to 

plot in the chart.  

3. Go to the Insert tab, in the Charts  

4. Click the chart type, and then click a chart subtype from 
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the drop menu that will appear.  

5. Click anywhere in the embedded chart to activate it. When you click on the chart, Chart Tools will be 

displayed which includes the Design, Layout, and Format tabs.  

6. The chart will automatically be embedded in the worksheet. A chart name will automatically be assigned.  

Move Chart to New Sheet  

1. On the Design tab, in the Location group, click Move Chart.  

2. Under Choose where you want the chart to be placed, click on the New sheet bubble  

3. Type a chart name in the New sheet box.  

Change Chart Name  

1. Click the chart.  

2. On the Layout tab, in the Properties group, click the Chart Name text box.  

3. Type a new chart name.  

4. Press ENTER.  

Change Chart Layout  

1. Click anywhere in the chart.  

2. Go to the Chart Tools, the Design group  

3. In the Chart Layouts, click the chart layout that you want to use. To see all 

available layouts, click More .  

Change Chart Style  

1. Click anywhere in the chart.  

2. On the Design tab, in the Chart Styles group, click 

the chart style that you want to use. To see all 

predefined chart styles, click More.  

Chart or Axis Titles  

To make a chart easier to understand, you can add titles, such as chart and axis titles.  

To add a chart title:  

1. Click anywhere in the chart.  

2. On the Layout tab, in the Labels group, click Chart Title.  

3. Click Centered Overlay Title or Above Chart.  

4. In the Chart Title text box that appears in the chart, type the text that you want.  

5. To remove a chart title, click Chart Title, and then click None.  

NOTE: You can also use the formatting buttons on the ribbon (Home tab, Font group). To format the whole 

title, you can right-click it, click Format Chart Title, and then select the formatting options that you want. 

To add axis titles:  

1. Click anywhere in the chart.  

2. On the Layout tab, in the Labels group, click Axis Titles.  

3. Do one or more of the following:  

a. To add a title to a primary horizontal (category) axis, click Primary Horizontal 

Axis Title, and then click the option that you want.  

b. To add a title to primary vertical (value) axis, click Primary Vertical Axis 

Title, and then click the option that you want.  

4. In the Axis Title text box that appears in the chart, type the text that you want.  

5. To remove an axis title, click Axis Title, click the type of axis title to remove, 

and then click None.  

Data Labels  

1. On a chart, do one of the following:  

a. Click on the chart area to add a data label to all data points of all data series  

b. Click in the data series to add a data label to all data points of a data series  
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c. Click on a specific data point to add a data label to a single data point in a data series  

2. On the Layout tab, in the Labels group, click Data Labels, and then click the display option that you want.  

3. Text boxes will appear in the area of your chart based on your selection.  

4. Click on the text box to modify the text.  

5. To remove data labels, click Data Labels, and then click None.  

NOTE: Depending on the chart type that you used, different data label options will be available. 

Legend  

When you create a chart, the legend appears, but you can hide the legend or change its 

location after you create the chart.  

1. Click the chart in which you want to show or hide a legend.  

2. On the Layout tab, in the Labels group, click Legend.  

3. Do one of the following:  

a. To hide the legend, click None.  

b. To display a legend, click the display option that you want.  

c. For additional options, click More Legend Options, and then select the display 

option that you want.  

NOTE: To quickly remove a legend or a legend entry from a chart, you can select it, 

and then press DELETE. You can also right-click the legend or a legend entry, and 

then click Delete. 

 

 

End of Class11 
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Data Tab  
This tab allows you to modifying worksheets with large amounts of data by sorting and filtering as well as 

analyzing and grouping data. 

Macros in Excel are not macros in the normal sense. Excel comes with its own programming language, 

Visual Basic for Applications. This means that very powerful macros can be created by almost anyone with 

the time and patience to construct them. A macro is a recording of actions to automate tasks that are tedious 

or you do frequently. 

Filter: 

Select the data that you want to filter     

 

 

 

 

 

 

On the Data tab, in the Sort & Filter group, click Filter. 

 

 

 

 

 

Click the arrow   in the column header to display a list in which you can make filter choices. 

Note    Depending on the type of data in the column, Microsoft Excel displays either Number Filters or Text 

Filters in the list. 

Filter by selecting values or searching     

Selecting values from a list and searching are the quickest ways to filter. When you click the arrow in a 

column that has filtering enabled, all values in that column 

appear in a list. 

1. Use the Search box to enter text or numbers on which to 

search 

2. Select and clear the check boxes to show values that are found 

in the column of data 

3. Use advanced criteria to find values that meet specific 

conditions 

To select by values, in the list, clear the (Select All) check box. 

This removes the check marks from all the check boxes. Then, 

select only the values you want to see, and click OK to see the 

results. 

To search on text in the column, enter text or numbers in 

the Search box. Optionally, you can use wildcard characters, 

such as the asterisk (*) or the question mark (?). Press ENTER to 

see the results. 

 



RRKKMMSSWWSS                                                                  

Option from Data and Review Tab, Track Changes, Protection, Goal Seek, Scenarios, Solver etc. Creating Macro 

 

2 

 

 

Advanced Filter: 

This example teaches you how to apply an advanced filter to only 

display records that meet complex criteria. 

When you use the Advanced Filter, you need to enter the criteria on the 

worksheet. Create a Criteria range (blue border below for illustration 

only) above your data set. Use the same column headers. Be sure there's 

at least one blank row between your Criteria range and data set. 

And Criteria 

To display the sales in the USA and in Qtr 4, execute the following 

steps. 

1. Enter the criteria shown below on the worksheet. 

2. Click any single cell inside the data set. 

3. On the Data tab, in the Sort & Filter group, click Advanced. 

 
4. Click in the Criteria range box and select the range A1:D2 (blue). 

5. Click OK. 

Notice the options to copy your filtered data set to another location and 

display unique records only (if your data set contains duplicates). 

Result. 

 
 

Goal Seek 

What if you want to know how many books you need to sell for the highest price, to obtain a total profit of 

exactly $4700? You can use Excel's Goal Seek feature to find the answer. 

1. On the Data tab, click What-If Analysis, Goal Seek. 

 
The Goal Seek dialog box appears. 

2. Select cell D10. 

3. Click in the 'To value' box and type 4700. 

4. Click in the 'By changing cell' box and select cell C4. 
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5. Click OK. 

 
Result. You need to sell 90% of the books for the highest price to obtain a total profit of exactly $4700. 

 

 
 

Scenarios: 

Create Different Scenarios 

But what if you sell 70% for the highest price? And what if you sell 80% for the highest price? Or 90%, or 

even 100%? Each different percentage is a different scenario. You can use the Scenario Manager to create 

these scenarios. 

Note: You can simply type in a different percentage into cell C4 to see the corresponding result of a scenario 

in cell D10. However, what-if analysis enables you to easily compare the results of different scenarios. Read 

on. 

1. On the Data tab, click What-If Analysis and select Scenario Manager from the list. 

 
The Scenario Manager dialog box appears. 

2. Add a scenario by clicking on Add. 
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3. Type a name (60% highest), select cell C4 (% sold for the highest price) for the Changing cells and click 

on OK. 

 
 

4. Enter the corresponding value 0.6 and click on OK again. 

 
 

5. Next, add 4 other scenarios (70%, 80%, 90% and 100%). 

Finally, your Scenario Manager should be consistent with the picture below: 
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Solver: 

Excel includes a tool called solver that uses techniques from the operations research to find optimal 

solutions for all kind of decision problems. 

Load the Solver Add-in 

To load the solver add-in, execute the following steps. 

1. On the green File tab, click Options. 

 
 

3. Check Solver Add-in and click OK. 
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4. You can find the Solver on the Data tab. 

 

 
Formulate the Model 

The model we are going to solve looks as follows in Excel. 

 
 

1. To formulate this linear programming model, answer the following three questions. 

a. What are the decisions to be made? For this problem, we need Excel to find out how much to order of 

each product (bicycles, mopeds and child seats). 

b. What are the constraints on these decisions? The constrains here are that the amount of capital and storage 

used by the products cannot exceed the limited amount of capital and storage (resources) available. For 

example, each bicycle uses 300 units of capital and 0.5 unit of storage. 

c. What is the overall measure of performance for these decisions? The overall measure of performance is 

the total profit of the three products, so the objective is to maximize this quantity. 

2. To make the model easier to understand, name the following ranges. 
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Range Name Cells 

UnitProfit C4:E4 

OrderSize C12:E12 

ResourcesUsed G7:G8 

ResourcesAvailable I7:I8 

TotalProfit I12 

 

3. Insert the following three SUMPRODUCT functions. 

 
 

Explanation: The amount of capital used equals the sumproduct of the range C7:E7 and OrderSize. The 

amount of storage used equals the sumproduct of the range C8:E8 and OrderSize. Total Profit equals the 

sumproduct of UnitProfit and OrderSize. 

Trial and Error 

With this formulation, it becomes easy to analyze any trial solution. 

For example, if we order 20 bicycles, 40 mopeds and 100 child seats, the total amount of resources used 

does not exceed the amount of resources available. This solution has a total profit of 19000. 

 
 

It is not necessary to use trial and error. We shall describe next how the Excel Solver can be used to quickly 

find the optimal solution. 

Solve the Model 

To find the optimal solution, execute the following steps. 

1. On the Data tab, click Solver. 
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Enter the solver parameters (read on). The result should be consistent with the picture below. 

 
 

You have the choice of typing the range names or clicking on the cells in the spreadsheet. 

2. Enter TotalProfit for the Objective. 

3. Click Max. 

4. Enter OrderSize for the Changing Variable Cells. 

5. Click Add to enter the following constraint. 

 
 

6. Check 'Make Unconstrained Variables Non-Negative' and select 'Simplex LP'. 

7. Finally, click Solve. 

Result: 
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The optimal solution: 

 
 

Protect Workbook: 

This example teaches you how to protect the workbook structure and windows in Excel. 

Structure 

If you protect the workbook structure, users cannot insert, delete, rename, move, copy, hide or unhide 

worksheets anymore. 

1. Open a workbook. 

2. On the Review tab, click Protect Workbook. 

 
3. Check Structure, enter a password and click OK. 

 
 

4. Reenter the password and click on OK. 
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Users cannot insert, delete, rename, move, copy, hide or unhide worksheets anymore. 

 
 

Recording a macro 

These are instructions for recording a simple macro – selecting a range of cells you need to enter data into 

on a regular basis. 

1. Select TOOLS, MACRO, RECORD NEW MACRO. The 

RECORD MACRO dialog box will appear. 

2. In the MACRO NAME text box, type a name for your macro. 

Macro names cannot include spaces – an underscore is a good 

way to separate words. Do not use a cell address in the name as 

this will cause an error. Also, you may not use names of 

commands that already exist, e.g. Close. We have used 

Select_Cells for our example. 

3. You may wish to give the macro a keyboard shortcut (which 

is typed in the SHORTCUT KEY text box). You can have a 

lower case or upper case letter. If you use a shortcut that is 

already assigned to another function (i.e. CTRL + B has already been assigned to BOLD), you will 

overwrite that shortcut whilst the workbook that is storing the macro is open. 

4. Decide where to store the macro This information gets entered in the STORE MACRO IN text box: 

• Personal Macro Workbook – a workbook that is usually hidden from view, amacro stored here will be 

available every time you use Excel, no matter which workbook or worksheet. 

• This Workbook – the current workbook. Useful if the macro 

you are going to record is only to be available when you are 

using this workbook. 

• New Workbook – Will open a new workbook where you can 

store the macro. You might do this because you want to have a 

similar macro workbook like the 

Personal Macro workbook – although unlike the Personal 

Macro workbook, this one will not open automatically. If you want to use the macros stored in this new 

workbook, you would have to physically open it first. 

5. If desired, fill in a brief description in the DESCRIPTION text box – this is for your information only. 
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6. Click on OK to start the recording process. You will be placed back in the main worksheet. A STOP 

RECORDING toolbar should appear (if not, click on VIEW, 

TOOLBARS, STOP RECORDING). This toolbar has two icons. An icon to stop the recording and one to 

toggle between recording relative or absolute addresses (explained later) 

Running a Macro 

The computer terminology for playing a macro is “Run”. 

To run a macro you can use any one of the methods 

following: 

1. Click on TOOLS, MACRO, MACROS (or use the 

keyboard shortcut ALT + F8), select your macro from the 

list. Click on RUN;  

2. Use the shortcut key if you created one (our example is 

CTRL + s); 

4. Use an icon on the toolbar if one has been created for the 

macro; or 

5. Use a button on the worksheet if one has been created 
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Sorting Data  
Sorting data is an integral part of data analysis. You might want to arrange a list of names in alphabetical 

order, compile a list of product inventory levels from highest to lowest, or order rows by colors or icons. 

Sorting data helps you quickly visualize and understand your data better, organize and find the data that you 

want, and ultimately make more effective decisions. 

Sort Data in Single Column  

1. Select a column of data in a range of cells  

2. On the Data tab, in the Sort & Filter group, do one of the following:  

     To sort in ascending or smallest to largest order, click Sort A to Z.  

     To sort in descending or largest to smallest order, click Sort Z to A.  

3. To reapply a sort after you change the data, click a cell in the range or table and then, on the Data tab, in 

the Sort & Filter group, click Reapply.  

Sort Data in Multiple Columns or Rows  

You may want to sort by more than one column or row when you have data that you want to group by the 

same value in one column or row, and then sort another column or row within that group of equal values.  

1. Select a range of cells with two or more columns of data.  

2. On the Data tab, in the Sort & Filter group, click Sort.  

3. The Sort dialog box will appear.  

4. Under Column, in the Sort by box, select the first column that you want to sort.  

5. Under Sort On, select the type of sort.  

   To sort by text, number, or date and time, select Values.  

   To sort by format, select Cell Color, Font Color, or Cell Icon.  

6. Under Order, select how you want to sort.  

    For text values, select A to Z or Z to A.  

    For number values, select Smallest to Largest or 

Largest to Smallest.  

    For date or time values, select Oldest to Newest or 

Newest to Oldest.  

   To sort based on a custom list, select Custom List.  

7. To add another column to sort by, click Add 

Level, and then repeat steps four through six.  

8. To copy a column to sort by, select the entry and 

then click Copy Level.  

9. To delete a column to sort by, select the entry and then click Delete Level.  

10. To change the order in which the columns are sorted, select an entry and then click the Up or Down 

arrow to change the order.  

11. To reapply a sort after you change the data, click a cell in the range or table and then, on the Data tab, in 

the Sort & Filter group, click Reapply.  

Consolidate: 

You can use Excel's Consolidate feature to consolidate your worksheets (located in one workbook or 

multiple workbooks) into one worksheet. Below you 

can find the workbooks of three districts. 

Before you start: if your worksheets are identical, it's 

probably easier to create 3D-references (if you have 

one workbook) or External References (if you have 

multiple workbooks) to consolidate your data. 
 

As you can see, the worksheets are not identical. 

However, the beauty of the Consolidate feature is that it can easily sum, count, average, etc this data by 

looking at the labels. This is a lot easier than creating formulas. 
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1. Open all three workbooks. 

2. Open a blank workbook. On the Data tab, click 

Consolidate. 

3. Choose the Sum function to sum the data. 

4. Click in the Reference box, select the range 

A1:E4 in the district1 workbook, and click Add. 

5. Repeat step 4 for the district2 and district3 

workbook. 

6. Check Top row, Left column and Create links to 

source data. 

Note: if you don't check Top row and Left column, 

Excel sums all cells that have the same position. 

For example, cell B2 (in distric1.xls) + cell B2 (in 

district2.xls) + cell B2 (in district3.xls). Because 

our worksheets are not identical, we want Excel to sum cells that have the same labels. If you check Create 

links to source data, Excel creates a link to your source data (your consolidated data will be updated if your 

source data changes) and creates an outline. 

7. Click OK. 

Result. 
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Data Validation Example 
In this example, we restrict users to enter a whole number between 0 and 10. 

 

Create Data Validation Rule 

To create the data validation rule, execute the following 

steps. 

1. Select cell C2. 

2. On the Data tab, click Data Validation. 

On the Settings tab: 

3. In the Allow list, click Whole number. 

4. In the Data list, click between. 

5. Enter the Minimum and Maximum values. 

 

 

 

 

 

 

 

 

 

 

 

 

Input Message 

Input messages appear when the user selects the cell and tell the user what to enter. 

On the Input Message tab: 

1. Check 'Show input message when cell is selected'. 

2. Enter a title. 

3. Enter an input message. 

Error Alert 

If users ignore the input message and enter a number that is not 

valid, you can show them an error alert. 

On the Error Alert tab: 

1. Check 'Show error alert after invalid data is entered'. 

2. Enter a title. 

3. Enter an error message. 

Data Validation Result 

1. Select cell C2. 
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2. Try to enter a number higher than 10. 

Result: 

Subtotal: 
Outlining data makes your data easier to view. In this example we 

will total rows of related data and collapse a group of columns. 

1. First, sort the data on the Company column. 

 
2. On the data tab, click Subtotal. 

 

 
3. Select the Company column, the column we use to outline our worksheet. 

4. Use the Count function. 

5. Check the Company check box. 

6. Click OK. 

Result: 
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7. To collapse a group of cells, click a minus sign. You can use the numbers to collapse or expand groups by 

level. For example, click the 2 to only show the subtotals. 

 
Note: click the 1 to only show the Grand Count, click the 3 to show everything. 

To collapse a group of columns, execute the following steps. 

8. For example, select column A and B. 

9. On the data tab, click Group. 

 

10. Click the minus sign (it will change to a plus sign). 

Result: 

 

11. To remove the outline, click any cell inside the data set and on the data tab, click Subtotal, Remove all. 

Data Table: 

To create a two variable data table, execute the following steps. 

1. Select cell A12 and type =D10 (refer to the total profit cell). 

2. Type the different unit profits (highest price) in row 12. 

3. Type the different percentages in column A. 

4. Select the range A12:D17. 

We are going to calculate the total profit for the different combinations of 'unit profit (highest price)' and '% 

sold for the highest price'. 
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5. On the Data tab, click What-If Analysis and select Data Table from the list. 

 
6. Click in the 'Row input cell' box (the unit profits are in a row) and select 

cell D7. 

7. Click in the 'Column input cell' box (the percentages are in a column) 

and select cell C4. 

We select cell D7 because the unit profits refer to cell D7. We select cell 

C4 because the percentages refer to cell C4. Together with the formula in 

cell A12, Excel now knows that it should replace cell D7 with $50 and 

cell C4 with 60% to calculate the total profit, replace cell D7 with $50 and 

cell C4 with 70% to calculate the total profit, etc. 

8. Click OK. 

Result. 

 

Conclusion: if you sell 60% for the highest price, at a unit profit of $50, you obtain a total profit of $3800, if 

you sell 80% for the highest price, at a unit profit of $60, you obtain a total profit of $5200, etc. 

Note: the formula bar indicates that the cells contain an array formula. Therefore, you cannot delete a single 

result. To delete the results, select the range B13:D17 and press Delete. 
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Formulas & Functions 
The organization of the formulas is new to Excel 2010. Previously in Excel 2007, to obtain all of the formulas Excel 

had to offer you had to click on the AutoSum dropdown arrow and select More Functions. Here there are the same 

options that appeared in the More Functions dialog box now appear on the Formula Tab. Each formula is divided up 

among relevant general topic categories. The categories are listed across the top of the Formula Tab group titled 

Function Library. 

 

With the new Excel Formula Bar the majority of all formulas you may need are at your fingertips. For example: a 

Math professor is interested in determining which formula would be best to convert radians to degrees. We will go to 

the Formula Tab, and select the Math & Trig downward arrow. 

Tip: When you scroll the mouse over a formula Excel will have a small dialog box that explains the purpose of each 

formula. 

Basic Formulas 
Add the Values in Rows or Columns 

Use the SUM function, which is prewritten formula, to add all the values in a row or column: 

1. Click your mouse in the cell in which you wish your result to appear 

2. Click the AutoSum button on the Home Tab or the Formulas Tab 

3. Highlight the range of cells you wish to add 

4. Press Enter 

1. To add some of the values in a column or row: 

1. Type an equal sign, type SUM, then type an opening parenthesis. 

2. Type or select the cell references you want to add. A comma (,) separates individual arguments that tell the 

function what to calculate 

3. Type a closing parenthesis, and then press ENTER. 

2. For example: =SUM(B2:B4, B6) and =SUM(B2, B5, B7) 

3. Find the Average, Maximum, or Minimum 

4. Use the AVERAGE, MAX, OR MIN functions. 

1. Click your mouse in the cell in which you wish your result to appear 

2. Click the arrow next to AutoSum on the Home Tab or the Formulas Tab. 

3. Click the Average, Max, or Min 

4. Highlight the range of cells you wish to find the value for 

5. Press Enter 

5. To see more functions, click More Functions on the AutoSum list to open the Insert Function dialog box 

6. OR go to the Formulas Tab and click on the More Functions orange textbook icon. 

Ranges and Individual Cells 
As you start to write excel formulas, you may realize you want to use a range of cells or nonadjacent cells in your 

formula. A range of cells will include the value of every cell within the range specified (for example, the range A1:A4 

includes the cells A1, A2, A3 & A4). Ranges of cells are identified with a colon. 

Nonadjacent cells can be listed in the formula by separating them with a comma rather than a colon. For example, 

=SUM(A2,A4) will add cells A2 and A4, but not A3. 

Copy a Formula 
Using the Fill Handle 

1. Select the cell that contains the formula, then position the 

mouse pointer over the lower-right corner of the cell until the 

black cross (+) appears. 

2. Drag the fill handle over the cell or cells to which you want to 

copy the formula, then release the mouse button. 
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Using Traditional Copy & Paste 

1. Select the cell that contains the formula, and on the Edit menu, click Copy. 

2. Select the cell or cells that you want to copy it to. 

a. To copy the formula and any formatting, on the Edit menu, click Paste. 

b. To copy the formula only, on the Edit menu, click Paste Special, and then click Formulas. 

Referencing Cells in Formulas 
You can include or reference other cells in a formula. When you do, the result of the formula depends on the values in 

the referenced cells and changes automatically when the values in the referenced cells change. This is extremely 

powerful in what-if scenarios. 

To see how this works, enter 10 in cell A1. Now select cell A2 and type =A1*2, and press ENTER. The value in cell 

A2 is 20. If you change the value in cell A1 from 10 to any value, the value in cell A2 will also change. Cell 

references are especially helpful when you create complex formulas, or conduct what-if analysis. 

Pressing [F4] repeatedly over a reference (cell) will allow you to 

switch between making the column, the row, or nothing 

‘Absolute.’ 

Relative References 
By default Excel uses Relative Referencing. In relative reference, you actually refer to cell that is above or below or 

left or right to a number of rows or columns. For example, if you refer to cell D2 from F2, you are actually referring to 

a column that is two columns to the left of cell D2 and in the same row (the second ‘2’row). When a formula that 

possesses a relative reference is copied from one cell to another cell, the value in the copied cell also changes. i.e., if 

you copy a formula =C2+D2 from E2 to the cell F2, the formula in F2 adjusts in such a way that when the cell F2 is 

dragged downwards by one row, the formula automatically changes to C3+D3 and places the resulting value of 

C3+D3 in cell F3. 

Absolute References 
In case, if you wish to maintain the original references as they were, then you should make use of the absolute 

references. If you want to make the above example retain the original reference when it is copied, then you should 

precede the columns A2 and B2 and the row number by a Dollar ($) symbol. i.e., you should use the formula as 

=$C$2+$B$2 so that when you copy the formula the original reference is retained. 

To make the cell appear in absolute format ($) click on the cell you would like to edit and press [F4] and press enter. 

You will observe the cell A1 turn into =$A$1. 

For example, if you copy or fill an absolute reference in cell B2 to cell B3, it stays the same in both cells 

=$A$1. 

Mixed References 
In some situations, you may need to make the cell reference as ‘Mixed’ reference, so that you can lock either a column 

or a row by preceding it with a Dollar ($) symbol. For example, if you use a formula as 

=$D4+E4, then you are making the value that is present in cell D4 as absolute and the value in cell E4 as Relative. 

References to Other Worksheets 
You can refer to cells in other worksheets within the same workbook just as easily as you refer to cells in the same 

worksheet. For example, to enter a reference to cell A2 in Sheet2 into cell A1 in Sheet1, do this: 

1. Select cell A1 in Sheet1, and type an equal sign. 

2. Click the Sheet2 tab. 

3. Click cell A2, and then press Enter. 

After you press Enter, Sheet1 is now active. Select cell A1, and you will see that it contains the formula 

=Sheet2!A2. 

The exclamation point separates the worksheet portion of the reference from the cell portion. 

Other Workbook References 
You can refer to cells in worksheets in other workbooks in the same way you refer to cells in other worksheets within 

the same workbook. These references are called external references. For example, to enter a reference to Book2 in 

Book1, follow these steps: 

1. Create 2 workbooks; Book1 and Book2 

2. Select cell A1 in Sheet1 of Book1, and type an equal sign. 

3. Switch to Book2. Click to select A2. 

4. Press Enter 
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After you press enter, your formula in Workbook 1, Cell A1, should be =[Book2]Sheet1!$A$2. This reference has 3 

parts: The Workbook Book2 in square brackets, the worksheet and the cell. So referencing cells in external workbooks 

by selecting the workbook, then worksheet, and then the cell you want to reference. 

Quick Reference Guide 
Add, Subtract, Multiply & Divide 
Type an equal sign (=), use math operators, and then press ENTER. 

=10+5 to add 

=10-5 to subtract 

=10*5 to multiply 

=10/5 to divide 

Formulas are visible in the formula bar when you select a cell that contains a result. If the formula bar is not visible, 

on the Tools menu, click Options. Click the View tab, and select the Formula bar check box. 

Understand Error Values 
##### The column is not wide enough to display the content. Increase column width, shrink contents to fit the 
column, or apply a different number format. 
#REF! A cell reference is not valid. Cells may have been deleted or pasted over. 
#NAME? You may have misspelled a function name. 

Practical Purposes of Excel Formulas 
Excel formulas are used to make the data you have entered more useful. Through the use of formulas you are able to, 

at a minimum, maintain finances, schedules, and detailed reports. Here are a few examples of some common ways 

Excel formulas may be applied into your daily activities. Additional formulas will be described in detail later on in the 

tutorial. 

Using Date & Time Formulas 

In this example we have a list of birthdays. Our objective with this data is to find out how 

many birthdays occurred more than six months ago, and how many occurred five years 

ago. To start we want to know todays date. 

 

Step 1: Click in cell A2. Type in =TODAY() and press ENTER. 

The computer will automatically enter in today’s date. 

 

Step 2: Click in cell C2. In this example, we want this value to be five years before 

today’s date. To do this, the formula must be =EDATE(A2-60) and press enter. 

 60 months in five years 

 If you simply get a numerical value instead of a date, that means you have to format 

the cell to be a date. 

Right click on the cell and click Format Cells. In the Number tab of the format dialog box, choose Date.   

Choose whatever date format you wish and then click Ok. 

 

Step 3: Select your current data (A4:B10) and go to the Home Tab. 

Click on the Sort & Filter dropdown arrow and select Filter. Now in 

the Name and Birthday column you should see a dropdown arrow. 

Click on the arrow under Birthday and select Date Filters and 

between. 

 

Step 4: You will be prompted with an AutoFilter box which we will 

use to help sort your data. 

 In the “is after or equal to” field, put the date that occurred five 

years ago 

 In the “is before or equal to” field, put today’s date 

 Click Ok 

 

Step 5: Any dates ranging between the dates five years ago and today’s 

date will show, but all others will disappear from view. 

Step 6: We can do basically the same thing we just did by using a 
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formula. We will use the AND formula because we have two things to check. 

 First, click the down arrow by Birthday and click Clear Filter from “Birthday” 

 Add a new column heading in C5 reading 

 
Today to 5y Ago 
Step 7: Click your mouse in C6 and enter =AND( click on cell B5 is greater than or equal to only 

B2, and comma B5 is less than or equal to only A2. 

o =AND(B5>=$B$2,B5<=$A$2) 

o Note that we are using an absolute reference for A1 and A2 because we don’t want our formula to reference cells 

lower than those if/when we drag/copy the formula. 

Step 8: Click enter, it will show us the statement is TRUE. months ago, and how many occurred five years ago. To 

start we want to know todays date. 

Step 1: Click in cell A2. Type in =TODAY() and press ENTER. 

The computer will automatically enter in today’s date. 

 

Step 2: Click in cell C2. In this example, we want this value to be five years before today’s date. To do this, the 

formula must be =EDATE(A2-60) and press enter. 

 60 months in five years 

 If you simply get a numerical value instead of a date, that means you have to format the cell to be a date. 

Right click on the cell and click Format Cells. In the Number tab of the format dialog box, choose Date. 

Choose whatever date format you wish and then click Ok. 

 

Step 3: Select your current data (A4:B10) and go to the Home Tab. Click on the Sort & Filter dropdown arrow and 

select Filter. Now in the Name and Birthday column you should see a dropdown arrow. Click on the arrow under 

Birthday and select Date Filters and Between. 

Step 4: You will be prompted with an AutoFilter box which we will use to help sort your data. 
 In the “is after or equal to” field, put the date that occurred five years ago 

 In the “is before or equal to” field, put today’s date 

 Click Ok 

 

Step 5: Any dates ranging between the date five years ago and today’s date will show, but all others will disappear 

from view. 

 

Step 6: We can do basically the same thing we just did by using a formula. We will use the AND formula because we 

have two things to check. 

 First, click the down arrow by Birthday and click Clear Filter from “Birthday” 

 Add a new column heading in C5 reading 

Today to 5y Ago 
 

Step 7: Click your mouse in C6 and enter =AND( click on cell B5 is greater than or equal to only B2, and comma B5 

is less than or equal to only A2. 

 =AND(B5>=$B$2,B5<=$A$2) 

 Note that we are using an absolute reference for A1 and A2 because we 

don’t want our formula to reference cells lower than those if/when we 

drag/copy the formula. 

 

Step 8: Click enter, it will show us the statement is TRUE. 

 

Step 9: Now we want to have this formula we just created to be applied to 

the entire list of birthdays. To do this roll your mouse over C5 until you get 

the + symbol from the mouse. Once the mouse pointer looks like the +, drag 

all the way to the bottom of the column and release. Each column will now 

have a TRUE or FALSE in the box indicating that the birthday was between 

six months to five years ago, and will indicate FALSE if the birthday was 

within the last five years. 
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Commonly Used Functions & Formulas 
Below is a list and description of commonly used formulas within Excel. 

 
Math & Trig Icon 
PRODUCT Function 
The PRODUCT function provides a quick way to multiple numbers in a Excel. The advantage of using this function 

becomes apparent if you have several numbers to multiply together. It is easier then building a long formula. 

The syntax for the PRODUCT function is: =PRODUCT( Number1, Number2, ... Number255 ) 

TIP: Up to 255 numbers can be entered into the function. 

SUMIF Function 
The SUMIF function is used to add up the values in cells in a selected range that meet certain criteria. 

The syntax for the SUMIF function is: = SUMIF (Range, Criteria, Sum Range) 

Range - the group of cells the function is to search. 

Criteria - determines whether the cell is to be counted or not. 

Sum Range - the data range that is summed if the first range meets the specified criteria. If this range is omitted, the 

first range is summed instead. 

SUMIFS Function 
The SUMIFS function adds up the data in selected cells when specific criteria are met in two or more ranges of data. 

The SUMIFS function works like the AND function in that it only sums the data if the criterion for each range is true. 

The syntax for the SUMIFS function is: =SUMIFS ( Sum_range, Criteria_range1, Criteria1, 

Criteria_range2, Criteria2, ...) 

Sum_range - the range of cells to be added. 

Criteria_range - the range of cells the function is to search. 

Criteria - determines whether a cell in the Sum_range is to be counted or not. 

Note: Up to 127 range/criteria pairs can be entered into the function. 

ROUND Function 
The ROUND function is used to reduce a given value to a specific number of decimal places. 

The syntax for the ROUND function is: = ROUND ( Number, Num_digits ) 

Number - the value to be rounded. 

Num_digits - the number of decimal places to reduce the above number to. 

ROUNDOWN Function 
The ROUNDDOWN function is used to round a number down towards the next lowest number. ROUNDDOWN is 

similar to the ROUND function except that it always rounds a number downward while the ROUND function will 

round up or down depending on whether the last digit is greater than or less than 5. For example, the ROUND function 

would round the number 34.567 up to 34.6 because the second decimal place (6) is greater than 5. Since 

ROUNDDOWN doesn't care whether the second digit is greater or less than 5 it rounds the answer down to 34.5. 

The syntax for the ROUNDDOWN function is: = ROUNDDOWN ( Number, Num_digits ) 

Number - the value to be rounded. 

Num_digits - the number of decimal places to reduce the above number to. 

ROUNDUP Function 
The ROUNDUP function is used to round a number upwards towards the next highest number. 

ROUNDUP is similar to the ROUND function except that it always rounds a number upward while the 

ROUND function will round up or down depending on whether the last digit is greater than or less than 5. 

For example, the ROUND function would round the number 34.231 down to 34.2 because the second decimal place 

(3) is less than 5. Since ROUNDUP doesn't care whether the second digit is greater or less than 5 it rounds the answer 

up to 34.3. The syntax for the ROUNDUP function is: = ROUNDUP ( Number, Num_digits ) 

Number - the value to be rounded. 

Num_digits - the number of decimal places to reduce the above number to. 
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Logical Icon 
IF Function 
The IF function, one of Excel’s logical functions, tests to see if a certain condition in a spreadsheet is true or false. 

The syntax for the IF function is: =IF ( logical_test, value_if_true, value_if_false ) logical_test – a value or expression 

that is tested to see if it is true or false. value_if_true – the value that is displayed if logical_test is true. value_if_false 

– the value that is displayed if logical_test is false. 

 
Lookup & Reference Icon 
VLOOKUP Function 
Excel's VLOOKUP function, which stands for vertical lookup, is used to find specific information that has been stored 

in a spreadsheet table. 

Note: The data in the table should be sorted in ascending order (alphabetically A to Z). 

The syntax for the VLOOKUP function is: = VLOOKUP ( lookup_value , table_array , col_index_num , 

range_lookup ) 

lookup _value: The value you want to find in the first column of the table_array. 

table_array: This is the table of data that VLOOKUP searches to find the information you are 

after. 

The table_array must contain at least two columns of data. The first column contains the lookup_values. 

col_index_num: The number of the column in the table_array that contains the data you want 

returned. 

range_lookup: A logical value (TRUE or FALSE only) that indicates whether you want VLOOKUP 

to find an exact or an approximate match to the lookup_value. Typing False will return exact 

matches only. 

 

TRANSPOSE Function 
The TRANSPOSE function, one of Excel's Lookup & Reference functions, is used to copy data located in a row into a 

column or copy data located in a column into a row. 

The syntax for the TRANSPOSE function is: { = TRANSPOSE ( Array )} 

Array - the range of cells to be copied from the horizontal to the vertical or vertical to the horizontal. 

The curly braces " { } " surrounding the function indicate that it is an array function. 

 

Date & Time Icon 
NETWORKDAYS Function 
The NETWORKDAYS function, one of Excel's Date and Time functions, can be used to count the number of working 

days between two dates - such as the start and end dates for a project. The function automatically removes weekend 

days from the total. Specific holidays can also be omitted. 

The syntax for the NETWORKDAYS function is: = NETWORKDAYS ( Start_date , End_date , Holidays ) 

Start_date - the start date of the chosen time period. 

End_date - the end date of the chosen time period. 

Holidays - can be used to exclude one or more dates from the total number of working days 

 

AutoSum 
AVERAGE Function 
The AVERAGE function, one of Excel's statistical functions, is used to find the average or arithmetic mean of a given 

list of arguments. The syntax for the AVERAGE function is: = AVERAGE ( argument1, argument2, ... argument255 ) 

Argument1, argument 2, ... argument 255 can be numbers, named ranges, arrays, or cell references. 

Tip: Up to 255 arguments can be entered. 

MAX Function 
The MAX function, one of Excel's statistical functions, is used to find the largest or maximum number in a given list 

of values or arguments. The syntax for the MAX function is: =MAX( argument1, argument2, ... argument30 ) 

Argument1 ... argument 30: The arguments can be numbers, named ranges, arrays, or cell references. 

Up to 30 arguments can be entered. 
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MIN Function 
The MIN function, one of Excel's statistical functions, is used to find the smallest or minimum value in a list of 

numbers or arguments. The syntax for the MIN function is: =MIN ( argument1, argument2, ... argument30 ) 

Argument1 ... argument 30: Arguments can be numbers, named ranges, arrays, or cell references. Up to 

30 arguments can be entered. 

 

Statistical 
AVERAGEIF Function 
The AVERAGE IF function is used to find the average of values in cells in a selected range that meet certain criteria. 

The syntax for the AVERAGE IF function is: =AVERAGEIF( Range, Criteria, Sum Range) 

Range - the group of cells the function is to search. 

Criteria - the number, expression, or text statement that the data in the Range above is to determines whether the cell 

is to be counted or not. 

Average_range - the data range that is averaged if the first range meets the specified criteria. If this range is omitted, 

the first range is averaged instead. 

COUNTIF Function 
The COUNTIF function, one of Excel's COUNT functions, is used to count up the number of cells in a selected range 

that meet specified criteria. The syntax for the COUNTIF function is: =COUNTIF ( Range, Criteria) 

Range - the group of cells the function is to search. 

Criteria - determines whether the cell is to be counted or not. This can be a number, expression, cell reference, or text 

string. 

End of Class14 
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Insert a Pivot Table 

To insert a pivot table, execute the following steps. 

1. Click any single cell inside the data set. 

2. On the Insert tab, click PivotTable. 

 

The following dialog box appears. Excel automatically selects the data for you. The default location for a 

new pivot table is New Worksheet. 

3. Click OK. 

 

Drag fields 

The PivotTable field list appears. To get the total amount exported of each product, drag the following 

fields to the different areas. 

1. Product Field to the Row Labels area. 

2. Amount Field to the Values area. 

3. Country Field to the Report Filter area. 
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Below you can find the pivot table. Bananas are our main export product. That's how easy pivot tables can 

be! 
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Introduction:  
When you have information or ideas to share with an audience, you must do some kind of presentation. You 

could just talk and wave your hands around a lot. But, most of us find it helpful to to see your points up on a 

screen. We like to have printed handout sheets to take home and to make notes on during your presentation, 

too. All of these supplements to your words can be created using presentation software (also called 

presentation graphics). 

 

Slide sorter view of a short presentation (PowerPoint 2013) 

Advantages: Slides 

 Your audience can follow along, even if they dozed off (for just a minute, of course!). 

 Pictures and charts explain some things much better than words. 

 Sounds, music, and video can make a strong impact and show what even still pictures cannot. 

 

Advantages: Print-outs 

 Your audience can review your points later from the print-out. 

 Your audience can take notes along side your points. 

 Your audience can share what they learned with others who missed your excellent presentation. 

 You can use the Notes Page print-out to include all the other stuff you would like to say to expand on the 

slide points. They can act as your cue cards.  

 

First slide of the example 
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Fortunately, you do not have to choose between these different kinds of "presentations". You can do them all 

from the same software!!  

In this set of lessons you will learn how to create, edit, and run a presentation. You will also learn how to put 

your presentation into hard copy and into a self-running format. 

 

What is a presentation? 
A presentation is a set of slides, generally in outline format.  

Presentations are used most often to accompany a speech. 

However, a presentation can also be set up to run all by itself. You 

can print the slides in several different layouts. 

The illustration above has one title slide and twelve content slides. 

Thumbnails of the slides show at the left of the PowerPoint 

window.  

In this first project the presentations that you will create are just 

plain text. Adding the pretty stuff is in the next two projects. 

 

What you need for a slide show 

To show a presentation to a large group you need: 

 a screen 

 a computer 

 a projector 

 the correct cable to connect the computer to the projector  

Of course, for just a couple of people, you could have them gather around 

your computer's monitor screen. But for four or more, you need to shine your 

presentation onto a wall or a large screen. That's just what PowerPoint is 

about! 

 

Examples: 

In case you are still not sure what a presentation is, there are two ways to view below. 

The first downloads a PowerPoint Show, which automatically plays the presentation full screen on your 

computer monitor. PowerPoint must be installed on your computer for this one to work.  

The second uses PowerPoint Online to run the presentation in a frame on this page. So you have to be online 

for this method to work. 

 

How to Start: 
To begin Microsoft PowerPoint, go to Start Menu > All Programs > Microsoft Office > Microsoft 

PowerPoint 2010 (Figure 1). Select PowerPoint Presentation from the Project Gallery if a blank document 

does not open. 
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PowerPoint Window: 

 

Interface: Views 
The PowerPoint interface has several different views to help you do your work. Most of your time will be 

spent in Normal view. 

Presentation Views:  
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Normal View- with slide thumbnails 

 

Normal  View - with Outline 

 

Notes Page 

 

Slide Sorter 

 

Reading View 
 

Slide Show 

 

Print Preview - 2007 

 

Print Preview - 2010 

 

Print Preview -2013 

Master Views: 

The Masters control the default look and behavior of your slides and handouts. You can configure a master 

for each slide layout, like Title & Content, Two Content, and Section Header. 

 

Master -  

Title slide 

 

Master - 

Title & Content 

 

Master - Notes Page 

 

Master - Handout 

Views Bar   
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There is a Views toolbar tucked away at the bottom right of the PowerPoint window next to the Zoom slider. 

It has buttons for only 4 views: Normal, Slide Sorter, Reading, and Slide Show. 

Slide Sorter is a handy view when you need to move slides around or select and delete several at a time. 

Reading view runs the presentation in the PowerPoint window with the ribbon and navigation pane hidden.  

Slide Show runs the presentation full screen.   

Where are the commands to change views? 

 Views Bar:  
 Ribbon: View tab > Presentation Views group and Master Views group 

 

 

 PowerPoint 2007, 2010: Navigation pane in Normal View: Tabs for Slide thumbnails and Outline  

 Quick Access Toolbar: Print Preview - if you followed the steps in a previous lesson. 

 Office button menu/File tab: Print > Print Preview 

Adding/Deleting Slides 
To add a new slide click onto the Home tab click on the New Slide tool and use the slide layout thumbnails 

to select the layout for your new slide. To change a layout, select the slide you want to change, click on the 

Layout tool and select the layout thumbnail that will be replacing the current layout. 
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Delete a slide by selecting the slide in the left column and selecting Cut from the Clipboard group in the 

Home tab or pressing the Delete key on the keyboard. 

 

Slide Pane 
The Normal View is where you will do most of your work.  The Normal view usually shows three panes: 

Navigation, Slide, and Notes.  

First we will take a closer look at the Slide Pane. 

 

Slide Pane 

 A large version of the selected slide in the Navigation Pane appears in the Slide Pane.  

 You will do most of your editing and format changes directly on the slide.  

 

What's On A Slide? 

Most slides have placeholders to hold your text. A placeholder is a special kind of text box.  

What text appears in the outline? 
Only text that is in a placeholder will show up in the outline in the Navigation Pane. PowerPoint creates 

placeholders when you apply a slide layout to a slide. The outline will not see text that you put in a text box. 

that you created yourself. 

 

Example Slide Layouts with Placeholders: 

A selected placeholder shows a thin border with circles (resizing handles). 
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Title Slide:  

Placeholders for the title and subtitle of the 

whole presentation 

Title & Content: 

Placeholders for slide title and bullet list 

(the default layout for a new slide)  

 

What can you do directly on a slide? 

 Enter and edit text. 

 Insert a picture, chart, table, text box., or other object. 

 Resize or move an object or placeholder. 

 Add an AutoShape, with or without its own text. 

 

Slide Show View: Control with Keyboard 
You can use the keyboard to advance through the slides or to back up or to jump around when you need to 

skip slides or return to a previous slide. 

When the slides are a distraction to your speech or discussion or during a break, you can turn the screen 

black or white with a key combo. 

Action Key(s) 
Show first slide Home 

Show last slide End 

Advance one step Page Down 

Down arrow 

Right arrow 

N (for Next) 

space 

ENTER 

Back up one step Page Up 

Up arrow 

Left arrow 

P (for Previous) 

BACKSPACE 

Jump to slide # of slide and press ENTER 

Whites/unwhites screen W 

, (comma) 

Blacks/unblacks screen B 

. (period) 

Stop presentation and return to 

PowerPoint 

ESC 

CTRL + BREAK 

- (hyphen) 

Views: Print Preview 

You have a number of choices to make if you want to print your 

presentation. Happily, you can preview before printing. 

Print Preview in PowerPoint is a bit different from the preview in 

other programs. You must choose a print layout from several 

possibilities.  
PowerPoint 2010, 2013: Print Preview is part of the BackStage View on the 
File ribbon tab. The preview is at the right with controls for your options in 
the middle panel. 
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Print Layout Examples 

 

Slides 

Each slide takes a whole page 
 

Handouts- 1 slide per page 

 

Handouts - 2 slides per page 

 

Handouts- 3 slides per page 

Includes lines for taking notes. 

 

Handouts- 4 slides per page 

 

Handouts- 6 slides per page 

 

Handouts- 9 slides per page 

 

Notes Pages 

One slide per page  

with its Notes 

 

Outline 

 

Photo Album: 

 Here you can create a series of slides or an entire presentation based on images you select from your 

computer. Clicking on the Photo Album tool brings up a dialog box to select images and format the series 

of slides to place in your presentation, including frames and captions. 
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Design Tab 

The Design tab contains the groups for the tools regarding the formatting of the layout and general look of 

the document. Here you can set the slide size and orientation (i.e. Landscape versus 

Portrait), add a preformatted theme or set a background color. Note 

that Themes and Background Color employ Live Preview to see what the theme or color 

would look like on the slide before applying it. 

 

If you want to create a custom theme, you can set the Colors, Fonts, and Effects of the fonts and accents, by 

using the individual tools next to the preformatted themes. You can also set a custom background in the 

Background Styles tool. Here there are some preformatted colors that you can choose. Create a background 

of your own by 
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selecting Format Backround. Here you can set up a backround with a solid, gradient or 

picture/texture fill. 

 

Animations Tab 
The Animations tab contains groups for the tools relating to adding custom animations to 

slide objects within a slide. 

 
Adding animation: Choose to have text dissolve onto the slide, art objects fly in from an angle, or sound 

build as a slide is presented. 

1. On your slide you have either text boxes, images or charts (called Slide Objects). Click once on one of 

the Slide Objects (text or images) to select it. 

2. In the Animations tab click Add Animation to bring up a listing of common effects to add. 
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1.  

2. You can also access a complete listing of animations for Entrance, Emphasis, or Exit effects by selecting 

More Entrance/Emphasis/Exit Effects. 

3. Once you have selected this option, the appropriate palette will appear on the right side of the slide. 

5. Now you can single click on any animation and preview the effect on the selected object. This window 

also shows the full range of effects that are a available.  
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Click OK to add the effect. 

NOTE: You can only animate one slide at a time. 

Once the animation has been applied, you can click on the Animation Pane tool to customize the applied 

animation in terms of timing, triggers for the animation. 
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Transitions Tab 

 

The next. The default transition doesn’t involve any special effects. 

1. Select the slide from the thumbnails on the left. 

2. Click on the selection to apply the effect on the current slide. The effect occurs between the selected and 

previous slide. 

 
3. You can then select Effect Options for the transition and slide advancement settings in the tools to the 

right of the transitions. Click Apply to All to apply the settings to all slides. 

 

Slideshow Tab 

 

The Slideshow tab contains tools for setting up and viewing the slideshow presentation. 

Here you can view the slide show from the beginning or from a current selected slide. 

Slide Masters Use the Slide Master feature in PowerPoint to help develop consistency in your presentation 

by adding a new style/format to one slide then have it apply to all slides in the presentation. 

With the Slide Master feature you can: 

 Change the default typeface style and color for all slides in a presentation 
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  a company logo, name, department or date to a presentation 

  headers, footers and notes to all slides in a presentation to change to a Slide Master click on the 

Slide Master button in the Presentation Views group. Make desired changes then click on the Close 

Master View button to finish. 

 

 



RRKKMMSSWWSS                                                                        

Concept of DBMS, RDBMS, Field, Record, Database File, Different Field Types. Creating, Saving, 

Opening, Closing, Dropping, Accessing of Database. 

 

1 

 

What is a database?  

 

 

 

 

 

 

 

A database is basically just a list. Some lists are a lot more complicated than others! 

You use databases every day. Your grocery list, address book, and telephone book are all simple databases. 

(VERY simple!) A teacher's grade book, an accounting ledger sheet, and the address cards in a rolodex are 

also simple databases. You don't need a computer and special software to use these, just good eyes and 

perhaps a sharp pencil. 

Computer database software is useful or even required for more complex databases, like a store's inventory, 

a bank's records of your deposits and withdrawals, the state's database of crimes, an airline's database of 

upcoming flights and reservations. These are more than just simple lists! 

Types of Databases 
Databases can be organized into types based on: 

 Structure (like text, flat file, and relational)  

 Content (bibliography data, full-text documents, images, numbers, info about other databases)  

 Function (static information or allowing changes).  

A database of databases is called a meta database. Some just list the available databases. Others can reach 

into those databases to select documents or data.  

We will be looking at three of the types based on their structure: text, flat file, and relational. There are other 

types of database structures besides these!  

After this first project, you will work with relational databases.  

Database Terms 
Field = one item of data 

     Example:  the last name or the city in an address book.  

     Field name = value, like LASTNAME = "Washington".  

Record = a set of fields that belong together 

Example- Student info: ID#, name, preferred name, which section, which line in the grade book, birth date, 

bus number 

 

Data type = Each field has a data type, such as text, number, memo, OLE object, etc. Most data types also 

have attributes, like the size of the field or a default value. 
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Relational Database 
Most recent databases are relational databases. These are made up of a set of related tables. Each table is 

made up of records which are made up of a set of fields, just like the single table in a flat database.  

Printing any one table does not show all of the data. It can be very difficult to print a relational database in a 

way that shows all of the data at once because there is so much more data included than in a flat file 

database. The more data in a record and the more records you will have in your database, the more useful a 

relational database will be to you.  

 

Advantages 

 Avoids duplication of data 

   Example: Student info and Assignments are in separate tables that are linked to a table of Scores 

   Example: Supplier info and Customer info are in separate tables that are linked to the Orders.  

Reduces file size by avoiding duplication 

 Can keep data consistent 

   Example: Choosing from a list of suppliers avoids winding up with "My Supplier, Inc." in one record 

and just "My Supplier" in another. Totals and groupings won't work if the names are not exactly the 

same. 

 Faster queries 

Disadvantages 

 More complex 

 More difficult to set up initially 
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How to Start M S. Access 

Start-> M. S. Office-> M. S. Access 2010 

Access Window: 

 

Data type 

The type of data is allowed in a field. There are several allowed data types: 

AutoNumber: Assigns a number for each record automatically. The best way to be sure each record 

has a unique ID. 

Text: Stores text and numbers and symbols, up to 255 characters. 

Number: Stores numbers only. 

Currency: Accepts numbers and formats as money. 

Date/Time: Stores dates and times. Tricky to work with. 

Memo: Accepts alphanumeric data. Use when you might need more than 255 characters. Cannot be 

sorted. 

Hyperlink: Accepts alphanumeric text and formats as a hyperlink, like an email address or a link to 

a web page. 

Attachment: Accepts one or more objects like photos or Word documents or PDF files.  
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Different Form View: 
In many ways Excel actually is more user-friendly in its database features than Microsoft Works, but not in 

everything.  

 

Form View: Unlike in Excel, even in a basic database like Microsoft Works, you can rearrange and format 

the form view to suit yourself. Color is nice, but even nicer is being able to see all the fields in a compact 

form and with enough room to write. 
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Report View: Reports in Microsoft Works can give you a basic print-out. Some of the fields in the Star 

Wars Collectibles database need more room than the default formatting gives.  

 

Happily, the Report Design View lets you make some adjustments to the formatting of the report like 

widening the space, adding text wrapping, and changing the font.  

Clearly the report is based on a datasheet layout.  

You can move fields to a second row for the report and group the records.  

The example at the right groups the records by YearMade and puts a dividing line between the groups. It 

also formats the fields to wrap the text.  

 

Be forewarned - The text in a field will be cut off if you did not leave enough space in the report design 

view.  
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Queries 
A query can organize the data from one or more tables. It can sort the records into a particular order or filter 

results to show only the records that match certain criteria. Calculated fields in a query can combine text 

fields or do math with number values. 

Design View 
Nowadays queries are often designed visually. You can drag the fields that you want to see in your results 

from the table to the columns in the Design View. Choose which columns to sort on and add restrictions as 

criteria. You can even create new calculated fields based on the original ones. 

 

The example query above is a simple one. It selects a few of the fields in the table Students. It creates a new 

field called Name by concatenating (putting two of more values together to form a single text string) the 

fields LastName and FirstName. The results are filtered to show only the students in class A. The results are 

sorted in ascending alphabetical order on the field Name. (Since the field Class is restricted to just class A, 

the Sort Ascending command for the field Class does not actually change anything.)  

Datasheet View 
When you run the query, the results show in a datasheet, neatly in order and filtered and only the fields that 

you chose will show.  

 

SQL View 
Behind the Design View, shown above, is 

programming code in SQL (Structured Query 

Language). You can view and edit the actual 

query code, if you choose. Once you know how 

to write a query in SQL, it can be faster just to 

type simple queries yourself (if your fingers 

will type what your brain meant to type). 

Sometimes that is a big 'IF'! For the most of us, 

drag and drop is a great blessing! 


