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Microsoft Excel 2010

Excel is a spreadsheet program in the Microsoft Office system. You can use Excel to create and format workbooks (a
collection of spreadsheets) in order to analyze data and make more informed business decisions. Specifically, you can use
Excel to track data, build models for analyzing data, write formulas to perform calculations on that data, pivot the data in
numerous ways, and present data in a variety of professional looking charts.
Home Tab

 

Getting Started
Now that you have an understanding of where things are located, let's look at

the steps needed to create an Excel document.
Opening Outlook

You may have a shortcut to Word on your desktop, if so double click the icon
and Word will open. If not follow the steps below:

1. Click on the Start button 2. Highlight Programs
3. Highlight Microsoft Office 4. Click on Microsoft Excel 2010
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Excel 2010 information
 Available Columns: A through XFD - 16,384 columns
 Available Rows: 1 through 1,048,576
 There are over 17 billion cells in each worksheet!!!!
 A cell is the intersection of a column letter and a row number. The cell address can be found in the Name Box just

above column A.
Workbooks and Worksheets

 Each Excel file is a Workbook containing one or more Worksheets
Default setting provides you with three worksheets - you can add or remove as needed from there
    Worksheets can also be reordered within the file and renamed - you can also copy or move a worksheet to
      another workbook (file)
Several sheets can be used for one project, containing it all in one file, or you can still use one file for each part
      of a project, depending on your needs.

Column Sizing
On a worksheet, you can specify a column width of 0 (zero) to 255. This value represents the number of characters

that can be displayed in a cell that is formatted with the standard font. The default column width is 8.43 characters. If the
column width is set to 0, the column is hidden.

To quickly change column size:
1. Double click on the line between the column you want to size and the next column (You may do the same for rows)
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OR
1. Select the column or row you want to format
2. On the Home tab select the down arrow under Format in the Cells group and click AutoFit Column Width

Conditional Formatting
1. Select the cells where you want to apply the conditional formatting
2. On the Home tab, in the Styles group, select Conditional Formatting
3. Select the condition you want to use
4. Click Ok
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Highlight Cells Rules: Highlights cells from terms you set.

 

Example: Greater Than

 

Top/Bottom Rules: formats your cells to what you specify if the values fall in the top 10, bottom 10, top 10% and
bottom 10% of all values.

Data Bars, Color Scales and Icon Sets: Displays a colored bar graph, colored scale or icons relative to the data
in the cells.
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Conditional Formatting Rules
Creating a New Rule
1. Under Conditional Formatting, select New Rule
2. Select a rule type from the top of the box
3. Edit the rule in the bottom of the box

a. Change the format of the condition
b. Select if you want to display the bar (only available with the Data Bar option)
c. Change the type of information you want to use
d. Change the color of the bar

Clearing rules
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1. Click Conditional Formatting
2. Click Clear Rules and select which of the rules should be cleared

Subtotal
Total several rows of related data automatically
1. Highlight the data you want to subtotal
2. Select the Data tab, and in the Outline group > click

Subtotal
3. The Subtotal box will appear, make the appropriate

changes > Click Ok
a. Select where the subtotal change will occur
b. Select what function to use
c. Select the field for the subtotal

Example: In the example I've created a subtotal for sala-
ries for each change in rank.
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Graphics
Click the Insert Tab - Select an option in the Illustrations Group
 Picture: Select a picture from a file
 Clip Art: Select to insert graphic clips
 Shapes: Select readymade shapes
 Smart Art: Select to insert a graphic that helps to communicate information

Clip Art
1. Type in your search criteria in the Search for box.
2. Select the image you would like to use in your spreadsheet form the preview window.

Shapes
1. Click Shapes
2. Select the wanted shape
3. Draw the object on the

spreadsheet
  Hint: Click and drag with
   your mouse

Smart Art
1. Click SmartArt
2. Select the type of SmartArt

graphic you would like to use .
3. Click Ok     &   4. Fill in the

          text fields on the Smart Art.
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Formatting Spreadsheets
To further enhance your spreadsheet you can format a number of elements such as text, numbers, coloring, and table

styles. Spreadsheets can become professional documents used for company meetings or can even be published.
Wrap Text

You can display multiple lines of text inside a cell by wrapping the text. Wrapping
text in a cell does not affect other cells.

1. Click the cell in which you want to wrap the text.
2. On the Home tab, in the Alignment group, click Wrap Text.
3. The text in your cell will be wrapped.

Note : If the text is a long word, the characters won't wrap (the word won't be split); instead, you can widen the column
or decrease the font size to see all the text. If all the text is not visible after you wrap the text, you might have to
adjust the height of the row. On the Home tab, in the Cells group, click Format, and then under Cell Size click
AutoFit Row.

Format Numbers
In Excel, the format of a cell is separate from the data that is stored in the cell. This

display difference can have a significant effect when the data is numeric. For example,
numbers in cells will default as rounded numbers, date and time may not appear as antici-
pated. After you type numbers in a cell, you can change the format in which they are
displayed to ensure the numbers in your spreadsheet are displayed as you intended.

1. Click the cell(s) that contains the numbers that you want to format.
2. On the Home tab, in the Number group, click the arrow next to the
Number Format box, and then click the format that you want.

Cell Borders
By using predefined border styles, you can quickly add a border around cells or

ranges of cells. If predefined cell borders do not meet your needs, you can create a
custom border.

Note : Cell borders that you apply appear on printed pages. If you do not use cell bor-
ders but want worksheet gridline borders for all cells to be visible on printed
pages, you can display the gridlines.

Apply Cell Borders
1. On a worksheet, select the cell or range of cells that you want to add a border to,

change the border style on, or remove a border from.
2. Go to the Home tab, in the Font group
3. Click the arrow next to Borders
4. Click on the border style you would like
5. The border will be applied to the cell or cell range

Note : To apply a custom border style, click More Borders. In the Format Cells
dialog box, on the Border tab, under Line and Color, click the line style and
color that you want.

Remove Cell Borders
1. Go to the Home tab, in the Font group
2. Click the arrow next to Borders
3. Click No Border.

Note : The Borders button displays the most recently used border style. You can click
the Borders button (not the arrow) to apply that style.
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Cell Styles
You can create a cell style that includes a custom border, colors and accounting formatting.
1. On the Home tab, in the Styles group, click Cell Styles.
2. Select the different cell style option you would like applied to your spreadsheet.

Note : If you would like to apply a cell fill and a cell border, select the cell fill color first the ensure both formats are applied.

Charts in Excel
Microsoft Excel no longer provides the chart wizard. Instead, you can create a basic chart by clicking the chart type

that you want on the Insert tab in the Charts group. Charts are used to display series of
numeric data in a graphical format to make it easier to understand large quantities of data
and the relationship between different series of data.

To create a chart in Excel, you start by entering the numeric data for the chart on a
worksheet. Then you can plot that data into a chart by selecting the chart type that you want
to use on the Insert tab, in the Charts group. Worksheet data Chart created from worksheet data.

A chart has many elements. Some of these elements are displayed by default; others can
be added as needed. You can change the display of the chart elements by moving them to
other locations in the chart, resizing them, or by changing the format. You can also remove
chart elements that you do not want to display.

1. The chart area is the entire chart and all its  Elements.
2. The plot area is the area of the chart bounded by the axes.
3. The data points are individual values plotted in a chart rep-

resented by bars, columns, lines, or pies.
4. The horizontal (category) and vertical (value) axis along

which the data is plotted in the chart.
5. The legend identifies the patterns or colors that are assigned

to the data series or categories in the chart.
6. A chart and axis title are descriptive text that for the axis or chart.
7. A data label provides additional information about a data

marker that you can use to identify the details of a data point
in a data series.
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Create a Chart
1. On the worksheet, arrange the data that you want to plot in a chart. The data can be arranged in rows or columns

- Excel automatically determines the best way to plot the data in the chart.
2. Select the cells that contain the data that you want to use for the chart.

Note : If the cells that you want to plot in a chart are not in a continuous range, you can select nonadjacent cells or
ranges as long as the selection forms a rectangle. You can also hide the rows or columns that you do not want to
plot in the chart.

3. Go to the Insert tab, in the Charts.
4. Click the chart type, and then click a chart subtype from

the drop menu that will appear.
5. Click anywhere in the embedded chart to activate it. When

you click on the chart, Chart Tools will be displayed which
includes the Design, Layout, and Format tabs.

6. The chart will automatically be embedded in the worksheet. A chart name will automatically be assigned.
Move Chart to New Sheet

1. On the Design tab, in the Location group, click Move Chart.
2. Under Choose where you want the chart to be placed, click on the New sheet bubble .
3. Type a chart name in the New sheet box.
Change Chart Style
1. Click anywhere in the chart.
2. On the Design tab, in the Chart Styles group,

click the chart style that you want to use. To see
all predefined chart styles.

Chart or Axis Titles
To make a chart easier to understand, you can add titles, such as chart and axis titles.
To add a chart title:
1. Click anywhere in the chart.
2. On the Layout tab, in the Labels group, click Chart Title.
3. Click Centered Overlay Title or Above Chart.
4. In the Chart Title text box that appears in the chart, type the text that you want.
5. To remove a chart title, click Chart Title, and then click None.
To add axis titles:
1. Click anywhere in the chart.
2. On the Layout tab, in the Labels group, click Axis Titles.
3. Do one or more of the following:

a. To add a title to a primary horizontal (category) axis, click Primary Horizontal Axis Title, and then click the
    option that you want.
b. To add a title to primary vertical (value) axis, click Primary Vertical Axis Title, and then click the option that you want.

4. In the Axis Title text box that appears in the chart, type the text that you want.
5. To remove an axis title, click Axis Title, click the type of axis title to remove, and then click None.

Data Labels
1. On a chart, do one of the following:

a. Click on the chart area to add a data label to all data points of all data series
b. Click in the data series to add a data label to all data points of a data series
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c. Click on a specific data point to add a data label to a single data point in a data
    series

2. On the Layout tab, in the Labels group, click Data Labels, and then click the
display option that you want.

3. Text boxes will appear in the area of your chart based on your selection.
4. Click on the text box to modify the text.
5. To remove data labels, click Data Labels, and then click None.

Legend

When you create a chart, the legend appears, but
you can hide the legend or change its location after you
create the chart.
1. Click the chart in which you want to show or hide a
    legend.
2. On the Layout tab, in the Labels group, click Legend.
3. Do one of the following:

a. To hide the legend, click None.
b. To display a legend, click the display option that you want.
c. For additional options, click More Legend Options, and then select the display option

      that you want.

Formulas in Excel
Formulas are equations that perform calculations on values in your worksheet. A formula always starts with an equal

sign (=). An example of a simple is =5+2*3 that multiplies two numbers and then adds a number to the result. Microsoft
Office Excel follows the standard order of mathematical operations. In the preceding example, the multiplication operation
(2*3) is performed first, and then 5 is added to its result.

You can also create a formula by using a function which is a prewritten formula that takes a value, performs an
operation and returns a value. For example, the formulas =SUM(A1:A2) and SUM(A1,A2) both use the SUM function
to add the values in cells A1 and A2.

Depending on the type of formula that you create, a formula can contain any or all of the following parts.
Functions - A function, such as PI() or SUM(), starts with an equal sign (=).
Cell references - You can refer to data in worksheet cells by including cell references in the formula. For example, the

cell reference A2 returns the value of that cell or uses that value in the calculation.
Constants - You can also enter constants, such as numbers (such as 2) or text values, directly into a formula.
Operators - Operators are the symbols that are used to specify the type of calculation that you want the formula to

perform.
Create Simple Formulas
1. Click the cell in which you want to enter the formula.
2. Type = (equal sign).
3. Enter the formula by typing the constants and operators that you

want to use in the calculation.
Create a Formula with Cell References

The first cell reference is B3, the color is blue, and the cell range has a
blue border with square corners. The second cell reference is C3, the color is green, and the cell range has a green border
with square corners.
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To create your formula:
1. Click the cell in which you want to enter the formula.
2. In the formula bar, at the top of the Excel window that you use, 

type = (equal sign).
3. Click on the 1st cell you want in the formula.
4. Enter an Operator such as +, or *.
5. Click on the next cell you want in the formula. Con-

tinue steps 3 - 5 until the formula is complete
6. Hit the ENTER key on your keyboard.

Use Auto Sum
To summarize values

quickly, you can also use
AutoSum.
1. Select the cell where you would like your formulas solution to appear.
2. Go to the Home tab, in the Editing group,
3. Click AutoSum, to sum your numbers or click the arrow next to AutoSum to select a
    function that you want to apply.

Create a Formula with Function
1. Click the cell in which you want to enter the formula.
2. Click Insert Function on the formula bar. Excel inserts

the equal sign (=) for you.
3. Select the function that you want to use.

Note : If you're not sure which function to use, type a ques-
tion that describes what you want to do in the Search
for a function box (for example, "add numbers" re-
turns the SUM function), or browse from the catego-
ries in the Or Select a category box.

4. Enter the arguments.
5. After you complete the formula, press ENTER .

Example of Various Excel's Functions
Excel's Text Functions
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Excel's Date Functions
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Excel's Time Functions

Excel's Math Functions
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Excel's Trigonometric Functions
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Excel's Statistical Functions
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Excel's Logical Functions

Excel's Lookup Functions

Excel's Information Functions
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Excel's Table Functions

Delete a Formula
When you delete a formula, the resulting values of the formula is also deleted. However, you can instead remove the

formula only and leave the resulting value of the formula displayed in the cell.
To delete formulas along with their resulting values, do the following:
1. Select the cell or range of cells that contains the formula.
2. Press DELETE.
To delete formulas without removing their resulting values, do the following:
1. Select the cell or range of cells that contains the formula.
2. On the Home tab, in the Clipboard group, click Copy .
3. On the Home tab, in the Clipboard group, click the arrow below Paste , and then click Paste Values.

Hide Rows or Columns
1. Select the rows or columns that you want to hide.
2. On the Home tab, in the Cells group, click Format.
3. Under Visibility, point to Hide & Unhide, and then click Hide Rows or Hide Columns.
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Note : You can also right-click a row or column (or a selection of multiple rows or
columns), and then click Hide.

Unhide Rows or Columns
1. Select the rows, columns or entire sheet to unhide.
2. On the Home tab, in the Cells group, click Format.
3. Under Visibility, point to Hide & Unhide, and then click Unhide Rows or

Unhide Columns.
TIP : You can also right-click the selection of visible rows and columns sur-

rounding the hidden rows and columns, and then click Unhide.
Sort Data in Single Column

1. Select a column of data in a range of cells
2. On the Data tab, in the Sort & Filter group,
    do one of the following:

 To sort in ascending or smallest to largest order, click Sort A to Z.
     To sort in descending or largest to smallest order, click Sort Z to A.

3. To reapply a sort after you change the data, click a cell in the range or table and then, on the Data tab, in the Sort
& Filter group, click Reapply.

Sort Data in Multiple Columns or Rows
You may want to sort by more than one column or row when you have data that you want to group by the same value

in one column or row, and then sort another column or row within that group of equal values.
1. Select a range of cells with two or more columns of data.

2. On the Data tab, in the Sort & Filter group, click Sort.
3. The Sort dialog box will appear.
4. Under Column, in the Sort by box, select the first column that you want to sort.
5. Under Sort On, select the type of sort. To sort by text, number, or date and time, select Values. To sort by format,

select Cell Color, Font Color, or Cell Icon.
6. Under Order, select how you want to sort. For text values, select A to Z or Z to A. For number values, select

Smallest to Largest or Largest to Smallest.  For date or time values, select Oldest to Newest or Newest to
Oldest. To sort based on a custom list, select Custom List.

7. To add another column to sort by, click Add Level, and then repeat steps four through six.
8. To copy a column to sort by, select the entry and then click Copy Level.
9. To delete a column to sort by, select the entry and then click Delete Level.
10. To change the order in which the columns are sorted, select an entry and then click the Up or Down arrow to

change the order.
11. To reapply a sort after you change the data, click a cell in the range or table and then, on the Data tab, in the Sort

& Filter group, click Reapply.
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Freezing Rows or Columns
When you need to keep the top row or left column in view as you work with a large amount of data, you can Freeze

it so it's always visible on the screen (note - this does not affect printing).
1. Go to View/Freeze Panes
2. Select either Freeze Top Row (freezes row 1) or Freeze First Column (freezes column A)

To unfreeze, select Unfreeze Panes
Finalizing a Spreadsheet

To complete your spreadsheet there are a few steps to take to ensure your document is finalized.
Using the "Spell Check" Feature

Excel does not have the same spell check feature as Word
and PowerPoint. To complete a Spelling and Grammar check,
you need to use the Spelling and Grammar feature.

1. Click on the Review tab.
2. Click on the Spelling & Grammar command (a blue

check mark with ABC above it).
3. A Spelling and Grammar box will appear, correct any

Spelling or Grammar issue with the help of the box.
Save a Spreadsheet

To save a document in the format used by Excel 2010
and Excel 2007, do the following:

1. Click the File tab.
2. Click Save As.
3. In the File name box, enter a name for your document.
4. Click Save.
To save a document so that it is compatible with Excel 2003 or earlier, do the following:
1. Click the File tab.
2. Click Save As.
3. In the Save as type list, click Excel 97-2003 Document. This changes the file format to .xls.
4. In the File name box, type a name for the document.
5. Click Save.

Headers and Footers
A header is a section that appears at the top of

every printed page; footer is a section that appears
at the bottom of every printed page. To create a
header or footer in Excel, you display the Insert
tab and then, in the Text group, click Header &
Footer to display the Header & Footer Tools De-
sign contextual tab.

When you display your workbook's headers
and footers, Excel displays the workbook in Page
Layout view. Page Layout view shows you exactly
how your workbook will look when printed, while
still enabling you to edit your file, a capability not
provided by Print Preview. You can also switch to
Page Layout view by displaying the View tab and
then, in the Workbook Views group, clicking Page
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Layout. Excel divides its headers and footers into left, middle, and right sections. When you point to an editable header or
footer section, Excel highlights the section to indicate that clicking the left mouse button will open that header or footer
section for editing.
Print Preview

Print Preview automatically displays when you click on the Print tab. Whenever you make a change to a print-related
setting, the preview is automatically updated.

1. Click the File tab, and then click Print. To go back to your document, click the File tab.
2. A preview of your document automatically appears. To view each page, click the arrows below the preview.

Print a Worksheet
1. Click the worksheet or select the worksheets that you want to print.
2. Click File.
3. Click Print.
4. Once you are on the Print screen you can select printing options:

To change the printer, click the drop-down box under Printer,
    and select the printer that you want.
To make page setup changes, including changing page
    orientation, paper size, and page margins, select the options
    that you want under Settings.
To scale the entire worksheet to fit on a single printed page,
    under Settings, click the option that you want in the
    scale options drop-down box.
To print the specific information, select Print Active Sheets or
    Print Entire Workbook

5. Click Print.
Help

If you need additional assistance when completing your document you can use the help feature.

1. Click on the blue circle with the white question mark  command

2. A Help box will appear.
3. Click in the Search Help textbox and type what you need help with
4. Click the magnifying glass next to the text box and the possible solutions will appear.

Goal Seek
To use Goal Seek, you display the Data tab and then, in the Data Tools group,

click What-If Analysis. On the menu that is displayed, click Goal Seek to open the
Goal Seek dialog box.

 In the dialog box, you identify the cell with the target value; in this example, it is
cell C4, which has the percentage of costs accounted for by the Labor category.
The To Value field has the target value (.2, which is equivalent to 20 percent), and
the By Changing Cell field identifies the cell with the value Excel should change to
generate the target value of 20 percent in cell C4. In this ex-
ample, the cell to be changed is C3. Clicking OK tells Excel
to find a solution for the goal you set. When Excel finishes its
work, the new values appear in the designated cells, and the
Goal Seek Status dialog box opens.

Goal Seek finds the closest solution it can without ex-
ceeding the target value. In this case, the closest percentage it
could find was 19.97 percent. In this exercise, you'll use Goal
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Seek to determine how much you need to decrease transportation costs so those costs make up no more than 40 percent
of Consolidated Messenger's operating costs.

1. On the Data tab, in the Data Tools group, click What-If Analysis and then, in the list, click Goal Seek.
The Goal Seek dialog box opens.
2. In the Set cell field, type D4.
3. In the To value field, type .4.
4. In the By changing cell field, type D3.
5. Click OK.

Excel displays the solution in both the worksheet and the Goal Seek Status dialog box.

 6. Click Cancel.
Excel closes the Goal Seek Status dialog box without saving the new worksheet values.

Solver
Goal Seek is a great tool for find-

ing out how much you need to change
a single input value to generate a de-
sired result from a formula, but it's of
no help if you want to find the best mix
of several input values. For example,
marketing vice president Craig Dewar
might want to advertise in four national
magazines to drive customers to Con-
solidated Messenger's Web site, but he might not
know the best mix of ads to reach the greatest num-
ber of readers. He asked the publishers for ad pric-
ing and readership numbers, which he recorded in a
spreadsheet, along with the minimum number of ads
per publication (three) and the minimum number of
times he wants the ad to be seen (10,000,000).

If you performed a complete installation when
you installed Excel on your computer, you see the
Solver button on the Data tab in the Analysis group.
If not, you need to install the Solver Add-In. To do
so, click the File tab, and then click Options. In the
Excel Options dialog box, click Add-Ins to display
the Add-Ins page. At the bottom of the dialog box,
in the Manage list, click Excel Add-Ins, and then
click Go to display the Add-Ins dialog box. Select
the Solver Add-in check box and click OK to install
Solver.

After the installation is complete, Solver appears
on the Data tab, in the Analysis group. Clicking Solver
displays the Solver Parameters dialog box.
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The first step of setting up your Solver problem is to identify the cell that contains the summary formula you want to
establish as your objective. To identify that cell, click in the Set Objective box, click the target cell in the worksheet, and
then select the option representing whether you want to minimize the cell's value, maximize the cell's value, or make the cell
take on a specific value. Next, you click in the By Changing Variable Cells box and select the cells Solver should vary to
change the value in the objective cell. Finally, you can create constraints that will set the limits for the values Solver can use.
To do so, click Add to open the Add Constraint dialog box.

You add constraints to the Solver problem by selecting the cells to which you want to apply the constraint, selecting the
comparison operation (such as less than or equal to, greater than or equal to, or must be an integer), and clicking in the
Constraint box to select the cell with the value of the constraint. You could also type a value in the Constraint box, but
referring to a cell makes it possible for you to change the constraint later without opening Solver.

In this exercise, you'll use Solver to determine the best mix of ads given the following constraints:
 You want to maximize the number of people who see the ads.
 You must buy at least 8 ads in 3 magazines and at least 10 in the fourth.
 You can't buy part of an ad (that is, all numbers must be integers).
 You can buy no more than 20 ads in any one magazine.
 You must reach at least 10,000,000 people.
 Your ad budget is $3,000,000.

PivotTables
With Excel worksheets you can gather and present

important data, but the standard worksheet can't be
changed from its original configuration easily. As an
example, consider a worksheet that records monthly
package volumes for each of nine distribution centers
in the United States.

 In this dialog box, you verify the data source for
your PivotTable and whether you want to create a
PivotTable on a new worksheet or an existing
worksheet. After you click OK, Excel displays a new
or existing worksheet and displays the PivotTable Field
List task pane.

If the PivotTable Field List task pane isn't visible, you can display it by clicking any
cell in the PivotTable to display the PivotTable Tools contextual tabs. On the Options
contextual tab, in the Show/Hide group, click Field List.

To assign a field, or column of data, to an area of the PivotTable, drag the field header
from the Choose Fields To Add To Report area at the top of the PivotTable Field List
task pane to the Drag Fields Between Areas Below area at the bottom of the task pane.
For example, if you drag the Volume field header to the Values area, the PivotTable
displays the total of all entries in the Volume column.
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To pivot a PivotTable, you drag a field header to a new position in the PivotTable Field List task pane. As you drag a
field within the task pane, Excel displays a blue line in the interior of the target area so you know where the field will appear
when you release the left mouse button. If your data set is large or if you based your PivotTable on a data collection on
another computer, it might take some time for Excel to reorganize the PivotTable after a pivot. You can have Excel delay
redrawing the PivotTable by selecting the Defer Layout Update check box in the lower-left corner of the PivotTable Field
List task pane. When you're ready for Excel to display the reorganized PivotTable, click Update.
Macro

Instead of going through a lengthy series of steps to highlight the cells with the important information, you can create a
macro, which is a recorded series of actions, to perform the steps for you. After you have created a macro, you can run,
edit, or delete it as needed. In Excel, you run and edit macros by using the items available in the Macros group on the View
tab. You can make your macros easier to access by creating new buttons on the Quick Access Toolbar, to which you can
assign your macros.
Creating and Modifying Macros

The first step of creating a macro is to plan the process you want to automate. Computers today are quite fast, so
adding an extra step that doesn't affect the outcome of a process doesn't slow you down noticeably, but leaving out a step
means you will need to re-record your macro. After you plan your process,
you can create a macro by clicking the View tab and then, in the Macros
group, clicking the Macros arrow. In the list that appears, click Record Macro.
When you do, the Record Macro dialog box opens.

 After you type the name of your macro in the Macro Name box, click
OK. You can now perform the actions you want Excel to repeat later; when
you're done, in the Macros list, click Stop Recording to add your macro to the
list of macros available in your workbook.

To modify an existing macro, you can simply delete the macro and re-
record it. Or if you just need to make a quick change, you can open it in the
Visual Basic Editor and add to or change the macro's instructions. To delete a macro, open the Macro dialog box, click the
macro you want to delete, and then click Delete.
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